Jump to content

mastana

Assertion failed: ARRAY_COUNT[CompareName]

Recommended Posts

Assertion failed: ARRAY_COUNT[CompareName]

Good morning,

I have this message when I want to join a game:

Quote

Assertion failed: ARRAY_COUNT[CompareName] = =
ARRAY_COUNT[JumpURL]
[File:H:\Trunk\Engine\Source\Runtime\Engine\Privrate\UnrealEngine.cpp]
[Line: 9505]

I bought the game yesterday, no mods, verified the files, uninstalled, deleted the game folders, launched as admin, checking and unchecking the DLCs on steam, basically tried everything I found on the steam community forums... bought the season pass to see if it would change something, nothing.

After hours of trying things, I now have the "old maps" working, what I noticed is it crashes only when loading the maps: Valguero, Ragnarok and The Center, the other maps (like the Island) works fine, any idea? Thanks in advance for you help.

 

Share this post


Link to post
Share on other sites
On 8/11/2019 at 8:19 PM, mastana said:

Assertion failed: ARRAY_COUNT[CompareName]

Good morning,

I have this message when I want to join a game:

I bought the game yesterday, no mods, verified the files, uninstalled, deleted the game folders, launched as admin, checking and unchecking the DLCs on steam, basically tried everything I found on the steam community forums... bought the season pass to see if it would change something, nothing.

After hours of trying things, I now have the "old maps" working, what I noticed is it crashes only when loading the maps: Valguero, Ragnarok and The Center, the other maps (like the Island) works fine, any idea? Thanks in advance for you help.

 

Known issue, especially when it starts to display server lists and when you change your filter.

For favorites, I have removed the servers from steam. You will need to know how to bring up steam and see your favorite servers listed there. This seems to temporarily fix it. But it would be nice if WildCard actually fixed this error once and for all. As this has been going on now for 4 years.

Share this post


Link to post
Share on other sites

To add to this issue, none of the aforementioned solutions help.  This actually isn't an issue at all with server selection etc.

I have done all of the steps as well, and I go try to load the center map in single player and I get the same crash, before I even leave the menu UI.

About to ask for a refund, how in the world can a crasher like this exist in this day and age?

Share this post


Link to post
Share on other sites
On 1/25/2020 at 1:56 AM, CyberAngel67 said:

FYI, this error occurs on any of the maps (Official or not and all installed)

I have never had that error on already properly installed map. But shows up instantly if i am missing a map that i am trying to connect to.

Share this post


Link to post
Share on other sites
56 minutes ago, Luewen said:

I have never had that error on already properly installed map. But shows up instantly if i am missing a map that i am trying to connect to.

You are correct, the specific assertion discussed in that thread happens when you attempt to load a map you don't have. The assertion for the issues @CyberAngel67 is referencing is Assertion failed: (Index >= 0) & (Index < ArrayNum).

  • Facepalm 1

Share this post


Link to post
Share on other sites
22 hours ago, invincibleqc said:

You are correct, the specific assertion discussed in that thread happens when you attempt to load a map you don't have. The assertion for the issues @CyberAngel67 is referencing is Assertion failed: (Index >= 0) & (Index < ArrayNum).

Yah, but the op is having the exact same error that is discussed on the steam thread linked. Its not the error his referencing to. And those 2 errors are not linked per se.

Share this post


Link to post
Share on other sites

As I said, you are correct and CyberAngel67 is wrong. The "Assertion failed: ARRAY_COUNT[CompareName] = = ARRAY_COUNT[JumpURL]" happens when you attempt to join a map you don't own. If the cause was the issues CyberAngel67 referred, then OP would get "Assertion failed: (Index >= 0) & (Index < ArrayNum)" instead.

  • Facepalm 1

Share this post


Link to post
Share on other sites
16 minutes ago, invincibleqc said:

As I said, you are correct and CyberAngel67 is wrong. The "Assertion failed: ARRAY_COUNT[CompareName] = = ARRAY_COUNT[JumpURL]" happens when you attempt to join a map you don't own. If the cause was the issues CyberAngel67 referred, then OP would get "Assertion failed: (Index >= 0) & (Index < ArrayNum)" instead.

And you are also wrong.

The error message I was thinking about is different to the original one listed here, but it certainly is not the error message you have suggested either. But when Ark boots up from the error message I thought, I do see this exact message when Ark first starts and it takes about 5-10 of these crashes before it comes good.

So while the error I had mentioned is actually the following, I do still see this same message after this error when Ark hits the first menu screen after this error. Especially when Ark thinks your net speed/bandwidth is not enough to play the game, have I seen the error reported in this post.

 

Fatal error!

VERSION: 287.123
ShooterGame.exe!UCanvasPanel::`vftable'() (0x00007ff6c8706210) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c93ef9f) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c9466fa) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1cfd85f7) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c943d6d) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c94083e) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1cdd823a) + 0 bytes [UnknownFile:0]
steam_api64.dll!UnknownFunction (0x000000006c8456c4) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FOnlineAsyncTaskManagerSteam::OnlineTick() (0x00007ff6c7b3c049) + 0 bytes [f:\build\trunk\engine\source\runtime\online\onlinesubsystemsteam\private\onlineasynctaskmanagersteam.cpp:130]
ShooterGame.exe!FOnlineAsyncTaskManager::Run() (0x00007ff6c69522c9) + 0 bytes [f:\build\trunk\engine\source\runtime\online\onlinesubsystem\private\onlineasynctaskmanager.cpp:65]
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff6c641d4d6) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff6c641d398) + 8 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
KERNEL32.DLL!UnknownFunction (0x00007fff66da3034) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff68d51471) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff68d51471) + 0 bytes [UnknownFile:0]

  • Thanks 1

Share this post


Link to post
Share on other sites
23 hours ago, CyberAngel67 said:

And you are also wrong.

The error message I was thinking about is different to the original one listed here, but it certainly is not the error message you have suggested either. But when Ark boots up from the error message I thought, I do see this exact message when Ark first starts and it takes about 5-10 of these crashes before it comes good.

So while the error I had mentioned is actually the following, I do still see this same message after this error when Ark hits the first menu screen after this error. Especially when Ark thinks your net speed/bandwidth is not enough to play the game, have I seen the error reported in this post.

 

Fatal error!

VERSION: 287.123
ShooterGame.exe!UCanvasPanel::`vftable'() (0x00007ff6c8706210) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c93ef9f) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c9466fa) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1cfd85f7) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c943d6d) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1c94083e) + 0 bytes [UnknownFile:0]
steamclient64.dll!UnknownFunction (0x00007fff1cdd823a) + 0 bytes [UnknownFile:0]
steam_api64.dll!UnknownFunction (0x000000006c8456c4) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FOnlineAsyncTaskManagerSteam::OnlineTick() (0x00007ff6c7b3c049) + 0 bytes [f:\build\trunk\engine\source\runtime\online\onlinesubsystemsteam\private\onlineasynctaskmanagersteam.cpp:130]
ShooterGame.exe!FOnlineAsyncTaskManager::Run() (0x00007ff6c69522c9) + 0 bytes [f:\build\trunk\engine\source\runtime\online\onlinesubsystem\private\onlineasynctaskmanager.cpp:65]
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff6c641d4d6) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff6c641d398) + 8 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
KERNEL32.DLL!UnknownFunction (0x00007fff66da3034) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff68d51471) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff68d51471) + 0 bytes [UnknownFile:0]

That is an error message that pops up also when you get dced from making too complicated custom painting since the painting custom templates broke.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...