Jump to content

Recommended Posts

We don't know yet.

I, personally, am guessing that it has something to do with getting it wet or near water since they said that it's weaker while under those conditions.

My second guess is that you have to go lava diving for eggs.

  • Like 1

Share this post


Link to post
Share on other sites

My best guess would be that you would have to steal it's eggs. It kinda resembles a rock drake to me. So that would be my logic. But like @TinyHippo said, you will never know until they release Genesis (which unfortunately got delayed to February 25). 

They might make a special way of taming it to where you have to lead it to water to weaken it in order to deal torpor. Or maybe we'll have to leave it with a certain percentage of health in order to deal torpor? We don't know.

To the moment it's just guesswork. But I personally think my first method is the most likely.

Share this post


Link to post
Share on other sites
50 minutes ago, IanHighlander said:

Lava diving? Now that sounds fun, if only... 😂

>Thinking lava diving is in the 'if only' category

The magmasaur saddle will let us dive in lava without taking damage. Lava diving is all but confirmed. The only question is whether or not the magmasaur is the only way to do it.

Share this post


Link to post
Share on other sites

hey guys my magmasour did not teleport with me from the arctic nw to volcanic east, it is not the glitch where they are invisible and you need to re-log already tried this. i have looked through all of the arctic on my blood stalker can anyone help me? it is not mess deleted or it would say in tribe logs that it was killed by mesh detection also it has not died yet...

WILD CARD PLEASE FIX TELEPORTS.  also has anyone had this glitch and did you get it back. also if so how.

Share this post


Link to post
Share on other sites
16 hours ago, bill765 said:

hey guys my magmasour did not teleport with me from the arctic nw to volcanic east, it is not the glitch where they are invisible and you need to re-log already tried this. i have looked through all of the arctic on my blood stalker can anyone help me? it is not mess deleted or it would say in tribe logs that it was killed by mesh detection also it has not died yet...

WILD CARD PLEASE FIX TELEPORTS.  also has anyone had this glitch and did you get it back. also if so how.

This happens fairly often. Two ways I get it back, one ill whistle follow all even if I can't see it then go out of render so whatever has my mag snagged will let it go. Sometimes you have to tp back to where you were when it disappeared i.e if I tp to ocean east and its not there I'll leave render and tp back to ocean east. If still not there, then I'll whistle follow all and slowly leave render tp back to ocean east then retrace the path I left render. Normally it'll be there or it'll follow you outta render. My guess is while the dino is there sometimes tp doesn't fully reassemble the dinos render. Hope it helps and hopefully gets patched soon so we won't have to worry about it at all lol.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...