Jump to content

Admin / Trusted Player Tool - Game Save Visualiser


Recommended Posts

2 minutes ago, ANewHome said:

1. Regarding the abandoned structures - the tribe profiles are there in the server directory .

2. It is the overview that is displaying incorrectly - if you go to the ‘tamed’ creatures list it does not show them as abandoned.

3. In addition it’s not showing all tribes where I know that tribe files exist in the directory.  The previous version before the tribe detection changes shows them up - the new version does not.


I'll need your game data and examples to investigate.


Not sure what you mean by this one?  In maps I have with missing .arktribe AND .arkprofile data the abandoned tames are listed when you select [ASV Abandoned] it shows them tames in the list as expected?  

Unless you mean you can't see "ASV Abandoned" as the Tamer/Imprinter when selecting "All Tribes / All Creatures"?  That's by design, it shows the original names where available and if you use copy commands it will also use the original linked tribeid for you to clean up map structures and such.


New ASV no longer reads ALL .arktribe files unless it can first detect player, tame or structure for that player/tribe in the .ark file. Previous version read in ALL .arktribe and .arkprofile files - which made it slower and wasn't needed as them players / tribes were no longer relevant in the game.

Im currently working on reading in the appropriate .arkprofile files too to get mission scores and some character data (Gender).

Link to comment
Share on other sites

This is an example, with what I am seeing from the data.

It was previously helpful to read all the .arktribe files - as it helped identify tribes that had been to the map and do have a tribe on that map - but they dont have structures or tames on the map.   This was really helpful in the past to identify which tribe files could be safely deleted - these people do not have players on that map (right now), structures or tames.


All the file dates on the .arktribe are from the 25/06/2021 -> 19/06/2021.


The 'ASV Abandoned is showing 2 tames' - however when going into the drill down for tamed creatures it shows none.



Missing Tribes.jpg

Edited by ANewHome
Highlight tribes correctly.
Link to comment
Share on other sites

Image 1 - New ASV just doesn't work like that anymore.  If there is no reference to them tribes/players - ie. no structures, players or tames then it won't read them in.  I'll investigate adding a config option to the settings page to force them to be included.

Image 2 - Tames actually belong to a tribe, not a player.  The player list is only to narrow down the tribe if you know the player and not the tribe name.  ASV Abandoned tames have no link back to the player, only the original tribe id, so no reason to list players of that tribe.  This shows tames on mine - not sure why it doesn't on yours.. maybe they are in cryo?


hmm, thinking about it - how can something be abandoned, but in cryo.  That cryo has to belong to somebody still on the server.  I'll investigate that one after work.

Edited by MirageUK
  • Thanks 1
Link to comment
Share on other sites

Same issue others are experiencing @Rattgtg - I was trying to do things using shortcuts - thinking that the player data available in the .ark file was enough to identify things.  Turns out some players in the .ark file have weird NetId that then causes ASV to crash attempting to find that matching .arkprofile file.

I'm in the middle of re-writing it to work similar to how the old version worked, reading data from .arkprofiles first, then the .ark file.

Hopefully have you an update out this evening but busy playing atm.

  • Thanks 2
Link to comment
Share on other sites

Version available.



  • Re-worked the way it loads tribes/players so that information is now available even if they are no longer actively playing the map.
  • Fixed the issue reported by @Rattgtg and @Larkfields by re-working as above.

FYI I'll be adding support for Lost Island in a release later today.


  • Thanks 1
Link to comment
Share on other sites

Seems to be having problems loading content, waited 20 minutes for it and nothing. So i started over and currently have been waiting 10 minutes, still says loading content and the program says not responding

Update: 20 minutes in, pretty sure its not working 

stepped out but left it running opening my gen2



Edited by Rattgtg
1694 seconds
Link to comment
Share on other sites

1 hour ago, Milsurp said:

Hey Mirage, this tool looks great and I wanted to use it to troubleshoot a problem, but it appears you have a crashed website atm. Just wanted to let you know.

I've taken down the files for now until I fix the issues.  Currently testing against all data I have but looking promising - hopefully have an update out in the next hour.

Link to comment
Share on other sites

Version available.




  • Support for mod map Lost Island


  • Once again re-worked the way it loads up tribe and player data. Hopefully no further issues to be found.
  • Actually made the tribe/player lookups work properly in Tame and Player Structure tabs.
Edited by MirageUK
Link to comment
Share on other sites

1 minute ago, Rattgtg said:

seeing some long load times, been like 15-30 sec load times and with the last version 352 seconds to load gen2

Yeah - I will see what I can do with a performance pass once I've got a stable release working with the alternate toolkit.

It now loads EVERY single .arkprofile file to build up the basic tribe information, then identifies players in .ark that don't have a matching .arkprofile and if they have a .arktribe it loads the appropriate tribe information (logs etc.)

Previously I was doing it in reverse - but had issues matching up some .arktribe/.arkprofile data - so reverted to the way the old toolkit used to do things by loading every .arkprofile now.  This obviously adds to the loading speed but ultimately should improve accuracy of tribe and player data.

Also - the new toolkit previously mis-identified cryo/vivarium tame tribe and location data - so some time has been added for matching them up and fixing that.

FYI on my machine, using your last provided copy of Gen 2 data it loads up in 110-120 seconds.

Link to comment
Share on other sites

@BoRGaMeS - thank Google translate.  I was able to work out what you were asking, and find the download link, to reproduce your issue.

It seems you have some .arkprofile that doesn't have valid data.  No character stats or character config properties.

I will debug and add a check around that section to ensure the data continues to load.

Edited by MirageUK
Link to comment
Share on other sites

Version now available.



  • Removed the massive performance hit caused by my de-dupe code on players.  @Rattgtg
  • Added checks to ensure .arkprofile data is valid before attempting to read it in. @BoRGaMeS
Edited by MirageUK
  • Like 2
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...