Jump to content

Toni

Members
  • Content Count

    1,192
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Toni

  1. +1 First fix breeding / mating issues first: - Dinos do not wanna mate even if they are ready (about 50% do not work at the moment) - Wrong mating-timers when taking dinos out of cryos (vanilla x1 instead of what we configured in our Game.ini for MatingIntervalMultiplier) Nobody cares about events/rates if the functions for which this rates would be helpful do not work.
  2. You can use customdynamicurl=not_needed_because_its_buggy. There is an other way to get that working!!! Reason why it doesn't work: - It always checks arkdedicated.com/dynamicconfig.ini instead of what you configure. How to solve/workaround this unfinished/buggy thing: - On your webserver, name the file dynamicconfig.ini and place it in the root directory - Ensure that this dynamicconfig.ini can be called by http. (https or redirects do not work). So --> http://yourdomain.com/dynamicconfig.ini must be callable and must stay on http. - Edit your hosts file (Google if you d
  3. I don't use rawSockets (Because of the long waiting time for players to be able to join the server again --> if they had a crash/disconnect. This is a still not solved bug). But yeah, the question i asked above is exactly that? have they enabled rawSocket per default? One of WC should simply give a statement, so we know whats going on and what needs to be changed on our side.
  4. Can Wildcard please give a statement to this? What exactly was changed on network side of the servers? What does private server owners need to change? Have you enabled rawSockets per default now? Do the servers now need 4 Ports (Game / Query / Query 2 / Rcon) instead of 3 (Game / Query / Rcon)?
  5. - Disable Dino Decay (they will die of starvation some time...so decay not needed for dinos). - Login and wait 1 minute (render all things) is not enough. ---> Stay some minutes (i always doing it for 10 minutes) in your base to let the timers being updated (this isn't directly done on rendering by the server!)
  6. I can't confirm that! - First, ARK uses 2 Cores/Threads ... 1 for all the main calculations / 1 for networking Things. ....So if you only give 1 Core/Thread, it has to calculate the network parts on the same CPU where all the other calculations run too. - Second. Windows auto assignment of cores doesn't work as good as manually set it with affinity. If for example there is a load of 20% on one core caused by windows... for windows its fine to place the ARK server there too because 80% is still free. If you place the ARK servers manually, they will use at least 50% on that
  7. its a known problem since 4 years... and will be like 90% of all other bugs never been fixed. (The same for all the explorer notes. I do not even start to collect them since it always gets deleted some time..).
  8. Do you invite people to your birthday party without giving them something to food and drink? Thats exactly what you done with this post.... Please next time use the time to fix bugs instead of creating such a senseless post (For example the "buffer overflow" while traveling with max slots equipped. ). There is still many more important things to do instead of writing such posts.
  9. The event isn't working on private servers! Not even by adding the commandline (Which shouldn't be necessary for all the official maps). We don't see any mounds at all. Please fix.
  10. Some technical questions: - How often does the programm poll the ARK servers via RCON? (get chatlog) (I'm sure it does because ARK still has no websocket support) - Where does this exe store the chat log locally and in which format? (json, sqlite, ?) (I'm sure it stores it because the program has to know if a message was already broadcasted to the other servers or not).
  11. Would be nice if you can switch from dropbox to GitHub (We wanna see the program-code / config-files / screenshots / documentation and so on before we download something). Your program looks very nice.. but since its an .exe, i have to setup isolated windows and ARK servers to test if this thing is really doing what it should do I personally do not add my Rcon credentials to a program for which i don't know what it really/exactly does So it would be nice if you can add a bit more transparency to your program (The best would be nodejs because lightwight, fully transparent, crosspl
  12. I can't answer your question, but i can give you some other options. If this this dinos / structures / items are lost because they leaved the tribe (Mostly happens when they are merging tribes in a wrong way), then you can use this command to add the members back to the tribe: https://ark.gamepedia.com/Console_Commands#ForcePlayerToJoinTargetTribe This command mostly solves such problems. But i don't know the exact situation you have on your server.
  13. Use this parameters: -p -s --pretty-printing --items long --creatures --structures --bases I think your problem is caused by --tribeless Edit: And use -Xmx4G because 2G isn't enough if you have big savefiles.
  14. Here is what you gave us with the new turrets wildcard: https://clips.twitch.tv/ShinyStupidSquirrelCeilingCat Once more an absolutely untested thing? Where is the final tweaking you talked about?
  15. 27th is over... where is the turret? May we expect delays on Aberration too? Again behind the timeline?
  16. Update on this topic: Its running much better now. It doesn't create additional CPU load anymore. They have silently changed something without saying it in the patch notes. The servers performance (fps) generally is a bit better with UDP. So i change my recommendation now to "Use ?bRawSockets"
  17. The best example to measure the actual binary flatfile savesystem is --> Move some items into the cluster. Is the performance nice there? No it isn't. Would an SQL be way faster by adding/removing some items? --> For sure An other example --> Wild dino wipes --> Now generates a timeout for about 60 seconds. How long would a database have to DELETE * from wilddinos; ? A few milliseconds....not 60 seconds! Maybe your right in general. But the actual state of the game shows that the implementation of this binary saves is very inperformant.
  18. Have a look at Conan Exiles (Using SQLite Database)... no save lagg, no inventory transfer lagg, Backups all 3 Minutes. So before you post something... have a look like other developers done it with the Unreal Engine... instead of posting what your personal opinion is. We all know --> Autosave = lagg We all know --> Transfering many single items = Freeze on client We all know --> Wild dino wipes = server doesn't respond for a minute We all know --> Transfering items into the ARK Data is very slow and you can't transfer several items at once All
  19. You can't unmod them. A mod dino is an other type of dino than a non mod dino. Thats exactly the reason why you shouldn't use flyer mods. Better wait till the speed is coming back in vanilla (Confirmed for the TLC dino pass).
  20. Thats the reason why i don't use this wild dino wipe at restart function. Changing the savefile while starting is really really risky. For example if there would be a crash at startup (Like we had last weekend with Ragnarok), then its destroying your savefile because it is changing it at startup. Here is the reason for the servers "downtime" / "no-response" The problem is based on the save system of ark (Like i already reported 1000 times for other problems...And already posted a solution because Conan Exiles has a solution for it with the UE ! They key-word is SQLite Da
  21. - auto-destruction is executed when you restart the server, so this souldn't affect the servers performance while running. - Wild dino wipes are the same as ever on The Island, The Center and Scorched Earth. Only Ragnarok has more than 60 seconds freeze and therefore all players get kicked. (If you have 20 minutes, then for sure something with your server is not ok)
  22. Newest example: Many admins with the S+ Mod have corrupted saves and can't startup their servers. (Exactly on the map where i said bRawSocket has a Problem with the Save Files -> Ragnarok). I don't have this crashes/corrupted files on my servers. (Maybe because i gone back to TCP) So there is a big chance that this problems are caused by bRawSockets ? Unfortunately no of the admins with crash servers is answering me the question if they are using bRawSockets or not...Each one is posting the Crash stack instead of answering questions which can help to find the cause.
  23. The saving problem is not reproducable, its coming randomly. An ark server alsways first creates a .tmp and then moves it to a .ark. In my case about each 10th time it couldn't make the .ark file and leaved the .tmp file. My observations about UDP: - Autosave gives a much bigger lagg than with Steam P2P - Big bases are loading in slower with UDP - Generally (Gameplay) no differences found. Not better, not bader... - Uses more CPU Power than Steam P2P (But has the same ingame server performance) So in conclusion, still the same --> Its just heating
  24. Found some massive problems with bRawSocket! Ragnarok has problems to create the savefiles when using bRawSockets. Its creating .tmp files instead of .ark files. So if you do not want to loose data, i recommend you to go back to TCP (Steam P2P). Anyway there is zero performance improvement by using UDP. The autosaves generally runs better with Steam P2P...so less lagg by using TCP. I will give it another try when its really fixed...which is absolutely not the case at the moment. More CPU load, no performance improvements and problems with save files.
×
×
  • Create New...