Jump to content

Windsinger

Members
  • Content Count

    44
  • Joined

  • Last visited

  • Feedback

    N/A

Community Reputation

19 Gathering Thatch

About Windsinger

  • Rank
    Naked
  • Birthday 01/28/1985

Personal Information

  • ARK Platforms Owned
    PC
    PS4

Recent Profile Visitors

1,223 profile views
  1. Bump for people who still want to setup their own servers at home. Important keynote is that your router/modem at home allows you to connect to your own external IP(v4) address. Full example here
  2. You could have left this line out, not needed. You did however answered it and i found out what caused the servers not seeing each other, one of the servers has multiple network interfaces and this caused a problem apparently. In the latest UE4 release the engines handles this differently hence why i was so confused if i was missing something. Thank you for your time & response
  3. Hi, Yes, this bit i'm aware of. What i'm wondering how does that ID works outside of the server? is it something you can connect between physical servers or is that not possible?. Server1: - Island - TheCenter Server2: - Ragnarok - Extinction If you start these up, then only the ark servers from physical Server1 will see each other, and vice versa for Server2. Players on Island will not be able to transfer to Extinction. So from my understanding, if this is solely done through files/ID... it should be able through a special network drive (Read NOT UNC, i'm using iSCSI disks). However the case remains the same, this is why i ask if there is anything socket/network wise i'm missing that allows them to see each other only on the physical host they are hosted. Because i dont see any special sockets being created
  4. ClusterID across multiple physical servers Hi, Could anyone explain how the clusterID works, how does it know what servers to allow, is it a socket created internally on the system, steam related? I can easily create 10 servers on 10 different physical systems, all sharing the same folder / cluster files but so far when I've test they only see themselves. How does the clusterID protection work? If I run it on the same system it works fine, but seperate system it no longer displays it. Anyone an idea?
  5. Is it password protected? If yes, did you check the little box in the transmitter "show password protected" [emoji56]
  6. WORKING SETUP ! [Verified 2019-07-22] Example below is a basic working setup Tested on Windows 10 with basic steamCMD and creating some batch files. Adjust SessionName, AltSaveDirectory and ClusterID's as you see fit! Required files: steamcmd.exe > https://developer.valvesoftware.com/wiki/SteamCMD#Windows # server 1 @echo off D:\Steam\steamcmd.exe +login anonymous PASS +force_install_dir "D:\Steam\ARK" +app_update 376030 +quit start D:\Steam\ark\ShooterGame\Binaries\Win64\ShooterGameServer.exe "TheIsland?listen?SessionName=Potato1?AltSaveDirectoryName=TheIsland?Port=7781?QueryPort=27001?RCONPort=27011" -NoTransferFromFiltering -clusterid=Potato -automanagedmods exit # server 2 @echo off D:\Steam\steamcmd.exe +login anonymous PASS +force_install_dir "D:\Steam\ARK" +app_update 376030 +quit start D:\Steam\ark\ShooterGame\Binaries\Win64\ShooterGameServer.exe "Ragnarok?listen?SessionName=Potato2?AltSaveDirectoryName=Ragnarok?Port=7782?QueryPort=27002?RCONPort=27012" -NoTransferFromFiltering -clusterid=Potato -automanagedmods exit In this example configs are loaded from following dir for each server D:\Steam\ark\ShooterGame\Saved\Config\WindowsServer Firewall ports: The only 2 ports that are required are the Port and QueryPort (7781/27001 for server1 and 7782/27002 for server2 in this example). Note: People playing from internal LAN should connect using their external IP if their router allows it.
  7. Looks lovely! <3 Do we get Collectors edition also for the PC btw?
  8. I'll test the wider port setting, will get back on this! Yes, both servers are showing in the game menu. Both upload and download are working (both ways).
  9. Did the a new test with 2 seperate dirs + 2 seperate configs, same issue. Any suggestions are welcome. It has to be something simple/trivial that I've forgotten considering it's a default install of windows / steam / ARK with no special config apart from being a PvE server and the settings listed above.
  10. @Gumballz, thank you for your reply, i've checked all the items you've mentioned. The server itself is setup as a PvE system. Other things i've tested/adjusted to test. - Disabled server password - I've double check and set the filters to show all types + maps in the main menu. - Logged in to the server. - On the terminal it does not allow me to set any options to where it's PvE/PvP but i've set that earlier. - Check all the boxes below too, no change, it keeps saying after a few seconds "No sessions found!"
  11. Added some info in regards the network location. since i know servers like this can and will perform different in certain LAN vs dedicated server situations. For clarification, in the local LAN or Unofficial browser i can find the server perfectly fine and can login without problems. If people would like any more info please or have a question, please let me know. Thing i've tried to adjust so far, - Move the " marks in the batch file, just after the UE4 paramenters and not after the -command structure [no change] - Added the ?bRawSockets [no change] - Specified different Rconports for each session [no change] - Instead of 1 directory, create 2 seperate dirs, for each server one and make a shared cluster folder. [no change] Things i'm still going to test, - Suggestions welcome!
  12. Solution for working setup here > #comment-1802925 #################################################### Cluster working via "Transmit ARK Data" but not "Travel to another ARK" Hey all, Problem : See attachment, Brief explanation: I can transfer ARK survivors/items/dinosaur between the servers I've setup. just the button on the top right doesn't work and shows "No sessions found..." Machine Setup, 1 machine on a local lan segment with Win10, I7-950, 24GB mem, 128GB SSD for running the 2 cluster servers 1 machine on a local lan segment with Win10, I7-6800K, 32GB mem, GTX1080 for running the ARK client. Steam install+update (steamcmd.bat) @echo off steamcmd.exe +login anonymous PASS +force_install_dir "C:\Steam\ARK" +app_update 376030 validate +quit Server1 setup "ClusterCookie-TheCenter" @echo off C:\Steam\steamcmd.exe +login anonymous PASS +force_install_dir "C:\Steam\ARK" +app_update 376030 +quit start C:\Steam\ark\ShooterGame\Binaries\Win64\ShooterGameServer.exe "TheCenter?listen?SessionName=ClusterCookie-TheCenter?ServerPassword=REMOVED?ServerAdminPassword=REMOVED?AltSaveDirectoryName=TheCenter?Port=7777?QueryPort=27015?RCONPort=27020?MaxPlayers=127 -NoTransferFromFiltering -clusterid=REMOVED -automanagedmods" exit Server2 setup "ClusterCookie-TheIsland" @echo off C:\Steam\steamcmd.exe +login anonymous PASS +force_install_dir "C:\Steam\ARK" +app_update 376030 +quit start C:\Steam\ark\ShooterGame\Binaries\Win64\ShooterGameServer.exe "TheIsland?listen?SessionName=ClusterCookie-TheIsland?ServerPassword=REMOVED?ServerAdminPassword=REMOVED?AltSaveDirectoryName=TheIsland?Port=7779?QueryPort=27017?RCONPort=27021?MaxPlayers=127 -NoTransferFromFiltering -clusterid=REMOVED -automanagedmods" exit GameUserSettings.ini (showing only lines i've added, rest is default) [ServerSettings] ... PreventDownloadSurvivors=False PreventDownloadItems=False PreventDownloadDinos=False PreventUploadSurvivors=False PreventUploadItems=False PreventUploadDinos=False noTributeDownloads=false ... Firewall config, Inbound: UDP: 7777, 7778, 7779, 7780, 27015, 27017 Inbound: TCP: 27020, 27021 Based on other topics : Added Shootergame.exe as allowed application as well Is it something i'm missing?
×
×
  • Create New...