Jump to content

Sign in to follow this  
SuperFudge

Accidental Dedicated Server Launch

Recommended Posts

Accidental Dedicated Server Launch

I went to Host/Local and accidentally clicked 'Run as Dedicated Server' and now I am unable to launch Ark and play normally, does anybody know how to revert this issue? I have tried to verify the integrity of the game files and uninstalled and reinstalled the game. 

Share this post


Link to post
Share on other sites
4 minutes ago, SuperFudge said:

Accidental Dedicated Server Launch

I went to Host/Local and accidentally clicked 'Run as Dedicated Server' and now I am unable to launch Ark and play normally, does anybody know how to revert this issue? I have tried to verify the integrity of the game files and uninstalled and reinstalled the game. 

It sounds like the dedicated server is still running in the background. Did you check all processes to make sure that you have ARK completely shut down, or if that doesn't help did you reboot the computer?

Share this post


Link to post
Share on other sites
5 hours ago, SuperFudge said:

@Pipinghot There is no Ark, ShooterGame or server file running in my task manager and I restarted my computer and nothing changed. To be more specific, I get a command prompt for launching a server whenever I hit play through steam. Find image attached below

Yikes, that does seem like a weird result.

So let me ask a few questions:

1) Edit: Nevermind this question, I see it's Win64.

2) When you clicked on "RUN DEDICATED SERVER" it popped up a window asking you to choose the Server Password and Admin Password.

     a) Did you type anything into either of the Password fields?

     b) Did you Click "ACCEPT" or "CANCEL" from that pop-up window?

3) When you "hit play" through Steam, are you using the main Steam window and going to Library > ARK: Survival Evolved > Play, or are you right-clicking on the little circular Steam icon in your quick tray and from the menu selecting ARK?

Edited by Pipinghot

Share this post


Link to post
Share on other sites
5 hours ago, SuperFudge said:

@Pipinghot There is no Ark, ShooterGame or server file running in my task manager and I restarted my computer and nothing changed. To be more specific, I get a command prompt for launching a server whenever I hit play through steam. Find image attached below

As a follow up, i just thought of something else.

It looks like maybe your Dedicated server did not finish starting up properly, the output in your command window looks different than what I see in mine, but specifically I don't see an indicator that you completed a successful startup.

ServerStartup.JPG

I'm thinking maybe you need to give it more time to complete, then use CNTL-C to close down the server process, exit ARK completely and then restart the game.

 

Edited by Pipinghot

Share this post


Link to post
Share on other sites

So I ended up just uninstalling again and deleting every ShooterGame file I could find and after reinstalling from there it started working again. 

But  for the server and admin passwords I had left them blank and named the server '123' but whenever I noticed the command window pop up I closed it right away, realizing it was going to use my computer as a host and I was afraid I wouldn't be able to play at the same time. So that probably corrupted the setting up of the server and made everything worse. 

Yes for launching Ark, I would open up steam > Library > Ark > play and not right clicking steam in my task bar. But for giving it more time; Whenever I launched ark, that command window would pop up until it loaded my steam ID and then it would close itself, so im not sure this would have fixed it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...