Jump to content

Issues with transfer between clustered servers - ASE


Recommended Posts

I have a basic Island server and Scorched Earth running in docker containers.  Image provided by ich777.  No mods no custom configurations, just default config along with my set ports, names, cluster ID, and passwords.
Both servers come up and I can see and connect to them directly.  
When I log in to the island on a brand new survivor.  Level 1, no items.  Completely new and run over to an obelisk, I can see my other scorched server is available and I choose to transfer to it.
After about 30 seconds or so, I am sent back to the menu screen and given a "Host Timeout" error.

I then try to directly connect to scorched and now that server is timing out when I try to connect when it allowed me to connect just fine before I attempted the transfer.  
Bummer.  However, I can restart the scorched container, and when I directly connect to it again, it works and I can see my transferred survivor.  Pull him in, spawn, and take off for the closet obelisk to try going back to the Island server.  
Same exact experience.  Host times out, cannot connect directly, restart container, and I can connect and spawn in my transferred survivor.  
I'm not sure what's causing this, but it's consistent.  
**Relative specs:**  
This is a dedicated server running my docker containers.  I am NOT using Windows and not playing and hosting from the same machine.

  • AMD Ryzen 7 1800X
  • 64GB DDR4 3200
  • Game files and such are on an Intel 1TB NVMe
  • Connecting from "Join Ark" in game.  I've tried manually doing it from Steam > View > Game Servers, but that has it's own issue.  Something about "Cannot query game parameters" or something. (not important at the moment)
  • Confirmed that even though I'm connecting from in game, it's smart enough to use my local IP, so it's not some weird thing where it's routing out to the internet and back in.
Link to comment
Share on other sites

3 minutes ago, Larkfields said:

Have you separated the ports numbers by two?
Something like 7777 for the Island and 7779 for Scorched?


Island is 7777-7778
Scorched is 7779-7780

Again, they both work with direct connection, up until I try to transfer between them. Then I must restart the target server's container before I can connect to it again.

Link to comment
Share on other sites

5 hours ago, Larkfields said:

Which OS ?

I found that Windoze 11 was putting cores to sleep on my server - to save energy !
That was preventing people from connecting.

I'm not familiar with dockers...  Have you set up a shared directory for both maps to use as a cluster directory?

My server is running Unraid, which is linux.
Each Ark server is running in its own docker container, which is based on debian linux.

A directory has been mapped and both containers have access to it.

i CAN transfer between them.  that's not the issue.   The issue is that I disconnect during the transfer and then have to restart the container to be able to connect again.


Edited by DLCHAMP
Link to comment
Share on other sites

10 hours ago, Larkfields said:

What happens if two people are logged in - on different maps - and one of them tries to transfer?

Not sure.  Haven't gotten that far into testing since it hasn't worked with just one person, I haven't attempted to do anything with two people connected.
I'll test and get back.


Link to comment
Share on other sites

So, noob moment.  🤦‍♂️

I had all my ports forwarded for all servers, but since originally we were running Island on gportal, I didn't spin up that container and didn't forward those ports.
I decided to test out this whole transfer thing, so i spun up a vanilla island server as part of my cluster to 1. make sure it works, and 2. see exactly how it works (I'm really new to the game)

Turns out, I spun up the island server, but never forwarded the game ports while the steam port was already forwarded from my previous configurations.
So I could connect locally, but when my buddy tried to connect to my island server to test your recommendation earlier, he couldn't connect.  I checked my firewall and the attempt was being blocked.   So, I correctly extended the game ports to include the island and all my issues have gone away.


So thanks for recommending that.  I probably would have spent a whole extra few hours working this out before realizing that the missing ports were the issue, but thankfully him trying to connect and it timing out prompted me to immediately check to make sure the ports were correct. 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...