Jump to content

xAlex1337

No SteamCMDinstall.sh, Mod mismatch

Recommended Posts

No SteamCMDinstall.sh, Mod mismatch

Hi Guys,

 

I have an Ark Linux Server which works perfect in vanilla.
I have downloaded SteamCMD via curl -sqL "
https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz" | tar zxvf -

And installed Ark, everybody can join and I can play with my friends.

But I wanted to install some Mods and got into a lot of issues.

How I have installed the Mods:

I did add the Mod IDs to my Game.ini and to my GameUserSettings.ini and added -automanagedmods to my start script.


Then I tried to start the server but there were already some error messages and it was not possible to connect to the server.


How I have tried to fix the issue:
First of all I discovered that I don’t have the SteamCMDinstall.sh file which (as far as I know) is crucial for auto downloading Mods.

After searching for solutions on google for a while I discovered this fix:

(the post https://steamcommunity.com/app/346110/discussions/0/353915309347748338/)

 

cd Engine/Binaries/ThirdParty/SteamCMD
mkdir Linux
cd Linux
curl
http://media.steampowered.com/installer/steamcmd_linux.tar.gz > steamcmd.tar.gz
tar -zxf steamcmd.tar.gz
./steamcmd.sh

Which was kinda helpful, because I could start the Server and it acutally downloaded the mods now BUT I always get a Mod Mismatch error and my friends get it to.
We tried the regular stuff to solve this issue (deleting Mods folder and unsubscribed from every Mod) but nothing really solved the issue.

I did try a lot of other things but they didn’t helped me at all.
I would like to use the Ark tools Manager but it needs the SteamCMDinstall.sh to.
I don’t want to use ftp to install the mods manually and keep them up to date.


Im sure there is a solution for this but at the moment I don’t know what I can do and would really like some help.

Thanks in advance.

Share this post


Link to post
Share on other sites

Your game.ini should have a [ModInstaller] section like this...

[ModInstaller]
ModIDS=731604991
ModIDS=1333671171
ModIDS=821530042
ModIDS=793605978

and your GUS.ini should have the mods listed on a line like this...

[ServerSettings]
ActiveMods=731604991,1333671171,821530042,793605978

If you've done that, then  -automanagedmods  should "just work".

However, you need to be aware that some mods are NOT compatible with others. 
Some mods are not kept up to date, and
Some mods need to be the first one(s) in your lists of mods.

You need to read the documentation for the mods to see what their particular needs are.

Share this post


Link to post
Share on other sites

As I said I have already done that, I editet both files the right way (even tried just using 1 Mod so there cant be issues with them not being in order).
And I have added the -automanagedmods command to my startup script.
Still doesn't work, without the fix I mentioned the server wouldn't even fully start but crash every time when starting.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...