Jump to content

Recommended Posts

In my custom mods I am having troubles getting engrams to load an it seems anything I attach to my primal game data doesn't actually move into the Ark game after cooking "GameMod" though all of it works correctly while in the engine test play. 

My layout for my mod looks a little like this

Mod folder: Frost (Located in /Game/Mods/)

PGD: PrimalGameData_BP_Frost (Located in /Game/Mods/Frost)

Level: Frost (Located in /Game/Mods/Frost)

Folder: DarkClaw (Located in /Game/Mods/Frost)

Within the DarkClaw folder:

Sword TPV & FPV

EngramEntry_DarkClaw(child of sword)

PrimalItem_DarkClaw(child of sword)

WeaponDarkClaw(child of sword)

DarkClaw Texture

DarkClaw Material

 

I have checked and quadruple checked that these items are all referenced to one another in the correct places. They load and function correctly within the engine.

My world settings

Game Data Override is: PrimalGameData_BP_Frost

Force Load Map has been set to two variants on seperate cooks neither of which worked. "TheIsland" and blank

GameMode Override is left at none.

PrimalGameData settings

My EngramEntry is referenced in Additional Class Engram Entry

My PrimalItem is referenced in Master Items List

My Engram is set to be given to player inventory and the Primal item is set to be crafting component "none" which should make it craftable in inventory. Then my item is set to be given to player inventory.

 

Once I cook this and upload it my PrimalGameData_BP_Frost displays on the loading screen but once in game it does not show up in the menu tab and my engram does not show up as learnable. However I can spawn this item in and it functions correctly using:

Cheat GiveItem "BluePrint'Path'" 1 0 False

This item then will disapear from my inventory on the next server reset. But not on my personal client reset.

I have tried various fixes that modders state worked for them but none have fixed my issue. 

 

Does anyone know how I might be able to get my Engram to be learnable and exist through server resets? (The reset is not a wipe and does not remove any content other than my mod items)

Share this post


Link to post
Share on other sites

Just a few things off the top of my head:

1) make sure your engram is set to a level higher than 0 and requires at least 1 engram point to learn. (I've seen oddities like this with anything less) and that there is a crafting cost to them (1 wood or thatch is what I usually do for testing)
2) Make sure not of your engram items have any of the "deprecate" flags enabled.
3) Make sure any assets referenced are actually in your mod folder. not all of the assets in the devkit are actually packaged in the base game.

If all else fails you can try replicating what I do in my tutorials, having a visual example might help spot anything that was maybe forgotten. Episode 3 is where I actually create a first mod that includes the stuff you are working with now:
https://www.youtube.com/playlist?list=PL2o1TY9xh_JsmbgQfSCydfT-7OSdvxsVR

 

Edited by ZenRowe

Share this post


Link to post
Share on other sites

Thankyou Zen I have actually watched all of your videos and I think you are wonderful. However could you clarify for me what a "deprecate" flag is? My engram is set to learn at 74 and 3 points to learn with 4 different crafting materials set. 

Now if Im to understand this correctly all base game references that I have left unmodified such as skeletons materials and animations should be copied in my mod folder?

Share this post


Link to post
Share on other sites

Potentially. If you know the assets are in the game you generally don't have to copy them over, but if you aren't sure then you should probably use copies in your mod folder to be safe.

As for the deprecate flag if you go into the defaults of your primalitem and search "Deprecate" you should get one or tool boolean parameters make sure they are not set to true.

You can also compare your mod files that are downloaded. if you go into the directory that gets downloaded from steam you can check for yourself to see what files were uploaded. If something is missing then you have a potential starting place to find out what is going wrong.

Edited by ZenRowe

Share this post


Link to post
Share on other sites

I really appreciate your replies Zen and thankyou for your time.

So to further complicate things the deprecate flags are not enabled and in my mod directory after the cook all of my items are present and accounted for. Im going to try and relocate all references and then replace the reference with my copies next. Someome had mentioned creating blueprint children might be a cause too. Shpuld I perhaps recreate my bp items?

Share this post


Link to post
Share on other sites

It's possible that the version gap could be causing issues for you. Might want to hold off until the devkit update makes its way to the epic launcher and then confirm if the issue continues to be a problem.

Generally though making children of blueprints is the safer way to do things.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×