Jump to content

Process frozen: GameThread timed out waiting for RenderThread after 120.00 secs


Recommended Posts


Do you know how to solve this error?

I saw on discord and steam forum that we are a lot having this problem.

Game freezes on character creation, or spawn region menu, or at best on loading character (at best I managed to stay in the game for 5 seconds).

I have:
16gb ram, good 5 years i5, rtx 3060.

I tried:
Low settings
Install geforce experience and update the driver
Game on unofficial / official / solo games

Always the same result.

I watched task manager (W10) when entering in the game:  before the spwan ingame and until the freeze 5sec after the character's arrival : high cpu and less than 5% gpu. (it doen't use my gpu?)


Thanks for help.

Link to comment
Share on other sites

Same issue for me. dependency walker show issues on some dll, I udpated PATH, even install a new W11, still not able to play. Probaly because of CPU : I5-4690 (GPU ok RTX 3060)CrashContext.runtime-xmlBreadcrumbs_RHIThread_0.txtUEMinidump.zipCrashReportClient.ini


Edited by claude33
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...