Jump to content

Rag/Linux/Dedi: No dino spawns and can’t build outer map borders.


Recommended Posts

Background:
First post on the forums. Long time lone single player recently interested in Linux. Set up dedicated server through GameServiceManager for Linux (Ubuntu) to switch between Nitrado Island Server and home Dedicated Ragnarok server. Have been googling this specific issue for days and can not seem to find anything that pertains to the specific issue. Here we go:

I start the server with command “./arkserver start”. Server initiates with no issues. I join the server, still no issues (enjoying the non-existent ping of having the server in my house).

Character spawns in on the beach. No dinos anywhere...
First thatch foundation is crafted, selected, confirmed green, and placed. Building “thump” happens, but no foundation goes down. No error message, no “can’t place structure”, nothing. Just a thump, and air.
 

Curious, I go into creative mode and fly around the map with stone pillars ready. Following the map closely, I notice that i can not place any structures near the outer edges of the map - specifically the outermost land quadrants. I also noticed that dinos are only spawning toward the middle of the map. The seas are dead, the beaches are dead. Incidentally, I notice that I can place structures toward the middle of the map, in the same places where the dinos are spawning, and can not place structures where they’re not spawning.

And that’s the issue. Things I have tried so far: 

- Switching maps to TheIsland. Can build a anywhere, dinos spawn properly, works perfectly

- Deleting the save file and restarting the server
- Changing all the typical values: allow building near loot crates, loot crates spawn on structures, allow cave building, building allowed in resource-dense areas, changed value of building near resources to the lowest possible setting (I think it’s at 0.01 now). Even tried turning off the s+ integration.
- Have checked launch options that there isn’t anything wonky going on re: “don’t spawn dinos” and whatnot
 

I’m wondering if it could be a hardware limitation, is that a possibility? My server is running on an i7 @ 3.0GHz with 8GB RAM. The highest load values I’m getting are CPU at 73%.

In closing; I don’t want to sound more savvy than I actually am here, I’m very new to hosting and Linux and am using this as a project to learn how it all works. 

 

Has anyone else here run into this and figured out what’s going on?

Link to post
Share on other sites
  • 9 months later...

Having the same exact problem, you ever figure it out?

Trying everything.

Seems like the size of the map first loaded is still playable in the middle area of say a new, bigger map, but outside that area can't build and nothing spawns.

Edit I backed up all my configs and deleted them and with all new default configs I still have the same issue, so even with no mods, and all default settings it is still a problem.

FIXED:

Your arkserver.cfg (instance config) in lgsm/lgsm-config might be out of date, up date it by copying the _default.cfg as the new arkserver.cfg  and make sure you just copy everything over to the new config file. When I did that the game started behaving normally again.

I think the issue was the altsavedirectory paramater was "TheIsland" when I was playing on the "CrystalIsles" and it was loading some settings meant for The Island and not the map I was actually playing.

Edited by fawhxldawg
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...