Jump to content

Recommended Posts

Transfer server issues

I play on ps4, I transferred to Extinction with my tribe to get gachas. All of them were able to transfer back out, I'm stuck. Even without anything on me it won't transfer. It just sits there and doesn't load. The only thing it let's me do is back out. I have even tried to transfer to different servers, tried to kill myself and redo it and used a different ps4 system nothing is working. My character is stuck in Extinction. Any ideas? Or how I can get them to fix the issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...