Jeremy Stieglitz

Quickie Procedurally Generated ARKs How-To Guide

Recommended Posts

Pach    36

So, some friends of mine and I are trying to make a generated ARK that has both the SE and regular content in it (so we don't have to keep swapping servers).

All of us have SE.

Experimentation shows that the SE spawns are not working on the generated ARKs.  Is there some way to do this?  I would imagine that using one of the SE biomes would immediately cause the server to require the SE expansion to log in... is this "in the future", or is it available now?

I suspect that's what many other folks are trying to do as well, but figured I'd toss it out clearly. :)

 

Share this post


Link to post
Share on other sites
y0himba    31

Hello. Is there any way to get max and min values for each setting? We are testing extreme and minimal, but continually get crashes.  With max and min values we can get an idea of the type of map we want to build.

Also, a seed range and what can be contained in the seed like alpha-numeric or special characters, how high or low the seed value can go would be helpful.

Thank you for the PGM capability!

-Extremely happy ARK survivor.

Share this post


Link to post
Share on other sites
Archimodes    14
2 minutes ago, BubbaCrawfish said:

You are correct, that Linux isn't supported, but the tutorial simply covers both so when it's ready, you'll be able to get a Linux server up and running.

Seriously, the devs alienate Linux yet again? These are the only devs I've ever seen that don't seem the realize that the vast majority of servers out there run Linux. Jesus. A heads up would've been nice too. I had a box turned up specifically for procedural arks - it's been sitting and waiting for 2 weeks due to these awesome delays. Now what the hell am I going to do with it.

I've said it once, and I'll say it again. This would be a damn good game if the devs would actually realize that pissing on their admins isn't a good idea. If admins are happy, players are happy. 

Edited by Archimodes

Share this post


Link to post
Share on other sites
BubbaCrawfish    257
10 minutes ago, Archimodes said:

Seriously, the devs alienate Linux yet again? These are the only devs I've ever seen that don't seem the realize that the vast majority of servers out there run Linux. Jesus. A heads up would've been nice too. I had a box turned up specifically for procedural arks - it's been sitting and waiting for 2 weeks due to these awesome delays. Now what the hell am I going to do with it.

I've said it once, and I'll say it again. This would be a damn good game if the devs would actually realize that pissing on their admins isn't a good idea. If admins are happy, players are happy. 

You think you're the only one?

 

They haven't alienated Linux just because the linux portion of this will come in the next few days. They also did advise this in the patch notes.

Share this post


Link to post
Share on other sites
Archimodes    14
3 minutes ago, BubbaCrawfish said:

You think you're the only one?

 

They haven't alienated Linux just because the linux portion of this will come in the next few days. They also did advise this in the patch notes.

Link to the advisory please. I don't see it in the patch notes even now, but I could just be missing it. Even so, it wasn't there prior to release.

Who said I thought I was the only one? Wouldn't my statement about Linux being the most widely used server OS on the planet contradict that? If I thought I was the only one on Linux I'd probably not be pissed about a lack of support for it. Not even sure DILO you're on about right now, lol.

Edited by Archimodes

Share this post


Link to post
Share on other sites
BubbaCrawfish    257

Look under the first paragraph...

On 1/3/2016 at 1:06 AM, Jen said:

Note: Procedurally Generated ARKs currently do not work on Linux Servers, Linux Clients, or Mac Clients. We expect to have this fixed within a day or so, stay tuned!

When the release hit, this was added. It's been there the entire time since.

Edited by BubbaCrawfish

Share this post


Link to post
Share on other sites
Archimodes    14
4 minutes ago, BubbaCrawfish said:

Look under the first paragraph...

 

Ah - as I said, added today when the patch HIT, not prior. Also, as I said, I have had a 4.8ghz overclocked server (which mind you are expensive as all hell) sitting idle waiting for this patch to hit, for two weeks now. A little heads up prior to release day would be FANTASTIC.

EDIT: It's not been there the entire time, lol.

Edited by Archimodes

Share this post


Link to post
Share on other sites
BubbaCrawfish    257

I think you need to just chill and realize you aren't the only one in this boat... I'm in the same, but I'm not coining the speed of my server, or how much I'm spending on continuing to run a server.

When patch notes are released, it's at the time.

Maybe they couldn't get the Linux setup working at 3AM when they were working on this, and they ended up having to chuck it on the backburner due to the fact that they had worked very hard to produce what people wanted...

 

Ever thought of that?

There's no abandoning, or alienating of Linux, it's just more tricky than windows.  The note was there, yet you'd overlooked it.

Share this post


Link to post
Share on other sites
Bumbles    3

Jeremy, thank you so much for this info. You've answered all the questions I posted on the Steam discussions forum. It must have kept you up all night, and I for one appreciate the effort.

I'm very excited with this new ability to not only create unique maps, but also to tailor them with the creatures in the numbers I want on my maps. And that it replaces my 'More Creatures for Scorched Earth' mods means I can take a rest from that now, because anyone can use the new INI way of adding and subtracting the creatures they want.

I"m outa here to start generating some great maps.

Thanks once again.

Share this post


Link to post
Share on other sites
houndazs    0

Ok fellow players and Ark Admins. I'm running a dedicated Ark Server here at home, and I can not for the life of me get Procedural Arks to work. Everything I try, causes my Gaming Rig to crash. I can load Offical Procedural Servers just fine.

PGARK?listen?MultiHome=192.168.1.143?Port=7777?QueryPort=27015 is the command I'm using.

All I've done is insert(per Dev Instructions) my solo Game.ini settings into the Dedicated Servers Game.ini.

All my other maps run without issue. I usually run ASM for my other maps, but running procedural manually to troubleshoot the issue.

Help.....

EDIT: Yes, I've tried checking of local game data, and ensuring the server and my gaming rig are running the same version. Even checked the game files for validity on the server.

Untitled.png

Share this post


Link to post
Share on other sites
Mystalias    322
48 minutes ago, houndazs said:

Ok fellow players and Ark Admins. I'm running a dedicated Ark Server here at home, and I can not for the life of me get Procedural Arks to work. Everything I try, causes my Gaming Rig to crash. I can load Offical Procedural Servers just fine.

PGARK?listen?MultiHome=192.168.1.143?Port=7777?QueryPort=27015 is the command I'm using.

All I've done is insert(per Dev Instructions) my solo Game.ini settings into the Dedicated Servers Game.ini.

All my other maps run without issue. I usually run ASM for my other maps, but running procedural manually to troubleshoot the issue.

Help.....

EDIT: Yes, I've tried checking of local game data, and ensuring the server and my gaming rig are running the same version. Even checked the game files for validity on the server.

Looking at your error message, the first thing I thought of was that something in your settings is too high for your server to handle... but if you can make and use the map in single player, that seems very odd. I'm wondering if you've missed a step somewhere, like copying a map cache file or something...

Share this post


Link to post
Share on other sites
houndazs    0
58 minutes ago, Mystalias said:

Looking at your error message, the first thing I thought of was that something in your settings is too high for your server to handle... but if you can make and use the map in single player, that seems very odd. I'm wondering if you've missed a step somewhere, like copying a map cache file or something...

So I have to transfer the cache folder to the server as well? I'd assume it made ons own but I'll try it. 

Share this post


Link to post
Share on other sites
Mystalias    322
Just now, houndazs said:

So I have to transfer the cache folder to the server as well? I'd assume it made ons own but I'll try it. 

I'm not really sure, I've only been playing with this in single player so far today, but it feels like something is missing, and figure copying the already generated files from single player might help the server skip some of the crunching that might be leading to your issue.

Share this post


Link to post
Share on other sites
BubbaCrawfish    257
57 minutes ago, houndazs said:

So I have to transfer the cache folder to the server as well? I'd assume it made ons own but I'll try it. 

Does the server run with the normal maps rather than the PGArks?

If you haven't tried that then I'd suggest you do, and check that it's not trying to load the Primitive+ mod, as it's mentioning that.

 

If the map doesn't load in vanilla then I'd be looking at your runtimes seeing as most of the errors in there are saying about "Unknown Function"s, which would suggest something isn't installed right.

Share this post


Link to post
Share on other sites
y0himba    31
Quote

To get a PGARK configuration that you like, we recommend experimenting in singleplayer through the in-game UI, and then once you have settings you're happy with, copy the PGTerrainPropertiesString from your Windows\Game.ini into your dedicated server's WindowsServer\Game.ini (into the [/Script/ShooterGame.ShooterGameMode] section as described above). Then, as long as you're hosting a new PGMapName, those settings will take effect just as they were in your singleplayer game! You can also easily share good PGARK configurations by sharing that string with other server hosts, just copy the text of PGTerrainPropertiesString to them, and they can put it in their own INI. Share your best PGTerrainPropertiesString settings on the Forum! Hosts can put the PGTerrainPropertiesString value into PGLastUsedSettings as well, which will then become visible to the in-game UI for further custom tweaking/iteration.

Maybe this helps?  From:

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.