Jump to content

Jeremy Stieglitz

Scorched Earth Technical/Detail FAQ! (Ongoing)

Recommended Posts

20 minutes ago, Daumier said:

So if I upload a character to an SE server, will I still have the character on my Center server?

Or can my character only exist on one server at the same time? 

If it exists on both servers, what happens when I upload from the SE server? 

Your character only exists on one server at the same time

Share this post


Link to post
Share on other sites

I have had a measure of success in now being able to transfer items and dino's from my TheCenter map to a Scorched Map game I had been able to get running by using a Symlink.

I have had problems with the SE server not showing up in any server list either from the Join menu or in the Server Cluster  when running 2 instances from the same folder. However it does all show up for me when I run the game set up correctly but from separate folders. This has the side effect however of not being able to transfer anything

I have now seemingly solved that at least in terms of transferring Items and Dino's (haven't yet tested player transfers yet, but I see no reason why this shouldn't work) by creating a Symlink.

To achieve this, and this may be for the more advanced admins out there run the Command Prompt as an administrator (Search for Command and r.click on Command Prompt and select Run as Administrator) then use

mklink /D <link> <target>

  so in my case I used:
  
mklink /D H:\Ark-TheGenesis\ShooterGame\Saved\clusters H:\Ark-TheGenesis\ShooterGame\Saved\clusters

the /D tells the mklink command to create a folder link

The first folder directory is the link I am creating with the second folder where the actual cluster info is stored

As this simulates at least the cluster being run from the same fodler whenever either server changes the files within it changes them for the other server.

I had thought to do the same for the Saved folder in general but as the config files are all stored there as well I just assume this with take be back to the running the game from the same folder issues I had previously, so I just stuck to linking the cluster folder

 

Hope this is of some measure of help to those that can make use of it

Share this post


Link to post
Share on other sites

On official, The Center maps, the natural wild dino level is 150.

Are there any Scorched Earth server that are dino level 150?

Do they just gain 30 levels on transfer?

No one would ride a 120 dino on The Center, is that what we will be stuck bring back with us?

 

Share this post


Link to post
Share on other sites
13 hours ago, SurvivalServers said:

We've released a (very beta) tool which side launches another game server with the target map/expansion (in this case ScorchedEarth_P) running as a transfer instance in the same cluster. You can complete your transfers then toggle Scorched Earth from our control panel, disable the Transfer Mode (the beta tool that does all of this) and then be up and running on Scorched Earth with your transfer data.

For folks running this privately, you need to change the port/queryport/rconport, hostname (for easier identifying, not required though) and the AltSaveDirectoryName to something different to have an "output" folder location. You also need the "-NoTransferFromFiltering -clusterid=clustername" in your launch param next to the other -command arguments (not within the double quote UE4 launch params area) When you load in on the source game server, you have to visit an Obelisk and click the Cluster button in the top right to select the target transfer game server you launched and it will log in with that player data / save in the target game server folder. If you don't see a button for the cluster, the cluster has not been enabled (the -NoTransferFromFiltering -clusterid=clustername part) It's worked pretty well for the most part.

Host Havoc says they have nothing and until a multi machine solution it will not happen.
SS will now be getting my business because at least they are trying to find a solution.   

Share this post


Link to post
Share on other sites
11 minutes ago, aftershock113 said:

Host Havoc says they have nothing and until a multi machine solution it will not happen.
SS will now be getting my business because at least they are trying to find a solution.   

I've just been talking with my own hosting provider about this as well. They're still digging into it but are aiming to have something released on this front within a couple of days. I think how the hosting companies adapt to this is gonna be an... interesting... one to watch.

Share this post


Link to post
Share on other sites

So I'm hopeful that someone has managed to get this dynamic gate way going for unofficial.

I've had a mixed bag of results. I run a dedicated machine on ubuntu, so running multiple instances of the game is no issue.

I've done the same directory, separate directories, the separate saves issue is no big deal and easy to incorporate in the commandline launch, but a clean transfer only seems to happen when I have "tribute downloads" enabled. Which...as we all can expect is an issue. Also, even when it does work, sometimes it will not go correctly, and you have to start the survivor all over and lose the spawn opportunity or transfer.

 

I've even loaded up 2 perfectly clean server instances, no saves, no configurations, and the results were the same. Its just a raw switch between the clustered server instances, and if you touch it will loading the other instance on the local PC you can be sure you are going to be starting over. Battleye is also failing a lot after a successful transfer.

 

Anyone on a dedicated linux that has had complete success while not using Tribute Downloads?

 

Edited by Valiev

Share this post


Link to post
Share on other sites
4 hours ago, Garie said:

I have had a measure of success in now being able to transfer items and dino's from my TheCenter map to a Scorched Map game I had been able to get running by using a Symlink.

I have had problems with the SE server not showing up in any server list either from the Join menu or in the Server Cluster  when running 2 instances from the same folder. However it does all show up for me when I run the game set up correctly but from separate folders. This has the side effect however of not being able to transfer anything

I have now seemingly solved that at least in terms of transferring Items and Dino's (haven't yet tested player transfers yet, but I see no reason why this shouldn't work) by creating a Symlink.

To achieve this, and this may be for the more advanced admins out there run the Command Prompt as an administrator (Search for Command and r.click on Command Prompt and select Run as Administrator) then use


mklink /D <link> <target>

  so in my case I used:
  
mklink /D H:\Ark-TheGenesis\ShooterGame\Saved\clusters H:\Ark-TheGenesis\ShooterGame\Saved\clusters

the /D tells the mklink command to create a folder link

The first folder directory is the link I am creating with the second folder where the actual cluster info is stored

As this simulates at least the cluster being run from the same fodler whenever either server changes the files within it changes them for the other server.

I had thought to do the same for the Saved folder in general but as the config files are all stored there as well I just assume this with take be back to the running the game from the same folder issues I had previously, so I just stuck to linking the cluster folder

 

Hope this is of some measure of help to those that can make use of it

Hm nice .. i LOVE YOU .. that works :-)

Edited by LynxX

Share this post


Link to post
Share on other sites
Just now, DarkWaters said:

I was hoping we could get info on how the new saves are created with the ?AltSaveDirectoryName?. Do we get new "Saved Arks" folders within the "Saved" folder or are they made elsewhere? I'm trying to find a definite location so that I can back them both up separately as necessary.

Just put a name like save1 or save2, and it will create the dir within the default Saved directory.

Share this post


Link to post
Share on other sites
1 minute ago, DarkWaters said:

I was hoping we could get info on how the new saves are created with the ?AltSaveDirectoryName?. Do we get new "Saved Arks" folders within the "Saved" folder or are they made elsewhere? I'm trying to find a definite location so that I can back them both up separately as necessary.

...?AltSaveDirectoryName=Save0...

...?AltSaveDirectoryName=Save1...

the commands create 2 new savefolders: Save0 and Save1 in ..."SERVER"\ShooterGame\Saved

so each server has its own save&backupfile lovated in the specific folder.

Share this post


Link to post
Share on other sites

yes symbolic link will try this out , dont know y i didnt think about it , a tool that auto does this between servers , using some type of ftp would be ftw for people with severs on multi boxes

 

also if the devs add an option to point out the location of the cluster folder would help alot

 

this helped me do the symbolic link

http://www.howtogeek.com/howto/16226/complete-guide-to-symbolic-links-symlinks-on-windows-or-linux/

this program makes it point and click 

http://download.cnet.com/Link-Shell-Extension-64-bit/3000-2248_4-75213087.html

 

Forgot to mention to symbolic link the saves folder make them the same name and link them together because you tribe data will not transfer , i had to learn this the hard way =p lost a few dinos 

i have this working with ark server manager and 2 different folders and server settings , i like this way best because i can still control the servers with ark server manager and not have the info clash together hope this helps you guys =]

Edited by zzzTNTzzz

Share this post


Link to post
Share on other sites
41 minutes ago, davidturner said:

I've just been talking with my own hosting provider about this as well. They're still digging into it but are aiming to have something released on this front within a couple of days. I think how the hosting companies adapt to this is gonna be an... interesting... one to watch.

all they would need to do is allow remote desktop access and assign 4 ports for servers

 

Share this post


Link to post
Share on other sites
43 minutes ago, Valiev said:

So I'm hopeful that someone has managed to get this dynamic gate way going for unofficial.

I've had a mixed bag of results. I run a dedicated machine on ubuntu, so running multiple instances of the game is no issue.

I've done the same directory, separate directories, the separate saves issue is no big deal and easy to incorporate in the commandline launch, but a clean transfer only seems to happen when I have "tribute downloads" enabled. Which...as we all can expect is an issue. Also, even when it does work, sometimes it will not go correctly, and you have to start the survivor all over and lose the spawn opportunity or transfer.

 

I've even loaded up 2 perfectly clean server instances, no saves, no configurations, and the results were the same. Its just a raw switch between the clustered server instances, and if you touch it will loading the other instance on the local PC you can be sure you are going to be starting over. Battleye is also failing a lot after a successful transfer.

 

Anyone on a dedicated linux that has had complete success while not using Tribute Downloads?

 

I'm doing similar procesure like  you did. Actually I don't understand what it is to run two servers in the same directory. Would you explain, please?

Share this post


Link to post
Share on other sites

Here's an interesting ordeal. I removed all items from myself and flew to Blue Obelisk on the center to transfer to my clustered SE dedicated server. I went to Clustered ARKs and selected my SE server, entered the password and it has been frozen now for 10 minutes. No server crashes or any issues showing on my machine. Any ideas whats wrong?

20160903124536_1.jpg

Share this post


Link to post
Share on other sites
16 minutes ago, koreamedia said:

I'm doing similar procesure like  you did. Actually I don't understand what it is to run two servers in the same directory. Would you explain, please?

If you are using something like arkmanager, or arktools you will need to point a separate instance.cfg in your /etc/arkmanager/instances. Basically copy the main, and point it to your main .cfg, and edit your commandline start flags in that instance. Take backups, its a very specific process.

You control it via arkmanager start,stop,restart,update @instancename

or @all to hit all configured instances, which arkmanager checks the instances folder to see what is valid.

 

Otherwise, they way I'm doing it now is just creating new start scrips that are placed in the /binaries/linux folder to start the server instances the old way. There you setup your script, chmod +x that badboy to make it executable, and it starts up another instance of the game in the same folder with the commandline options you placed.

If using Ubuntu, open a shell and type top to see running processes, and you'll see the shootergame+ instance load up after running you startserver.sh script.

 

11 minutes ago, Ronnie said:

I got cross ark to work PERFECTLY. However, because you need to enable downloads, that means ANY DINO FROM ANY SERVER can be downloaded. that equals a stupid server. SHould only be able to download and transfer inside a cluster.

Thats what I was afraid of. I can only get it to work flawlessly with tribute downloads on =(

That really sucks.

Edited by Valiev

Share this post


Link to post
Share on other sites
2 hours ago, Ronnie said:

I got cross ark to work PERFECTLY. However, because you need to enable downloads, that means ANY DINO FROM ANY SERVER can be downloaded. that equals a stupid server. SHould only be able to download and transfer inside a cluster.

How did you get it work I gave up until WC comes out with a patch or something. If you have an easy way to get it to work I am all ears.

Share this post


Link to post
Share on other sites
18 minutes ago, Talabar said:

How did you get it work I gave up until WC comes out with a patch or something. If you have an easy way to get it to work I am all ears.

Just do exactly what is said on the first post.

But make sure in your configurations tributedownloads are on. That will make it work, as long as you did everything else correctly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...