Jump to content

Jeremy Stieglitz

Scorched Earth Technical/Detail FAQ! (Ongoing)

Recommended Posts

56 minutes ago, ddvs1 said:

Guys,

 

i manage the setup of 2 servers, and i can see the cluster in both servers, but the option Join w/ Survival still gray, and i can't travel.

Any tip on that?

 

Txs

search for this entrys in both gameusersettings.ini

PreventDownloadSurvivors=False
PreventDownloadItems=False
PreventDownloadDinos=False
PreventUploadSurvivors=False
PreventUploadItems=False
PreventUploadDinos=False

if Download or Upload Survivors is set to TRUE..  the button is grey ^^

Edited by LynxX

Share this post


Link to post
Share on other sites

It would appear that the name you give your cluster is very important.  I used cluster1 and when I went to transfer characters It listed 4 other Arks not in my network and when I tried to transfer it failed and deleted my character.   So beware.

 

I have ARK Server Manager and use it to configure and start/stop my servers.  The are in separate folders and I used the "mklink" command to make them work and save the ARKs to the same folder that I read in this chain of posts.

 

Share this post


Link to post
Share on other sites
25 minutes ago, Qwase said:

It would appear that the name you give your cluster is very important.  I used cluster1 and when I went to transfer characters It listed 4 other Arks not in my network and when I tried to transfer it failed and deleted my character.   So beware.

 

I have ARK Server Manager and use it to configure and start/stop my servers.  The are in separate folders and I used the "mklink" command to make them work and save the ARKs to the same folder that I read in this chain of posts.

r.

Thats because 4 other people used "cluster1" Thats why it said to make it a very unique ID...The transfer didn't work because the servers do not share a "clusters" folder.

Edited by Valiev

Share this post


Link to post
Share on other sites

My new problem now I've at least got the option to see my servers cluster is that when i transfer to a new Ark the server crashes when I go to spawn in the new world. I am connected to my cluster via a LAN but my brother who connects via the internet seems to have only minor issues transferring over.

 

My world were pre-exisiting worlds and running a bunch of mods (30+ of the buggers) and whilst playing on the center or scorched earth in itself is not an issue the finalisation of the transference is. Especially as the server crash cause my character to have to be downloaded again and in the process loses his tribe affiliation.

Soooo maaanny issues, soooo little backup from the Devs on this :(((((

Share this post


Link to post
Share on other sites

On unofficial linked server ....Engram Character Details not Saving/Updating.

Whenever new engrams are learned and the character relogs, the engrams revert to being unlearned.

If a character levels up and relogs, they remain the new character level, yet the new engram points they were awarded disappear.

 

Anyone else have a similar issue ?

Edit :  Brainfart ... never try to do server-side operations with less than 2 hour sleep in 2 dayz

Edited by Gumballz

Share this post


Link to post
Share on other sites
1 hour ago, Valiev said:

Thats because 4 other people used "cluster1" Thats why it said to make it a very unique ID...The transfer didn't work because the servers do not share a "clusters" folder.

Only because the folder name in the ID? Mine is -NoTransferFromFiltering -clusterid=my2000 , and a mklink with clusters folder in separate setup servers.

I have same issue, i can transfer from one server, but when i came back server crash, and i lost my caracter.

Any tip ?

 

Edited by ddvs1

Share this post


Link to post
Share on other sites

Hey guys...I have been trying to get this working without ASM and can't get it to work yet. I'm a beta tester for ASM and I'm sure it will be added once we know it's working without it and it will be easy to use. I spent a full day trying it out with the "clusters" and no luck. It comes up and doesn't crash, but can't see it.

ASM saves alot of your .CMD stuff in your GUS.INI so you would have to override it with the manual commands if you are testing with it. Like the SessonName= etc. But let's see if someone can get it working first and them we can give the ASM Devs the information to add it in so we don't have to rig it up.

Can anyone confirm they have it working with The Center and Scorched Earh traveling back and forth?

Thanks,

Doublee

Share this post


Link to post
Share on other sites
1 hour ago, Doublee313 said:

Hey guys...I have been trying to get this working without ASM and can't get it to work yet. I'm a beta tester for ASM and I'm sure it will be added once we know it's working without it and it will be easy to use. I spent a full day trying it out with the "clusters" and no luck. It comes up and doesn't crash, but can't see it.

ASM saves alot of your .CMD stuff in your GUS.INI so you would have to override it with the manual commands if you are testing with it. Like the SessonName= etc. But let's see if someone can get it working first and them we can give the ASM Devs the information to add it in so we don't have to rig it up.

Can anyone confirm they have it working with The Center and Scorched Earh traveling back and forth?

Thanks,

Doublee

i have it working with ASM 2 different install folders (this allows for different config files per server) but the cluster folder and world save are stored in the same folder using symbolic links, i talk a bit more about this in page 6 or 7

 

if you want to come see how it works check out my servers ↓

The Center Server  https://arkservers.net/server/162.248.93.226:27015

Scorched Earth Server https://arkservers.net/server/162.248.93.226:27025

 

9a8b0ce33e8331b63caf618590589e14.png

Edited by zzzTNTzzz

Share this post


Link to post
Share on other sites
On 3.9.2016 at 6:47 PM, DarkWaters said:

Here's an interesting ordeal. I removed all items from myself and flew to Blue Obelisk on the center to transfer to my clustered SE dedicated server. I went to Clustered ARKs and selected my SE server, entered the password and it has been frozen now for 10 minutes. No server crashes or any issues showing on my machine. Any ideas whats wrong?

Same here....

Share this post


Link to post
Share on other sites

Just wanted to say, why make scorched earth so hard? My tribe can't do anything but die every 5 seconds! It's freaking ridiculous! We can get anything built because of dying from vultures & terror birds every 5 seconds & losing everything we have. What's the point?!? Can't do anything but die! Complete waste of money on the dlc! Should have just stuck with the regular Ark!! 

Share this post


Link to post
Share on other sites

I can't see my other server in the cluster thing in the obelisk.  I'm running a test set up completely vanilla and firewall off.

My startup configs (Ubuntu):

Scorched Earth:

[Unit]
Description=ARK: Scorched Earth dedicated server
Wants=network-online.target
After=syslog.target network.target nss-lookup.target network-online.target

[Service]
ExecStart=/arktest/ShooterGame/Binaries/Linux/ShooterGameServer ScorchedEarth_P?listen?Port=7778?QueryPort=27016?MaxPlayers=10?SessionName=MySession1?AltSaveDirectoryName=arkse -NoTransferFromFiltering -clusterid=MyServerClusterName -server -log
LimitNOFILE=100000
ExecReload=/bin/kill -s HUP $MAINPID
ExecStop=/bin/kill -s INT $MAINPID
User=steam
Group=steam

[Install]
WantedBy=multi-user.target
The Center:

[Unit]
Description=ARK: Survival Evolved dedicated server
Wants=network-online.target
After=syslog.target network.target nss-lookup.target network-online.target

[Service]
ExecStart=/arktest/ShooterGame/Binaries/Linux/ShooterGameServer TheCenter?listen?Port=7777?QueryPort=27015?MaxPlayers=10?SessionName=MySession2?AltSaveDirectoryName=arktc  -NoTransferFromFiltering  -clusterid=MyServerClusterName -server -log
LimitNOFILE=100000
ExecReload=/bin/kill -s HUP $MAINPID
ExecStop=/bin/kill -s INT $MAINPID
User=steam
Group=steam

[Install]
WantedBy=multi-user.target

The servers start up I can see them in the Join ARK list but nothing in the cluster list...I get "No Sessions Found!"

Share this post


Link to post
Share on other sites
14 minutes ago, SassySha359 said:

Just wanted to say, why make scorched earth so hard? My tribe can't do anything but die every 5 seconds! It's freaking ridiculous! We can get anything built because of dying from vultures & terror birds every 5 seconds & losing everything we have. What's the point?!? Can't do anything but die! Complete waste of money on the dlc! Should have just stuck with the regular Ark!! 

*Mimics MLP-Rarity's voice* But I thought you wanted a challenge? The Island is too easy! We can tame or kill everything here! Why can't this be more of a survival game...?

Give it some time, just like other things they'll dial down the difficulty if they lose too many people because of it.

Share this post


Link to post
Share on other sites
4 hours ago, SassySha359 said:

Just wanted to say, why make scorched earth so hard? My tribe can't do anything but die every 5 seconds! It's freaking ridiculous! We can get anything built because of dying from vultures & terror birds every 5 seconds & losing everything we have. What's the point?!? Can't do anything but die! Complete waste of money on the dlc! Should have just stuck with the regular Ark!! 

You can do the admin commands for infinite stats then godmode and you won't die

Share this post


Link to post
Share on other sites
On 3.9.2016 at 1:08 AM, Lyserc said:

so i've managed to set up 3 server, the island, the center, scorched earth with the following commandlines:

%STEAMPATH%\steamcmd.exe +login %STEAMLOGIN% +force_install_dir %ARKSRVPATH% +"app_update %BRANCH%" update +quit


start %ARKSRVPATH%\ShooterGame\Binaries\Win64\ShooterGameServer.exe TheIsland?SessionName=%SESSIONNANE0%?QueryPort=%QUERYPORT0%?MultiHome=%IP%?MaxPlayers=%PLAYERS%?Port=%PORT0%?AltSaveDirectoryName=Save0 -NoTransferFromFiltering -clusterid=%CLUSTERID% -automanagedmods -nosteamclient -game -server –log


start %ARKSRVPATH%\ShooterGame\Binaries\Win64\ShooterGameServer.exe TheCenter?SessionName=%SESSIONNANE1%?QueryPort=%QUERYPORT1%?MultiHome=%IP%?MaxPlayers=%PLAYERS%?Port=%PORT1%?AltSaveDirectoryName=Save1 -NoTransferFromFiltering -clusterid=%CLUSTERID% -automanagedmods -nosteamclient -game -server –log


start %ARKSRVPATH%\ShooterGame\Binaries\Win64\ShooterGameServer.exe ScorchedEarth_P?SessionName=%SESSIONNANE2%?QueryPort=%QUERYPORT2%?MultiHome=%IP%?MaxPlayers=%PLAYERS%?Port=%PORT2%?AltSaveDirectoryName=Save2 -NoTransferFromFiltering -clusterid=%CLUSTERID% -automanagedmods -nosteamclient -game -server –log

All 3 server are running with some mods and without any error but are not listed in the ServerCluster list if i access an Obelisk.

Can someone help?

 

You have to enable the settings for upload/download on your servers:

?PreventDownloadSurvivors=False
?PreventDownloadItems=False
?PreventDownloadDinos=False
?PreventUploadSurvivors=False
?PreventUploadItems=False
?PreventUploadDinos=False

 

If your server is in a cluster, then only data from the other servers could be downloaded. 

 

Share this post


Link to post
Share on other sites

Hello all,

 

 Glad to see I am not the only one having an issue seeing the second server in the cluster in the obelisk.  I have an additional viewpoint to add...  these fellows describe the same problem I am having 

invisibleraptorpack
Talabar
Twin
ddvs1
KZ5EE

 

However... no one has mentioned LAN vs WAN ... I run a private server on a separate machine than my client .. it is however in my LAN (192.168.xxx.xxx , non routable internal subnet).  I can see the servers just fine in the connection list however the second one is not listed in the obelisk.  I have two friends that connect from outside my network and they are able to see the second server listed in the obelisk. 

 

 Wondering if it is an issue being in the same LAN/Network/Subnet as the cluster that's causing the cluster to not show up in the obelisk 

 

 So for the members above out of curiosity I are your servers living in the same internal IP space as your gaming client machines?

Edited by JGood121
grammar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...