Jump to content

HELP - My server crashes immediately and won't start


Recommended Posts

Ever since the scorched earth patch, my server no longer launches in Windows server 2016..there's another thread on this and it's basically wildcard breaking everything. 

 

I've been trying to get my server up and running in a new Windows server 2022 environment but now the console crashes immediately. I've tried maybe 10 times, creating different VMs and re-doing all the steps, but keep getting stuck.

 

I can install everything fine. Have my startup script and everything. When I start it, SteamCMD starts and checks for updates, then starts the server. The server console pops up loads some text but then just crashes. None of the Logs or crashstacks seem to have any useful info and I don't know where to go from here... 

 

SOLUTION - in case you come across this with the same issue, I had to create a Windows 11 VM and run the servers in there. Windows Server 2016 and 2022 do not work.

 

 

Startup Script:

start /wait C:\SteamCMD\steamcmd.exe +force_install_dir "C:\Ark Server" +login anonymous +app_update 2430930 +quit
start ArkAscendedServer.exe TheIsland_WP?SessionName="[NA] 3x Harvesting,4x Mating, 1.5x XP - Join Now!"?Port=7778?QueryPort=27015?AllowCrateSpawnsOnTopOfStructures=True?PvEAllowStructuresAtSupplyDrops=True -preventhibernation -clusterID=ArkFriendlyCluster -ClusterDirOverride="C:\Ark Server" -WinLiveMaxPlayers=35 -log -servergamelog -crossplay -PublicIPForEpic=96.237.159.115 -mods=975282,927131,929420,928621,929868,928793,928988,928708,928597,931047,929785,933489,932822? -passivemods=

 

Edited by slydog1225
Link to comment
Share on other sites

8 hours ago, Larkfields said:

1. Are there any clues in the Windows event logs?

2. Have you tried without using an existing save file?

3. If you're using mods, have you tried removing them all to see if the world loads up?
 

So the biggest clue I've gotten is from the event viewer. I have a warning from the application and it just says "Ran out of memory". I'm not sure how it ran out of memory though. More than enough ram (32gb), and I increased the page size thinking that might have been the issue, but no difference.

 

Yeah, I only tried with an existing save once, and all the others were fresh installs. So that also means no Mods. 

 

I know it has something to do with my VM, my old server was also run on a VM so not sure why its giving me these issues now. Just to try, I created a server on my gaming PC and was able to load it no problem. So not sure what's wrong with this thing.

Link to comment
Share on other sites

3 hours ago, invincibleqc said:

Did you remove them from your launch options?

Yes, sorry. I know I had them in that startup script in my original post. But i've tried doing completely fresh installs in completely new VMs. I would only do the basic like below:

"start YOUR_ARK_SERVER\ShooterGame\Binaries\Win64\ArkAscendedServer.exe TheIsland_WP?listen?SessionName="SERVERNAME"?Port=7777?QueryPort=27015?-WinLiveMaxPlayers=70 -UseBattlEye"

 

Link to comment
Share on other sites

So finally found a work around....
 
I believe it has something to do with Windows Server. I tried windows server 2016 and 2022 but both could not start the Ark server. I made a Windows 11 VM and I'm now able to start up both the island and scorched earth servers...So in case you come across this with the same problem, thats the solution
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...