Jump to content

Can No Longer Connect to Self-Hosted Dedicated Server


Recommended Posts

On July 9, 2021 it was the last time we, that is a friend and me, were able to connect to my dedicated server.

Following that weekend, all I get is the following:

- When simply clicking on "Join" choosing "LAN" with the widest filter possible, it states "No servers found".

- When using "connect <ip>:<port>" as launch options in Steam:
----------------------------------------
Host Connection Timeout

Lost/timedout connection to host.
----------------------------------------

- When trying to connect using "Steam" > "View" > "Servers" > "LAN" > "Connect":
----------------------------------------
Network Failure Message

Unable to query server info for invite.
----------------------------------------
The interesting-to-observe thing is that Steam's Server window actually shows the server available with the correct information.  Also the little command-line tool "rcon", is able to connect to the server and can happily run commands.  This tool, however, is directly on the server and does not actually run remotely.

The above would assume a client or network (e.g. NAT) issue.  However, not having changed anything from where it worked before the weekend to after it, I find this unlikely.  Also, while a non-connecting friend would point to a closed port, myself trying to connect from within the LAN, this would only hold if the server itself blocks traffic to/from the computer.  Then again, I am not sure if my connections are redirected to Steam and back despite choosing to connect to a LAN-located server.


SERVER INFORMATION
The server resides inside a KVM virtual machine using Fedora 33 for both the host as well as the guest.  Regarding this virtual host, the only thing I did was shutting it down during the weekend due to server maintenance of the host.  This VM remained shut down until Monday where the friend and me met again to play.

In general, the VM receives system updates every morning at 6:00 AM local time (DNF automatic), but I disabled the automatic restart of the OS as I restart it manually here and there anyway.  So, kernel updates are applied on next manual reboot rather than directly after the installation.
Considering ARK, it is started as SystemD service as outlined on Gamepedia's ARK site with minor modification to make it instantiated (arkd@.service), so I can change the map with ease using "arkd@TheIsland.service" for example.  Since only one instance will run at any given time, a port conflict will not occur.


TROUBLESHOOTING
In the meantime, I tried the following in the attempt to fix this:
- verified game files on server and client
- stopped the firewall service (SE Linux is already on permissive, so apart from warnings, nothing would be in the way)
- removed the default route from my secondary interface temporarily (should not be in the way, but one never knows)
- moved/renamed the directory "Saved" to start with a clean slate config-wise (in case any options or mods got into the way)
- restarted with a previous kernel (in case a kernel update was at fault)
- checked traffic with "tcpdump" (all looks good)
- upgraded the guest system to Fedora 34

Nothing seems to help.  So, I am apparently looking at all the wrong places.  I honestly wonder what happened as between a perfectly working state to this state the only viable thing I did concerning this VM was a restart (potentially changing the kernel being used in the process).

If anyone still has a hint, an idea or has seen this issue before and solved it, I am more than happy to check it out.
Of course, if additional information is needed, please let me know.

Link to post
Share on other sites

Through pure coincidence, I finally fell over the issue.  It was an updated mod.  This mod was updated the day after the friend and me played the last time (July 10th).  Contrary to other games I am used to, ARK does not tell that the server uses an incompatible version or mod, but instead hides the game from the client entirely.  A fairly bad design choice as it even leaves the admins puzzled for a time.

Anyway:  Copied the mod over from the client and the server is again visible and can be joined.

If Studio Wildcard employees are reading this:  Please have the game report incompatible versions instead of hiding it entirely.  It makes troubleshooting a lot easier.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...