Jump to content

Xbox Series X Gen 2 dashboard issues


Recommended Posts

I played Gen 2 on launch with my older xbox 1 X, with little to no issues with connection. A few days ago, I got my hands on the new xbox series X, the newer faster console. It seems the performance on ark is great except for Gen 2. Not sure where to report this but I am not the only one who has it. A few of my tribemates also have the series X and have the same issue but not the people in our tribe who have older xbox's. Just wondering if this is a bug or just related to our servers. Anyone else out there experience the same issues with gen 2 and the series X? 

Link to post
Share on other sites

I have a series x and play on gen 2 as well as many other maps and havent had significant issues specific to me and my xbox. When things are lagging and bugging out its generally the whole server having issues.

And at the same time lots of people reporting that when flying a skiff into space the asteroids go invisible. That has never happened to me on the Sx so I assume its people with old machines that are having that issue.

Link to post
Share on other sites
  • Volunteer Moderator
Posted (edited)
12 minutes ago, Piffguru said:

That happened to me constantly with my old xbox one on gen1 only, since getting the SX hasnt happened since.

Ya my old Xbox was miserable. Dashboarded all the time. The XSX has only been acting up for me on Gen2. No issues on Gen1.

Edited by Joebl0w13
Link to post
Share on other sites
On 6/23/2021 at 1:21 PM, Joebl0w13 said:

With my XSX, I dashboard every single time I teleport to my base from another teleporter. 

Never happened on other maps. Good times.

same here when teleporting, I also get dashboarded randomly as well on my XSX console.  I run a really good ping and fast internet so no issues there.  Only for the Gen2 map.  Maybe in a few months with more work it will become a bit more stable.

Link to post
Share on other sites
  • Volunteer Moderator
11 minutes ago, ehuhoser said:

same here when teleporting, I also get dashboarded randomly as well on my XSX console.  I run a really good ping and fast internet so no issues there.  Only for the Gen2 map.  Maybe in a few months with more work it will become a bit more stable.

It's odd. For me, I can tele to any other teleporter on the map, no problem. But when I come back to home base. Boom.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...