Jump to content

accidentally closing ARK window during play


Recommended Posts

I'm playing ARK on a 43" monitor on my PC, it's too big to play the game maximised, so i'm playing in a window. The problem is (and I don't know how or why), is that sometimes I manage to minimise/maximise or even close the window during gameplay. It's super damned annoying, especially now that i'm playing PvE and it happens while i'm being attacked. Anyone know how to resolve this? 

Link to post
Share on other sites
1 hour ago, TroyParry said:

I'm playing ARK on a 43" monitor on my PC, it's too big to play the game maximised, so i'm playing in a window. The problem is (and I don't know how or why), is that sometimes I manage to minimise/maximise or even close the window during gameplay. It's super damned annoying, especially now that i'm playing PvE and it happens while i'm being attacked. Anyone know how to resolve this? 

Sounds like your mouse is leaving the ark window? I know that your mouse comes "detached/loose" when you have an interface open. You could solve this by disabling the buttons(not sure if I am allowed to share it on the forums how to do it)

Link to post
Share on other sites
19 hours ago, Piffguru said:

What do you mean its too big to play? I play on a 50" with no problems. If you are seeing the toolbar being cut off then you need to go into the options to fix it.

I'm sitting too close to the monitor for full screen, 43" is too big to look at (I mostly use it for Photoshop, and generally having many things on the screen at once). I don't want the game to run full screen.

Link to post
Share on other sites
23 hours ago, Oli4 said:

Sounds like your mouse is leaving the ark window? I know that your mouse comes "detached/loose" when you have an interface open. You could solve this by disabling the buttons(not sure if I am allowed to share it on the forums how to do it)

It generally happens during battles when there's lots of keys being pressed and mouse movement. I'm unable to replicate the problem, it just happens at the most inconvenient time. My mouse doesn't normally leave the screen, even if i'm going through in-game popups.

As far as i'm aware, i'm just using mouse and shift/E/A/S/D/spacebar/numbers at the same time. I will sometimes accidentally minimise, maximise, or even close the entire game.

Link to post
Share on other sites
14 minutes ago, TroyParry said:

It generally happens during battles when there's lots of keys being pressed and mouse movement. I'm unable to replicate the problem, it just happens at the most inconvenient time. My mouse doesn't normally leave the screen, even if i'm going through in-game popups.

As far as i'm aware, i'm just using mouse and shift/E/A/S/D/spacebar/numbers at the same time. I will sometimes accidentally minimise, maximise, or even close the entire game.

I can share a simple fix for it that would hide the minimize/maximize/close button if you want. It is written in AHK

 

Other option what might happen is:

- you are pressing the windowskey+arrowkey

-You got some macros assigned?

Edited by Oli4
Link to post
Share on other sites
14 minutes ago, Oli4 said:

I can share a simple fix for it that would hide the minimize/maximize/close button if you want. It is written in AHK

 

#NoEnv
SendMode Input
SetWorkingDir %A_ScriptDir%

^F2::WinSet, Style, -0x80000, A
^F3::WinSet, Style, +0x80000, A

; https://docs.microsoft.com/en-us/windows/win32/winmsg/window-styles 0x80000 is WS_SYSMENU. with WinSet, Style, -0x80000 you remove the WS_SYSMENU. With the +0x80000 you create it again

Save this as anythingyouwant.ahk and run it. Ctrl+F2 will hide the buttons, Ctrl+F3 will show them again. it'll still maximize the window if you doubleclick on the top bar though(could disable that too)

Edited by Oli4
Link to post
Share on other sites
2 hours ago, Oli4 said:

 


#NoEnv
SendMode Input
SetWorkingDir %A_ScriptDir%

^F2::WinSet, Style, -0x80000, A
^F3::WinSet, Style, +0x80000, A

; https://docs.microsoft.com/en-us/windows/win32/winmsg/window-styles 0x80000 is WS_SYSMENU. with WinSet, Style, -0x80000 you remove the WS_SYSMENU. With the +0x80000 you create it again

Save this as anythingyouwant.ahk and run it. Ctrl+F2 will hide the buttons, Ctrl+F3 will show them again. it'll still maximize the window if you doubleclick on the top bar though(could disable that too)

I don't have any macros or customisation. Just got AHK running, will let you know if it still happens, thanks!

 

Link to post
Share on other sites
On 3/3/2021 at 6:03 PM, Oli4 said:

I can share a simple fix for it that would hide the minimize/maximize/close button if you want. It is written in AHK

 

Other option what might happen is:

- you are pressing the windowskey+arrowkey

-You got some macros assigned?

Sadly the issue still happens, it's definitely the mouse leaving the playable area. It even happens just after i've pressed a number to select my weapon then i'm double-clicking the mouse to attack. The mouse clicking could double-click the window header, causing the game to maximise/minimise. I've also managed to click the browser window that was sitting behind it.

Link to post
Share on other sites
1 hour ago, TroyParry said:

Sadly the issue still happens, it's definitely the mouse leaving the playable area. It even happens just after i've pressed a number to select my weapon then i'm double-clicking the mouse to attack. The mouse clicking could double-click the window header, causing the game to maximise/minimise. I've also managed to click the browser window that was sitting behind it.

 

Try this, this will hide the bar on top and lock your mouse inside the game client, can toggle with ctrl+f3. If something goes wrong you can press F4 to reload it.

#NoEnv
SendMode Input
SetWorkingDir %A_ScriptDir%

clipcursor(hwnd := "") {
    static unclip := DllCall("GetCursor")

    if hwnd {
        WinSet, Style, -0xC00000, A
        WinGetPos, rx, ry, rw, rh, ahk_id %hwnd%
        VarSetCapacity(rclip, 16)
        NumPut(rx, &rclip+0)
        NumPut(ry, &rclip+4)
        NumPut(rw + rx, &rclip+8)
        NumPut(rh + ry, &rclip+12)
    } else
        WinShow ahk_class Shell_TrayWnd
    return DllCall("ClipCursor", Ptr, hwnd ? &rclip : &unclip)
}

^f3::
lock:=!lock
if lock 
    SetTimer, locker, 0
else 
{
    SetTimer, locker, off
    WinSet, Style, +0xC00000, A
}
return

locker:
    clipcursor(winexist("ahk_class Shell_TrayWnd") ? winexist("ARK: Survival Evolved") : "")
return

f4::reload
return

 

Edited by Oli4
Link to post
Share on other sites
2 hours ago, Oli4 said:

 

Try this, this will hide the bar on top and lock your mouse inside the game client, can toggle with ctrl+f3. If something goes wrong you can press F4 to reload it.


#NoEnv
SendMode Input
SetWorkingDir %A_ScriptDir%

clipcursor(hwnd := "") {
    static unclip := DllCall("GetCursor")

    if hwnd {
        WinSet, Style, -0xC00000, A
        WinGetPos, rx, ry, rw, rh, ahk_id %hwnd%
        VarSetCapacity(rclip, 16)
        NumPut(rx, &rclip+0)
        NumPut(ry, &rclip+4)
        NumPut(rw + rx, &rclip+8)
        NumPut(rh + ry, &rclip+12)
    } else
        WinShow ahk_class Shell_TrayWnd
    return DllCall("ClipCursor", Ptr, hwnd ? &rclip : &unclip)
}

^f3::
lock:=!lock
if lock 
    SetTimer, locker, 0
else 
{
    SetTimer, locker, off
    WinSet, Style, +0xC00000, A
}
return

locker:
    clipcursor(winexist("ahk_class Shell_TrayWnd") ? winexist("ARK: Survival Evolved") : "")
return

f4::reload
return

 

I've loaded it and will test tomorrow, thanks once again! ❤️

Link to post
Share on other sites
On 3/4/2021 at 11:42 PM, Oli4 said:

 

Try this, this will hide the bar on top and lock your mouse inside the game client, can toggle with ctrl+f3. If something goes wrong you can press F4 to reload it.


#NoEnv
SendMode Input
SetWorkingDir %A_ScriptDir%

clipcursor(hwnd := "") {
    static unclip := DllCall("GetCursor")

    if hwnd {
        WinSet, Style, -0xC00000, A
        WinGetPos, rx, ry, rw, rh, ahk_id %hwnd%
        VarSetCapacity(rclip, 16)
        NumPut(rx, &rclip+0)
        NumPut(ry, &rclip+4)
        NumPut(rw + rx, &rclip+8)
        NumPut(rh + ry, &rclip+12)
    } else
        WinShow ahk_class Shell_TrayWnd
    return DllCall("ClipCursor", Ptr, hwnd ? &rclip : &unclip)
}

^f3::
lock:=!lock
if lock 
    SetTimer, locker, 0
else 
{
    SetTimer, locker, off
    WinSet, Style, +0xC00000, A
}
return

locker:
    clipcursor(winexist("ahk_class Shell_TrayWnd") ? winexist("ARK: Survival Evolved") : "")
return

f4::reload
return

 

It's still happening, I have no idea why i'm able to sometimes click my chrome browser that is open behind it. I'll try minimising stuff behind it to see if i'm able to play the game uninterrupted.

Link to post
Share on other sites

There are a lot of control keys commands in Windows which accidently can be triggered.

Me for example is using Shift-Key and Alt-Key for strafing left/right. That can be done in the ARK setup but it makes too much problems. Therefore the keys are remapped with:

LShift::Left
LAlt::Right

By this way any interfering of Shift- and Alt-commands is prevented.

Link to post
Share on other sites
On 3/6/2021 at 9:48 PM, Zapha said:

There are a lot of control keys commands in Windows which accidently can be triggered.

Me for example is using Shift-Key and Alt-Key for strafing left/right. That can be done in the ARK setup but it makes too much problems. Therefore the keys are remapped with:

LShift::Left
LAlt::Right

By this way any interfering of Shift- and Alt-commands is prevented.

I found out it's purely to do with the mouse. If I look up, it makes my mouse move up, until it eventually ends probably 1 pixel above my game window, then the mouse cursor becomes visible. Then when I right click, it's clicking behind the ARK window, which in the pics below is my desktop (black background).

 

Below pics are when I look up, and when I right click.

ark look up.png

Ark right click.png

Link to post
Share on other sites
On 3/6/2021 at 9:48 PM, Zapha said:

There are a lot of control keys commands in Windows which accidently can be triggered.

Me for example is using Shift-Key and Alt-Key for strafing left/right. That can be done in the ARK setup but it makes too much problems. Therefore the keys are remapped with:

LShift::Left
LAlt::Right

By this way any interfering of Shift- and Alt-commands is prevented.

I'm running my windows at 3840x2160, and below is my ARK settings. Anything strange? It doesn't seem right that my mouse is able to leave the window.

 

 

ARK settings.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...