Jump to content

"Procedure entry point" - Potentially critical game bug?


Recommended Posts

"Procedure entry point" - Potentially critical game bug?

So, first off. I'd like to know why bug reports aren't public, and why the "currently recognized submitted" bugs, only shows 3, when we all know there are hundreds.

Now then, to explain what this bug is that I'm here to talk about;

1394594056_Annotation2020-08-09004045.thumb.png.dcdd27a3e98bb01932c67d656e7c980b.png

This bug, crashes a core part of Windows 10. Explorer.exe, crashing anything that depends upon it as well. Remote Desktop, any open folders get closed, nVidia Share recording gets corrupted and crashes till you reboot computer, it breaks my start menu by blurring the start menu until I click "ok" on the error (likely because it glitches the renderer in the start menu that applies blur behind the start menu causing it to blur in front instead).
**Clarification** File Explorer, automatically reboots after it has crashed, however, it still takes out other processes with it in the cascade, which do not automatically come back, some of which, require a reboot of the machine, to get back.

This bug doesn't harm the game in any way, and came when they started using Epic Games Launcher for the game too. However, I place it in the critical category, because it crashes core Windows process which cascades to crash other processes too, ultimately requiring a reboot to fix some of the damage.
**Clarification** I do not use Epic Games Launcher. I use Steam. I just know that this bug started happening around the time crossplay and all that became a thing. I was on a break for a few months, but the bug happened in the last few months sometime and the reports I've seen all seem to indicate around the release of the crossplay or Epic Games version or whatever.

The error exactly as it shows with all spaces:

The procedure entry point  could not be located in the dynamic link library .

My bug report: https://survivetheark.com/index.php?/pc-bug-reports/procedure-entry-point-causes-windows-apps-to-close-and-crash-r41786/

It is my belief that bug reports should be public, so that people can come in and say "I have this too, my specs are this", so that we can compile a list of, who has the problem, where the problem is, what causes it by comparing the similarities between the machines that have it. It makes it far easier to diagnose when people can join in on a bug report, than when you have 2,000 separate bug reports on the same issue. Or, people who don't bother reporting the issue because they are lazy and your bug report form is large and requires a ton of information, when a public bug report, people can jump in and say "I have the same issue with the same settings except I play on a different map!".

Reproduction? Well, all you have to do is launch the game.
There are no mods relevant to this, no total conversions are loaded on my game.
No maps are relevant to this either.
It literally happens, the instant I launch the game and the splash screen has passed.

Steps taken to fix?
Personally I have not taken all of these steps, I looked at reports of people who did take steps and they took the basics and some the extreme.
Verified game files,
Changed launch options,
Running SFC Scan,
Reinstalled Visual C++,
Reinstalled graphics driver, (I did this, and it did not help. One person says it did.)

System Specs: https://valid.x86.fr/scg14b

Edited by Vas
More info. Clarifications.
Link to post
Share on other sites

I figure I'll throw in some error logs I found in Event Viewer at the exact moment of the crash related to launching Ark.

Log Name:      Application
Source:        Microsoft-Windows-Winlogon
Date:          8/18/2020 7:55:19 AM
Event ID:      1002
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      FluffyGamerPC
Description:
The shell stopped unexpectedly and explorer.exe was restarted.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Winlogon" Guid="{DBE9B383-7CF3-4331-91CC-A3CB16A3B538}" EventSourceName="Wlclntfy" />
    <EventID Qualifiers="16384">1002</EventID>
    <Version>0</Version>
    <Level>4</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-08-18T12:55:19.098323700Z" />
    <EventRecordID>10254</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>FluffyGamerPC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>explorer.exe</Data>
  </EventData>
</Event>
Log Name:      System
Source:        Application Popup
Date:          8/18/2020 7:55:30 AM
Event ID:      26
Task Category: None
Level:         Information
Keywords:      
User:          SYSTEM
Computer:      FluffyGamerPC
Description:
Application popup: ARK: Survival Evolved: ShooterGame.exe - Entry Point Not Found : The procedure entry point  could not be located in the dynamic link library . 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Popup" Guid="{47bfa2b7-bd54-4fac-b70b-29021084ca8f}" />
    <EventID>26</EventID>
    <Version>0</Version>
    <Level>4</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000000000000000</Keywords>
    <TimeCreated SystemTime="2020-08-18T12:55:30.966910000Z" />
    <EventRecordID>15394</EventRecordID>
    <Correlation />
    <Execution ProcessID="124" ThreadID="23072" />
    <Channel>System</Channel>
    <Computer>FluffyGamerPC</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="Caption">ARK: Survival Evolved: ShooterGame.exe - Entry Point Not Found</Data>
    <Data Name="Message">The procedure entry point  could not be located in the dynamic link library . </Data>
  </EventData>
</Event>

 

Edited by Vas
Remove Syntax Highlights
Link to post
Share on other sites
  • 7 months later...

So, an update today. Nuclearist, in Super Structure's discord mentioned that this error occurs because of a corrupted system file. He told me to run SFC /scannow to fix it, so I did. Rebooted. The game stopped having the error anymore.

The Easter update happened, and the error came back. Just like before, I updated Windows, the error disappeared. Then after Ark updated, the error came back.

I now suspect that every time Ark updates, it is corrupting a system file.

Link to post
Share on other sites

Looks like either your disk is silently failing, or you have some kind of virus. The message "Entry Point not found" in any executable indicates that this .exe file broken/corrupted. And something in your case is consistently breaking it. Either because the OS persists in writing the newly downloaded .exe to the same faulty sectors on your drive or because you have a virus that is busting this .exe.  Maybe try a CHKDSK /f on your drive (you will have to boot to let it do its business)

Link to post
Share on other sites

I ran another integrity check today, after the update. No integrity violations, and the error is still happening. This indicates to me that the game is the cause of the error, nothing outside the game. It was pure coincidence the error went away the first time. However it does come back every game update.

I have run numerous chkdsks as well. Its a standard procedure in AVG to check the disk occasionally. My SSDs are fine.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...