Jump to content

Recommended Posts

RECOVER greyed-out creatures in obelisk

After searching and finding no real solution except to delete dinos in the obelisk I figured out how to recover greyed-out dinos from the obelisk without losing items in the obelisk, map data, explorer notes, or skins!

First off I am using Classic Flyers mod on Singleplayer, patch 312.15 on Steam. No upload timers, transfer and upload enabled. I suspect that updating the game/mod bugged it. My other mods are Better Reusables, Auto Engrams!, Ultra Stacks, Structures Plus, Automated Ark 3, Meat Spoiler, Awesome Spyglass, and Dinotracker.

Now, to do this you need 3 variables specific to each dino breed: 2 letters & 1 nickname. I haven't tamed nor uploaded all dinos so I don't know the specific letters and nicknames for each one, but you can find out if you upload a dino of the same species to the obelisk, then examine your "PlayerLocalData.arkprofile" for the corresponding letters and nicknames. I'll show you how to fix a stuck Argentavis and a Pteranodon on the Island map.

First make sure you’ve exited ARK and downloaded Notepad++. This is important because it preserves the null characters in ANSI and allows you to enter some as well because you can't seem to copy/paste them.

Backup your game save and local data profile in “C:\Program Files (x86)\Steam\steamapps\common\ARK\ShooterGame\Saved\LocalProfiles\PlayerLocalData.arkprofile”.

Search (Ctrl+F) the dino’s name who is greyed out, and a few lines above the name should be 3 lines containing “/Game/Maps/TheIslandSubMaps/TheIsland”

Above those lines should be “ObjectPropertyNULLBSNULLNULLNULLNULLNULLNULLNULLNULLNULLNULLNULLÿÿÿÿ” I’ve attached a photo of the text editor highlighting the specific line we’re looking for — “obbie,” in this case, is the Argentavis' name.

Carefully, preserving every space and null character of the file, leave the first "NULL" after "ObjectProperty" and replace the null character “BS” with the first letter corresponding to your dino. In our case, the Argentavis, “p” after the first "NULL".

Leave the next 7 “NULL”s, insert “SOH” using “Edit>Character Panel” and finding “SOH” under the “Character” column. Make sure not to click the "Value" or "Hex" columns as it will enter a number instead of "SOH".

 Leave the next 3 “NULL”s, enter the second letter corresponding to your dino. In our case, the Argentavis, “h”. After “h” there should be 1 more “NULL”, add 2 more.

Replace “ÿÿÿÿ” with “BlueprintGeneratedClass”, a space, and the dino-specific blueprint file path. Underneath that line you should find what dino nickname it is that you’re working on but the Classic Flyer nicknames used in the file path can be found under the mod ID folder in “C:\Program Files (x86)\Steam\steamapps\common\ARK\ShooterGame\Content\Mods\895711211\Dinos”, are currently listed for me as Argent, Griffin, Harpagornis, Moth, Pela, Phoenix, Ptero, Quetz, Tapejara, and Wyvern. The file path format is “/Game/Mods/ClassicFlyers/Dinos/Nickname/Nickname_Character_BP.Nickname_Character_BP_C”

For me, since it’s a Classic Flyers Argentavis, I replaced “ÿÿÿÿ” with “BlueprintGeneratedClass /Game/Mods/ClassicFlyers/Dinos/Argent/Argent_Character_BP.Argent_Character_BP_C”. Add a “NULL” after that, and make sure to keep the space after it and the 3 “NULL”s before “DinoData”.

Your new line should look like this:

“ObjectPropertyNULLpNULLNULLNULLNULLNULLNULLNULLSOHNULLNULLNULLhNULLNULLNULLBlueprintGeneratedClass /Game/Mods/ClassicFlyers/Dinos/Argent/Argent_Character_BP.Argent_Character_BP_CNULL NULLNULLNULLDinoData”

Now save the file and make sure it is named “PlayerLocalData.arkprofile”. Open the game and test at the obelisk!

The letters for pteranodon I used are "m", "e", and "Ptero" for the nickname.

Cheers to this thread for leading me down the rabbit hole to find what file and section to mess with:

 

 

I figured this out by uploading a flyer in the obelisk alongside my corrupted ones stuck there and compared the two files side-by-side to spot the difference. You should make sure Notepad++ is viewing the file as ANSI if it doesn't by default. I imagine this could be done with vanilla dinos but I haven’t uploaded any so I don’t know the specific letters and nicknames. Hope this helps!

arkobbiefix.png

Edited by zzzmarshmallow
grammar
  • Like 2
  • Thanks 2
Link to post
Share on other sites
  • 3 months later...
  • 4 weeks later...

 

Which dinos and what did you type in the files? Is this in singleplayer? Any mods? Impossible to help without more info. 

Mine deleted when I put the wrong dino letters/nickname.

On 6/27/2020 at 9:39 PM, zzzmarshmallow said:

to do this you need 3 variables specific to each dino breed: 2 letters & 1 nickname. I haven't tamed nor uploaded all dinos so I don't know the specific letters and nicknames for each one, but you can find out if you upload a dino of the same species to the obelisk, then examine your "PlayerLocalData.arkprofile" for the corresponding letters and nicknames.

I had an argy stuck so I uploaded a new argy ("eggie") and exited the game. I looked in PlayerLocalData.arkprofile until I come across dinos stored in the obelisk. I'll attach a screenshot to show where I got "p", "h", and "Argent" as the "2 letters & 1 nickname" referenced above for the Argentavis.

On 6/27/2020 at 9:39 PM, zzzmarshmallow said:

replace the null character “BS” with the first letter corresponding to your dino. In our case, the Argentavis, “p”

On 6/27/2020 at 9:39 PM, zzzmarshmallow said:

Leave the next 3 “NULL”s, enter the second letter corresponding to your dino. In our case, the Argentavis, “h”.

On 6/27/2020 at 9:39 PM, zzzmarshmallow said:

For me, since it’s a Classic Flyers Argentavis, I replaced “ÿÿÿÿ” with “BlueprintGeneratedClass /Game/Mods/ClassicFlyers/Dinos/Argent/Argent_Character_BP.Argent_Character_BP_C”.

 

 

PlayerLocalDataObjectProperty.jpeg

Link to post
Share on other sites
  • 3 weeks later...

Hello.. I am havign the same issue. I have 2 argies stuck in the obelisk.. i have followed this to the best of my abilities and all it does is delete them.. I was trying to move them from a Valguero map server a friend of mine uses.. Non official multi player. To a Ragnarok server I run from my second computer, again non official, but multi player. I dont know what else to do.. Any ideas would be helpful. Attaching the original profile file to see if that helps.. the argies are named Hades and Redcrest.. TY

PlayerLocalDataold.arkprofile

Link to post
Share on other sites
  • 4 weeks later...

Unfortunately I've run into the same problem:

I uploaded a couple of argies on The Island map (server), then the server switched maps twice (Abberation, then Valguero) and on the second map I noticed that all of them were greyed out. They were all classic flyers (and only classic flyer dinos corrupted, non-flyers were fine!), so I copied your "BlueprintGeneratedClass /Game/Mods/ClassicFlyers/Dinos/Argent/Argent_Character_BP.Argent_Character_BP_C" part.

I did change one thing: I removed the space after "BlueprintGeneratedClass" because it looked like a mistake - did you add that one on purpose?

Edit: Tried it with the space and it still cleared everything. The last thing I can think of: Should there maybe be a tab instead of a regular space?

Edit 2: Not sure if the additional space is important but the blueprint bit has to be followed by a tab, NOT a space - and it worked! :) Thanks for the guide! Something weird I noticed: The "ByteProperty" (line below) doesn't say "DC2DC4" like in your screenshot but "‰5", I didn't have to edit that though. I also didn't have to check anything in terms of ANSI.

Edited by Nephtys
Link to post
Share on other sites
  • 3 weeks later...

A short update:

I managed to restore all of my classic flyers that were greyed out, even my wyvern, so thank you again!

Info for a lightning wyvern:

First letter: „

Second letter: |

If copying from the forums doesn't work, upload a poopty one yourself and copy the symbols.

Path: "BlueprintGeneratedClass /Game/Mods/ClassicFlyers/Dinos/Wyvern/Wyvern_Character_BP_Lightning.Wyvern_Character_BP_Lightning_C" (of course without the "")

And yes, you do need the space after "BlueprintGeneratedClass"!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...