Jump to content

DNL

Epic games server non-dedicated

Recommended Posts

3 hours ago, Smok1ngAce said:

As i using win10, i'll describe steps for this version (you'll need administrator rights):
Press "start" (or "windows" key), type in "defender", open "Windows Defender Firewall".
On left tab would be "Allow an app or feature through Windows Defender Firewall", press it.
Press "Change settings" button on top-right of list, then find game .exe file (must be ShooterGame) and check both boxes (like on screenshot).Scr1.thumb.png.86639b2f67a383994d676adfdb559d0c.png

tried it still did not work hope they fix this soon i am still getting errors after the update they sent to EGS

Share this post


Link to post
Share on other sites
Posted (edited)

After 3 days of trying everything (disable firewall, port forwarding, etc.) I finally found a way to play ARK together with my wife in our LAN.

 

1. Person A (host) hosts a non-dedicated server and looks up his IP adress.

2. Person B (joiner) needs to start a single player game.

3. Person B presses TAB to open the console and types open ipofhost:7777 (e.g. 192.123.234.56:7777).

 

 

Edited by Suricate

Share this post


Link to post
Share on other sites
Posted (edited)

After 3 days of trying everything (disable firewall, port forwarding, etc.) I finally found a way to play ARK together with my wife in our LAN.

 

1. Person A (host) hosts a non-dedicated server and looks up his IP adress.

2. Person B (joiner) needs to start a single player game.

3. Person B presses TAB to open the console and types open ipofhost:7777 (e.g. 192.123.234.56:7777).

 

 

Edited by Suricate

Share this post


Link to post
Share on other sites
Posted (edited)

Hey everyone! I have been horsing around with this with my wife all day now to try and make it work, and I wanted to confirm the fix for everyone! 100% Running the game without the anti cheat program allowed us to create a Non-Dedicated Server and connect together without getting the "Failed to connect." error. I was going to post a video here, but I'm having some issues so I will post a little step by step here. These tips below are all that I did to be able to finally create/host a Non-dedicated server and have my wife join that server without getting the "Failed to Connect" error. HOPEFULLY THIS HELP!!! Fingers Crossed!

#1 - Run ARK Without Anti Cheat

Open Epic Games Launcher  --->  Go to Library  --->  Click the 3 dots next to the title "ARK: Survival Evolved"  --->  Select the top option "Play ARK: No BattleEye AntiCheat, Unoffical Servers Only"

 

#2 - Increase Tether Distance Setting In ARK

On the ARK main menu, select Host \ Local  --->   In the settings on the left hand side, scroll down until you see "Non-dedicated Host Tether Distance"  --->  Type 99 in the box to increase this distance

 

#3 - Allow ARK To Communicate Through Private and Public Networks

Open Control Panel  --->  Select Windows Defender Firewall  --->  Near the top left, select the option "Allow an app or feature through Windows Defender Firewall"  --->  Scroll down the list off applications until you see "Shooter Game"  --->  Make sure both the Public and Private boxes are checked (You may have to click the "Change Settings" box in the top right to allow you to check these boxes

 

#4 - Open ARK Ports In Your Windows Firewall

Open Control Panel  --->  Select Windows Defender Firewall  ---> On the left side, select the "Advanced Settings" option  --->  Near the top left, double click the "Inbound Rules" icon  --->  On the right side click on "New Rule..."  --->  In the new window that opens, select the "Port" bubble, then hit Next  --->  Select the "UDP" bubble, then in the "Specific local ports" box paste 27015, 7777, 7778 then hit Next --->  Make sure the "Allow the connection" bubble is selected, then hit Next  --->  Make sure the "Domain" "Private" and "Public" boxes are selected, then hit next  --->  Enter "ARK Ports" in the name, then hit Finish

On the right side click on "New Rule..." again --->  In the new window that opens, select the "Port" bubble, then hit Next  --->  Select the "TCP" bubble, then in the "Specific local ports" box paste 27020 then hit Next --->  Make sure the "Allow the connection" bubble is selected, then hit Next  --->  Make sure the "Domain" "Private" and "Public" boxes are selected, then hit next  --->  Enter "ARK Optional Ports" in the name, then hit Finish

 

#5 - Allow Port Forwarding to

This is the only tricky one, as it will change depending on your Router/ISP, as you will have to log into your router to add the ports to the port forwarding list. The ports will be the same ones we added to Windows Defender Firewall (UDP 27015, 7777, 7779)(TCP 27020). I've pasted below a great How To Setup Port Forwarding link with pictures and instructions on how to do so.

https://www.wikihow.com/Set-Up-Port-Forwarding-on-a-Router

Edited by GuyFatal

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Biuske said:

Can u pass your discord to me ? 

I have some question

 

18 hours ago, zTohka said:

can you please give me your discord ? i want to ask you something about the port forwarding

discord - Smok1ng_Ace#5338

General: as i found out from a lot of guides, there are three ports that should be forwarded for server to be visible and connectable online: 7777, 7778, 27015.


Non-Dedicated: found a guide how to allow player go further away from game host:
https://www.youtube.com/watch?v=nsfyKKpJj3U
Tried with friend, set this on 999.0 instead of 99.0. Yea, for this trick non-dedicated host should have a powerful PC tho (tried on i7-8700 + RTX 2080 and FX-8300 + RX 580, on second config were laggy af).

Dedicated (AKA Unofficial): with last client update dedicated server have shown up in unofficial server list and friends (and some other guys on EGS version, tested without password with -epiconly) were able to join it. But seems like i can't host dedicated server and join it from same PC. Found a thread with same problem:

But seems like my router doesn't have NAT-loopback function. Gonna try to workaround this. Would share it here if i'd get succeed.

Edited by Smok1ngAce

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Suricate said:

After 3 days of trying everything (disable firewall, port forwarding, etc.) I finally found a way to play ARK together with my wife in our LAN.

 

1. Person A (host) hosts a non-dedicated server and looks up his IP adress.

2. Person B (joiner) needs to start a single player game.

3. Person B presses TAB to open the console and types open ipofhost:7777 (e.g. 192.123.234.56:7777).

 

 

Yeah, it seems to work on LAN, but it won't work if players aren't in same local network. U don't need port forwarding to play on LAN Non-Dedicated server with this trick, and u should have only private network access allowed in firewall settings instead of public.
Probably it would work even if gamers are far from each other but only in case u'd make a tunnel connection between all players (Hamachi should be ok as it creates a LAN-network too) it should work with this solution. But you'd have to use host ip that is in Hamachi. Well, still doesn't sure if it works, cause not sure if ARK setting up a direct connect for "open ip:port password" command.

Edited by Smok1ngAce

Share this post


Link to post
Share on other sites
On 6/15/2020 at 9:19 AM, Smok1ngAce said:

 

discord - Smok1ng_Ace#5338

General: as i found out from a lot of guides, there are three ports that should be forwarded for server to be visible and connectable online: 7777, 7778, 27015.


Non-Dedicated: found a guide how to allow player go further away from game host:
https://www.youtube.com/watch?v=nsfyKKpJj3U
Tried with friend, set this on 999.0 instead of 99.0. Yea, for this trick non-dedicated host should have a powerful PC tho (tried on i7-8700 + RTX 2080 and FX-8300 + RX 580, on second config were laggy af).

Dedicated (AKA Unofficial): with last client update dedicated server have shown up in unofficial server list and friends (and some other guys on EGS version, tested without password with -epiconly) were able to join it. But seems like i can't host dedicated server and join it from same PC. Found a thread with same problem:

But seems like my router doesn't have NAT-loopback function. Gonna try to workaround this. Would share it here if i'd get succeed.

nvm its okay i used hamachi instead of port forward

Share this post


Link to post
Share on other sites
On 6/15/2020 at 5:15 AM, GuyFatal said:

Hey everyone! I have been horsing around with this with my wife all day now to try and make it work, and I wanted to confirm the fix for everyone! 100% Running the game without the anti cheat program allowed us to create a Non-Dedicated Server and connect together without getting the "Failed to connect." error. I was going to post a video here, but I'm having some issues so I will post a little step by step here. These tips below are all that I did to be able to finally create/host a Non-dedicated server and have my wife join that server without getting the "Failed to Connect" error. HOPEFULLY THIS HELP!!! Fingers Crossed!

#1 - Run ARK Without Anti Cheat

Open Epic Games Launcher  --->  Go to Library  --->  Click the 3 dots next to the title "ARK: Survival Evolved"  --->  Select the top option "Play ARK: No BattleEye AntiCheat, Unoffical Servers Only"

 

#2 - Increase Tether Distance Setting In ARK

On the ARK main menu, select Host \ Local  --->   In the settings on the left hand side, scroll down until you see "Non-dedicated Host Tether Distance"  --->  Type 99 in the box to increase this distance

 

#3 - Allow ARK To Communicate Through Private and Public Networks

Open Control Panel  --->  Select Windows Defender Firewall  --->  Near the top left, select the option "Allow an app or feature through Windows Defender Firewall"  --->  Scroll down the list off applications until you see "Shooter Game"  --->  Make sure both the Public and Private boxes are checked (You may have to click the "Change Settings" box in the top right to allow you to check these boxes

 

#4 - Open ARK Ports In Your Windows Firewall

Open Control Panel  --->  Select Windows Defender Firewall  ---> On the left side, select the "Advanced Settings" option  --->  Near the top left, double click the "Inbound Rules" icon  --->  On the right side click on "New Rule..."  --->  In the new window that opens, select the "Port" bubble, then hit Next  --->  Select the "UDP" bubble, then in the "Specific local ports" box paste 27015, 7777, 7778 then hit Next --->  Make sure the "Allow the connection" bubble is selected, then hit Next  --->  Make sure the "Domain" "Private" and "Public" boxes are selected, then hit next  --->  Enter "ARK Ports" in the name, then hit Finish

On the right side click on "New Rule..." again --->  In the new window that opens, select the "Port" bubble, then hit Next  --->  Select the "TCP" bubble, then in the "Specific local ports" box paste 27020 then hit Next --->  Make sure the "Allow the connection" bubble is selected, then hit Next  --->  Make sure the "Domain" "Private" and "Public" boxes are selected, then hit next  --->  Enter "ARK Optional Ports" in the name, then hit Finish

 

#5 - Allow Port Forwarding to

This is the only tricky one, as it will change depending on your Router/ISP, as you will have to log into your router to add the ports to the port forwarding list. The ports will be the same ones we added to Windows Defender Firewall (UDP 27015, 7777, 7779)(TCP 27020). I've pasted below a great How To Setup Port Forwarding link with pictures and instructions on how to do so.

https://www.wikihow.com/Set-Up-Port-Forwarding-on-a-Router

Thanks so much for all the effort you've made to help us with this post first of all!
Second, I'm at the port forwarding section, and my router is a bit different from your description.
I'll list the settings if you're able to help as I'm not sure how to proceed with where to put the ports you listed above (The UDP and TPC ones) into this setup.
In order from top to bottom:
Local ip.. it has 192.168.178.0 should I change this as my person device ip is just a bit different?

Local start port - 0
Local end port - 0
External start port - 0
External end port - 0
Protocol (I chose "both)
Enabled - and it has On, Off, as the options.

Thanks again so much, I hope this works, but either way I appreciate your efforts.

Share this post


Link to post
Share on other sites
Posted (edited)

I forgot to say to my above comment that the options in this "security" section include: Firewall, MAC filtering, IP and port filtering, Port forwarding (the section I entered!), Port Triggering, and DMZ.

 

EDIT: Also, forgot to say that obviously I'm on PC, but would this work for someone on an XBOX to connect with ME? Should they or I try to host?
Thanks!

Edited by BigFuzzyBear

Share this post


Link to post
Share on other sites

Okay i have some information. As i have just seen epic can't do much. I contacted ark and they said
Thank you for contacting Studio Wildcard Customer Support.
We are sorry to hear about your issues with there private servers. As Customer Support, there are limitations on the amount of support we are able to offer in regards to this. For more information on private servers, please click here. We hope you find this link useful!

So they cant do anything either. Me and my friend have tried multiple things and we can't do anything. So in conclusion, this game is broken and probably won't be fixed until a patch is released. Sorry to break it to you. It confuses me how Vannoss gaming can do this though, it might just be EU servers.

Share this post


Link to post
Share on other sites
On 6/18/2020 at 10:21 AM, BigFuzzyBear said:

I forgot to say to my above comment that the options in this "security" section include: Firewall, MAC filtering, IP and port filtering, Port forwarding (the section I entered!), Port Triggering, and DMZ.

 

EDIT: Also, forgot to say that obviously I'm on PC, but would this work for someone on an XBOX to connect with ME? Should they or I try to host?
Thanks!

It won't work, ARK includes crossplay only for PC.

 

On 6/18/2020 at 10:19 AM, BigFuzzyBear said:

Thanks so much for all the effort you've made to help us with this post first of all!
Second, I'm at the port forwarding section, and my router is a bit different from your description.
I'll list the settings if you're able to help as I'm not sure how to proceed with where to put the ports you listed above (The UDP and TPC ones) into this setup.
In order from top to bottom:
Local ip.. it has 192.168.178.0 should I change this as my person device ip is just a bit different?

Local start port - 0
Local end port - 0
External start port - 0
External end port - 0
Protocol (I chose "both)
Enabled - and it has On, Off, as the options.

Thanks again so much, I hope this works, but either way I appreciate your efforts.

U should forward ports 7777, 7778, 27015. If u might create only 1 rule for port forwarding, then try to set this:

Local start port - 7777
Local end port - 7778
External start port - 7777
External end port - 7778
Protocol - UDP
Enabled - On

Don't forget about firewall rules, cause if u won't make game visible in public network it wouldn't be in non-dedicated server list.
After this done ur server should be connectable from EGS version in-game server list.

Share this post


Link to post
Share on other sites
17 hours ago, TiChopstick said:

Okay i have some information. As i have just seen epic can't do much. I contacted ark and they said
Thank you for contacting Studio Wildcard Customer Support.
We are sorry to hear about your issues with there private servers. As Customer Support, there are limitations on the amount of support we are able to offer in regards to this. For more information on private servers, please click here. We hope you find this link useful!

So they cant do anything either. Me and my friend have tried multiple things and we can't do anything. So in conclusion, this game is broken and probably won't be fixed until a patch is released. Sorry to break it to you. It confuses me how Vannoss gaming can do this though, it might just be EU servers.

Vanoss probably bought a server from Nitrado

Share this post


Link to post
Share on other sites

after the yesterday's update i'm able to very few dedicated servers,but the connect lost error is still happening while i'm trying to connect my friend non dedicated server or even when my friend please fix this i really want to play ark with my friends

Share this post


Link to post
Share on other sites

Thanks guys for all the help. Guess my hopes of playing with my son while he's on an Xbox and me on a PC will just have to wait. Sad, but luckily I got mine for free and his came free with gamepass ultimate, so no loss, but sadly the company has to see there is ZERO chance I'll recommend it or buy any further products until it's fixed.
Thanks everyone. I'll see if I can set up a non-dedicated on one pc and he logs on with our other epic games account (which I got ARK fro free with also) and see if we can from there.
Cheers!

Share this post


Link to post
Share on other sites
On 6/12/2020 at 7:46 AM, DNL said:

Epic games server non-dedicated

i use shift+F3 and i look my friend playing but i can t enter in the server , can u help me ?

all epic games players can t join!

Not sure if this will apply to everyone else but, I recently had similar issue. Mine was related to not actually downloading the other free DLC maps. 🤦‍♂️

Share this post


Link to post
Share on other sites
Posted (edited)

So i got it working, what i did was: let the game trough the firewall, opening the ports for the game, make a vpn using hamachi and get my friends to connect to it (here i found a problem with hamachi, a yellow sign appeared on the conection, the fix was installing an older version of the app, usefull video: https://youtu.be/vafSVCedML8), launch the game without anticheat, increase tether distance setting, launch the non dedicated server.
Then, on my friend side, he had to connect to my hamachi vpn, copy my hamachi ipv4 address, launch the game without anticheat, open a single player session, open the console (tab), and use the command: open "my ipv4 address":7777. 

Hope this works for you.

Edited by JICG

Share this post


Link to post
Share on other sites
1 hour ago, Gonger said:

my friend managed to forward his ports and it worked for 3 or 4 days then it just stopped his ports hadn't reset or anything. This is so bs

Has your friend's LAN address changed on the server?
Their server should have a static IP address - not using DHCP.

Also worth checking that the router's config hasn't changed.  ISPs sometimes push out firmware updates that change the settings or behaviour.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...