Jump to content

Hexed

Ark X-Play Dedicated Server works in LAN but not WAN

Recommended Posts

Ark X-Play Dedicated Server works in LAN but not WAN

Background info:

I have been running a dedicated server for cross-play on Windows 10 for months without issues with both Xbox and PC users connecting over the internet (and myself connecting locally via Xbox). I recently installed Malwarebytes free version (which comes with a 12 day trial of premium), ever since then my server can only be connected to locally all join attempts from outside get a "Join Failed" message. Neither Malwarebytes or Windows firewall logged any notifications about blocking any incoming connections. I have since then tried many things to get the server running correctly again along with several troubleshooting tests to try and narrow the problem down.

What I've tried:

Uninstalling Malwarebytes (both through windows and using Malwarebytes removal tool)

Adding inbound rules for Ark on Windows firewall

Tested with the firewall completely disabled.

I have verified that it's not a modem/router issue by launching Ark dedicated server on another PC and on an Xbox and everyone was able to join without issue to either of those.

I have ran a flushDNS on the problem PC.

I have factory reset the router as well.

I have uninstalled and reinstalled Ark on the problem PC.

I have reinstalled windows 10 files (with the option to keep Apps and personal files checked).

 

Final thoughts:

I feel I am left with doing a full Windows 10 reinstall. Does anyone have any ideas on how to get this problem resolved?

Share this post


Link to post
Share on other sites

It is good to know that the MalwareBytes installation may just be a odd coincidence then.

As far as port forwarding on my router goes I originally didn't have any ports forwarded (just UPnP turned on) and it worked like that.

Since these issues began though I have forwarded the following ports on my router:

 53

 80

 88

 500

 3074

 3544

 4500

 7777

 7778

 27015

I ran a "netstat -ab" while the server was loaded on my PC thinking I would see it listening on one of the above ports, but it didn't appear to be listening on any port. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...