Jump to content

Admin / Trusted Player Tool - Game Save Visualiser


Recommended Posts

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Admin / Trusted Player Tool - Game Save Visualiser Just a quick post of my own instead of hijacking others and name-dropping a new tool I've been working on. It's essentially my own UI which

Update - I'm no longer going to have time to do anything on this for the next couple of months.  Finally got completion date and will be picking keys up to our new house today.

Preview 39 now available. http://www.miragesoftware.co.uk/ARK/Apps/ARKViewer_Preview39.zip  Added command line export options. Use: Specified input save file ARKViewer.exe

Posted Images

"Item" displays are across a variety of screens and tabs. 

I'm at work at the moment and will have to check when I've finished but I believe they all add (Blueprint) to the item name if it is a BP.  I may be mistaken, its been a while since I used any of that side of the app.

If not then I'll check over the screens to determine how best to add that information in.

Link to post
Share on other sites

Version 4.0.0.11 now available.

http://www.miragesoftware.co.uk/Ark/Apps/ArkViewer2021-4-11.zip

BlueprintFilters.jpg.bb8caa25fbbc1d0c1fd38a60ffe5c3b3.jpg

Features

  • Added "BP" column to any screen that showed item data.
  • Added blueprint filter option to Item Search and Dropped Item tabs so you can filter them out if you're not bothered about blueprints.
  • Made the item search grid sortable to match the other tab grids.
  • Like 1
Link to post
Share on other sites
21 hours ago, MirageUK said:

It seems you have some .arkprofile that doesn't have valid data.  No character stats or character config properties.

I will debug and add a check around that section to ensure the data continues to load.

Out of curiosity, what kind of data is stored in .arkprofile files ? When I backup my servers files, I always wonder why some .arkprofile files are much larger than others. I don't see any logic (like level or "age" of the character). Some are less than 10 kB and other are 45 kB, for example.

Link to post
Share on other sites

Sorry for bad news Mirage...

2021-06-28 15:56:10 - ASV Command Line Started: 4
    Arg-0 = C:\ArkTools\ArkViewer2021_4_11\ARKSaveViewer.exe
    Arg-1 = all
    Arg-2 = C:\ArkServer\ShooterGame\ShooterGame\Saved\SavedCenter\TheCenter.ark
    Arg-3 = Z:\Apache24\htdocs\Center\Dinos.json
2021-06-28 15:56:13 - Failed to export: 
Object reference not set to an instance of an object.

Good news is the command line args are being picked up correctly now.


 

  • Facepalm 1
Link to post
Share on other sites

i cant seem to get it to load the content in the newest version and it dosent want to grab the newest file when i set it up to FTP because it looks for the original linked file but when i grab the file and download it it just dosent want to load the content it says Content failed to load. Please Check Settings Or Refresh The Download To Try Again 

  • Confused 1
Link to post
Share on other sites
10 hours ago, TheGodOfNoise said:

i cant seem to get it to load the content in the newest version and it dosent want to grab the newest file when i set it up to FTP because it looks for the original linked file but when i grab the file and download it it just dosent want to load the content it says Content failed to load. Please Check Settings Or Refresh The Download To Try Again 

Any chance you can zip up your folder and upload it somewhere I an download and investigate?

If so send me link and I'll investigate.  If not I'll have to add some logging to write out the actual error details to a file and determine what the issue is.

..edit

I'll add back in the error report screen to determine what caused errors on refresh for a release this evening after work.

Edited by MirageUK
Link to post
Share on other sites
17 hours ago, Larkfields said:

Many thanks Mirage for taking a look at my save files.
The fault I mentioned above was caused by me, not by ASV.

It was sort-of caused by ASV.  Next release - hopefully after lunch today - will read map name from the content instead of the filename so doesn't matter what you rename your save first.

...edit

Stuff came up at work over lunch so didn't end up sorting this out yet.  It'll be this evening now.

Edited by MirageUK
Link to post
Share on other sites

Version 4.0.0.12 now available.

http://www.miragesoftware.co.uk/ARK/Apps/ArkViewer2021-4-12.zip

Changes

  • Changed the way it identifies what map is loaded so it no longer relies on filename.ark @Larkfields
  • Re-added support to load the exported .asv pack format.
  • Re-added the error screen if error occurrs loading a save game to allow you guys to give me more information without having to give me your game files. @TheGodOfNoise - let me know what extra information it provides to try narrow down your issue.
  • Thanks 1
Link to post
Share on other sites
4 hours ago, MirageUK said:

Version 4.0.0.12 now available.

http://www.miragesoftware.co.uk/ARK/Apps/ArkViewer2021-4-12.zip

Changes

  • Changed the way it identifies what map is loaded so it no longer relies on filename.ark @Larkfields
  • Re-added support to load the exported .asv pack format.
  • Re-added the error screen if error occurrs loading a save game to allow you guys to give me more information without having to give me your game files. @TheGodOfNoise - let me know what extra information it provides to try narrow down your issue.

after i donwloaded version 4.12 it loads the file like it should so it looks like it has been fixed by something you updated :D 

...Edit 
it loads the tamed creatures but if i switch over to structures it dosent load anything but if i refrest the file from FTP it loads it after the refresh :)

Edited by TheGodOfNoise
Link to post
Share on other sites

Version 4.0.0.13 now available.

http://www.miragesoftware.co.uk/Ark/Apps/ArkViewer2021-4-13.zip

Changes

  • Implemented NLog framework and added log output for various important functions.
  • Fixed the sftp issue of it not updating.  sftp retrieval used to use the loaded mapname.ark to identify the .ark file to download from the server.  In the later versions I changed this so that it no longer stored the extension - but forgot to update the sftp to add it back on. @StevenB
  • Re-added the "unhandled" error screen.

FYI if you do encounter problems please update your NLog.config file to trace more information that might help me narrow the issues down.  Changing the "minLevel" to "DEBUG" instead of "INFO".

 

<?xml version="1.0" encoding="utf-8" ?>
<nlog xmlns="http://www.nlog-project.org/schemas/NLog.xsd"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      autoReload="true" >

  <targets>
    <target xsi:type="File"
        name="logFile"
        fileName="asvlog.log"
        archiveFileName="asvlog.{#}.log"
        archiveEvery="Hour"
        archiveDateFormat="yyyyMMddHH"
        archiveNumbering="Date"
        maxArchiveFiles="3"
        layout="${longdate}|${level:uppercase=true}|${message}${exception:format=ToString,StackTrace}"
     />
  </targets>
  <rules>
    <logger name="*" minlevel="Info" writeTo="logFile" /> <!-- just the important stuff -->
  </rules>
</nlog>

 

Edited by MirageUK
  • Thanks 1
Link to post
Share on other sites

Its ok, I found the issue. I was attempting to make the cro loads work with multi threads again as that bit is quite slow and in that attempt I broke it.  If it find a cryopod with no data.. it simply stops checking the rest atm.

Will hopefully fix it if I get chance at lunch.

Edited by MirageUK
  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...