Jump to content

ArkHeavy

crash Update v301.1, v301.3 killed my server (libaws-cpp-sdk-core.so not found)

Recommended Posts

1 minute ago, Rakeleer said:

Nope. You didn't need them before today and Ark 'rolled' along OK without them.

Exactly, what changed? Are we now sending some metrics to them using that? Do we need to start using AWS to host the servers? :D Who knows :)

Share this post


Link to post
Share on other sites
3 minutes ago, Plopsi said:

somehow we are not able to compile aws-stream (aws-cpp-sdk-stream) file or directory missing, anyone a idea?

 

- Plopsi

 

€: Oh and hi :)

You don't need "stream" just compile the ones needed:
 

cmake -D CMAKE_BUILD_TYPE=Release -D BUILD_ONLY="core;s3;dynamodb;sns;sqs" . # Debian / Fedora?
cmake3 -DCMAKE_CXX_FLAGS:STRING="-Wno-unused-parameter" -D CMAKE_BUILD_TYPE=Release -D BUILD_ONLY="core;s3;dynamodb;sns;sqs" . # Centos

 

Share this post


Link to post
Share on other sites
49 minutes ago, McBane said:

So for those who have debian stretch installed.
I've added the libraries to my gdrive: https://drive.google.com/open?id=16riMlI7ZTV7U2zFgD968HG8-iqk5B3Vl

And for all other building it should be done like this:
 


sudo apt-get install libcurl4-openssl-dev libssl-dev uuid-dev zlib1g-dev libpulse-dev git cmake # Debian Systems
sudo dnf install libcurl-devel openssl-devel libuuid-devel pulseaudio-devel git cmake # Fedora Systems
sudo yum install libcurl-devel openssl-devel libuuid-devel pulseaudio-devel git cmake3 # CentOs Systems
git clone https://github.com/aws/aws-sdk-cpp.git
cd aws-sdk-cpp
cmake -D CMAKE_BUILD_TYPE=Release -D BUILD_ONLY="core;s3;dynamodb;sns;sqs" . # Debian / Fedora?
cmake3 -DCMAKE_CXX_FLAGS:STRING="-Wno-unused-parameter" -D CMAKE_BUILD_TYPE=Release -D BUILD_ONLY="core;s3;dynamodb;sns;sqs" . # Centos
make
find . -name "libaws-*.so*" -exec cp {} /usr/lib/ \;

 

EDIT: Updates uploaded libraries and build instructions
EDIT2: Updated build instructions for CentOs
EDIT3: Another Update for CentOs building

 

Another tip, when compiling on a multi core system use:

Quote

make -j4

where 4 is the number of cores it can use to compile.

Speeds up compiling a lot!

--

A New Life PvE, open world PvP! Discord/Events/Shop!

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, McBane said:

So for those who have debian stretch installed.
I've added the libraries to my gdrive: https://drive.google.com/open?id=16riMlI7ZTV7U2zFgD968HG8-iqk5B3Vl

And for all other building it should be done like this:
 


sudo apt-get install libcurl4-openssl-dev libssl-dev uuid-dev zlib1g-dev libpulse-dev git cmake # Debian Systems
sudo dnf install libcurl-devel openssl-devel libuuid-devel pulseaudio-devel git cmake # Fedora Systems
sudo yum install libcurl-devel openssl-devel libuuid-devel pulseaudio-devel git cmake # CentOs Systems
git clone https://github.com/aws/aws-sdk-cpp.git
cd aws-sdk-cpp
cmake -D CMAKE_BUILD_TYPE=Release -D BUILD_ONLY="core;s3;dynamodb;sns;sqs" .
make
find . -name "libaws-*.so*" -exec cp {} /usr/lib/ \;

 

EDIT: Updates uploaded libraries and build instructions

This works for Debian Buster with the Caveat"sudo apt update" before this code.

 

Thanks!

Share this post


Link to post
Share on other sites
Update v301.3 killed my server (libaws-cpp-sdk-core.so not found) AGAIN !

New update same issue AGAIN !

error while loading shared libraries: libaws-cpp-sdk-core.so: cannot open shared object file: No such file or directory


Dev .. please pay attention ...and update server asap please !

Share this post


Link to post
Share on other sites

Crashing again with todays update :(

2019-11-12 19:29:26: [Update]
Running command 'update' for instance 'main'
Checking for update; PID: 15
Your server is already up to date! The most recent version is 4378314.
2019-11-12 19:29:47: [Start]
Running command 'run' for instance 'main'
2019-11-12 19:29:47: start
2019-11-12 19:29:47: Running /ark/server/ShooterGame/Binaries/Linux/ShooterGameServer TheIsland\?AdminLogging=true\?[...]
/ark/server/ShooterGame/Binaries/Linux/ShooterGameServer: error while loading shared libraries: libaws-cpp-sdk-core.so: cannot open shared object file: No such file or directory

So the workaround with custom compiled aws-libs is needed again...

Edited by bratkartoffel

Share this post


Link to post
Share on other sites

The above files compiled for debian stretch didn't work on my buster container. The workaround with installing libcurl3 didn't work too, so I've compiled the libs for buster myself:

https://drive.google.com/open?id=1GcXYURLf2QMsBHsqWA85pBPgQgENKzN0

Compiled tag 1.7.223, using current debian buster packages and the howto posted by @McBane

Edited by bratkartoffel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...