Jump to content

shenniko

help - linuxgsm - Dedicated Server not found

Recommended Posts

help - linuxgsm - Dedicated Server not found

Hi,

First off, this is pretty much the first time for me using Linux.. so.. be gentle..

I've followed the instruction on linuxgsm to install my Ark server, and also opened the required ports.. I've done ./arkserver postdetails, and the results are below:

 

Distro Details
=================================
Distro:    Ubuntu 19.04
Arch:      x86_64
Kernel:    5.0.0-25-generic
Hostname:  shenniko
tmux:      tmux 2.8
glibc:     2.29

Performance
Uptime:    0d, 8h, 6m
Avg Load:  0.25, 0.57, 0.71

CPU Model:      Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
CPU Cores:      8
CPU Frequency:  1605.454 MHz

Mem:       total  used  free   cached  available
Physical:  16GB   10GB  5.5GB  4.1GB   5.5GB
Swap:      8.0GB  10MB  8.0GB

Storage
=================================
Filesystem:      /dev/md2
Total:           679G
Used:            26G
Available:       619G
LinuxGSM Total:  19G
Serverfiles:     8.9G

ARK: Survival Evolved Server Details
=================================
Server name:    Shennikos Ark Server
Server IP:      144.76.13.249:7777
Maxplayers:     70
Default Map:    TheIsland
Master Server:  false
Status:         ONLINE

arkserver Script Details
=================================
Service name:           arkserver
arkserver version:      v19.10.0
User:                   ark
glibc required:         2.15
Discord alert:          off
Email alert:            off
Pushbullet alert:       off
IFTTT alert:            off
Mailgun (email) alert:  off
Pushover alert:         off
Telegram alert:         off
Update on start:        off
Location:               /home/ark
Config file:            /home/ark/serverfiles/ShooterGame/Saved/Config/LinuxServer/GameUserSettings.ini

Backups
=================================
No Backups created

Command-line Parameters
=================================
./ShooterGameServer "TheIsland?AltSaveDirectoryName=TheIsland?listen?MultiHome=144.76.13.249?MaxPlayers=70?QueryPort=27015?RCONPort=27020?Port=7777 -automanagedmods"

Ports
=================================
Change ports by editing the parameters in:
/home/ark/lgsm/config-lgsm/arkserver

Useful port diagnostic command:
netstat -atunp | grep ShooterGame

DESCRIPTION  DIRECTION  PORT   PROTOCOL
> Game       INBOUND    7777   udp
> RAW        INBOUND    7778   udp
> Query      INBOUND    27015  udp
> RCON       INBOUND    27020  tcp

Status:	ONLINE

Port Diag: netstat -atunp | grep ShooterGame
tcp        0      0 0.0.0.0:27015           0.0.0.0:*               LISTEN      1188/ShooterGameSer 
tcp        0      0 144.76.13.249:27020     0.0.0.0:*               LISTEN      13858/./ShooterGame 
udp        0      0 144.76.13.249:7777      0.0.0.0:*                           13858/./ShooterGame 
udp        0      0 0.0.0.0:7778            0.0.0.0:*                           1188/ShooterGameSer 
udp        0      0 0.0.0.0:27015           0.0.0.0:*                           1188/ShooterGameSer 
udp        0      0 144.76.13.249:14001     0.0.0.0:*                           13858/./ShooterGame 



So as you can see, by all means.. it looks like its working.. but i cant seem to find the server in the Ark list.. and neither can i connect directly.. Any ideas?

Share this post


Link to post
Share on other sites

Hi shenniko.

A few things spring to mind...

1. Multihome is only required if you have more than one network port on your computer.
2. You have double quotes around everything after ./ShooterGameServer but command line args should be outside the quotes...
 ./ShooterGameServer "TheIsland?AltSaveDirectoryName=TheIsland?listen?MultiHome=144.76.13.249?MaxPlayers=70?QueryPort=27015?RCONPort=27020?Port=7777" -automanagedmods
3. Ark uses the port number you specify and the next one up.  So you need to port-forward 7777 and 7778.
4. Steam likes to use ports 27015 and 27020... https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711 
5. Check that your router allows NAT-Loopback, otherwise you won't be able to connect to the server from your own LAN.
6. Command line arg I use are...      -NoCrashDialog -log -NoTransferFromFiltering -EnableIdlePlayerKick -ServerRCONOutputTribeLogs -automanagedmods

More info can be found at...
https://ark.gamepedia.com/Dedicated_Server_Setup

 

Share this post


Link to post
Share on other sites
12 minutes ago, Larkfields said:

You have double quotes around everything after ./ShooterGameServer but command line args should be outside the quotes...
 ./ShooterGameServer "TheIsland?AltSaveDi

Hi,

Thanks for the reply. This is a dedicated host from hetzner.com (im using the server for something else also)..

UFW ports below... so all ports should be open..

To                         Action      From
--                         ------      ----
27015                      ALLOW       Anywhere                  
7777/udp                   ALLOW       Anywhere                  
7778/udp                   ALLOW       Anywhere                  
27020/udp                  ALLOW       Anywhere                  
27015/udp (v6)             ALLOW       Anywhere (v6)             
7777/udp (v6)              ALLOW       Anywhere (v6)             
7778/udp (v6)              ALLOW       Anywhere (v6)             
27020/udp (v6)             ALLOW       Anywhere (v6)

Shootergame log
[2019.09.02-09.57.56:586][  0]Log file open, 09/02/19 10:57:56
[2019.09.02-09.57.56:586][  0]ARK Version: 298.37
[2019.09.02-09.57.56:586][  0]PID: 14594
[2019.09.02-09.58.14:014][  0]Primal Game Data Took 17.04 seconds
[2019.09.02-09.58.25:035][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2019.09.02-09.58.25:036][  0]BattlEye successfully started.
[2019.09.02-09.58.51:400][  0]Server: "Shennikos Ark Server" has successfully started!
[2019.09.02-09.58.57:536][  0]Commandline:  "TheIsland?AltSaveDirectoryName=TheIsland?listen?MultiHome=144.76.13.249?MaxPlayers=70?QueryPort=27015?RCONPort=27020?Port=7777 -automanagedmods"
[2019.09.02-09.58.57:536][  0]Full Startup: 62.27 seconds (BP compile: 0.00 seconds)
[2019.09.02-09.58.57:536][  0]Number of cores 4

The only sort of error i can find is in my arkserver-console.log (generated by linuxgsm ), but reading up on net, lots of people say its normal? :
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 346110

So according to logs.. server is running, ports are open.. but i still cant find my server or direct connect from steam..

Share this post


Link to post
Share on other sites

Try -nosteamclient  on the end of your command line to clear that error message.

BattleMetrics is seeing your server... https://www.battlemetrics.com/servers/search?q=Shennikos&sort=score   so you're part way there.
Click on your server name in battlemetrics, then try using the "connect" link in the top right of the page.

I see that you've been on the server, so my guess is that the ping times between your client and server are high enough that the client is timing out on the server list before finding yours.

 

Which country are you in, and which country is your server in?

 

Edited by Larkfields
added a question.

Share this post


Link to post
Share on other sites

Apologies, lots of tweaks and re-setting things...
 

It looks like i was originally booting up two servers... some sort of mix up with my service.. so i removed it and setup a Cron job.. So all seems to be working and booting now..

I've added the server to my Steam > View > servers > fav's (by entering my ip and searching for all games on that IP) so can connect that way... just cant see the server in the Ark list in the game..

Im in the UK and the server is in Germany.. so not that much distance..

Share this post


Link to post
Share on other sites

The server is clearly working because you're able to join as a direct connection, so the main thing you need to change is the quotation marks on your command line: The options on the end of the line (with minus signs) should be outside of the quotes.

 ./ShooterGameServer "TheIsland?AltSaveDirectoryName=TheIsland?listen?MultiHome=144.76.13.249?MaxPlayers=70?QueryPort=27015?RCONPort=27020?Port=7777" -automanagedmods  -nosteamclient -server -log

The ark server fails silently with a lot of these options, so it won't report an error when you get these options wrong.

At some point: you should add "?ServerAdminPassword=xxxxx" inside the quotes, with a password of your choice otherwise anybody would be able to enable cheats.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...