Jump to content

The ShooterGameServer issue and how to fix it!


Recommended Posts

The ShootergameServer issue and how to fix it!

Alright, so after the latest update (298.3) the update package screwed up the ShooterGameServer.exe, which prevents people from hosting a Dedicated Server entirely. Given that Non-Dedicated Servers lag extremely bad, hosting a Dedicated Server is really the only way to make a private session for you and your buds, without experiencing lag OR being severely limited in how far apart you can go from each other (some also say, that the Dedicated Server consumes less ram, can't really confirm that, but it might be possible). Until the devs decide to hotfix this issue (if ever) I have come up with a rather simple solution to this issue. It does take a bit of time, but it will let you host your Dedicated Server through the game. Here are the steps:

1. Go to Steam > Library > Tools
2. Download ARK Survival Evolved Dedicated Server.
3. Let it finish up, shouldn't take too long.
4. Right click ARK Survival Evolved Dedicated Server, then pick Properties > Local Files > Browse Local Files
5. The setup of the folders is almost the same as the game's folders, go to ShooterGame > Binaries > Win64 (or Linux, depending on your system)
6. In here you will find a fully functional ShooterGameServer.exe and ShooterGameServer.pdb (the .pdb I am not sure if you need in your main folder, but why not copy it as well, Linux doesn't have the .pdb file, so you don't need to copy it over).
7. Select both the Server.exe and the Server.pdb files, copy them, then go to Steam > steamapps > common > ARK > ShooterGame > Binaries > Win64 (I guess it would be Linux, if you're using Linux) > Paste the two files here. It will overwrite the broken ShooterGameServer.exe with the new one, which should be 50.2 MB in size. This will effectively fix the problem until the devs decide to patch it with a hotfix.

Not sure if anyone else has posted this fix or any other way to fix it, but as of writing this I have not found anyone, that has come up with an idea to fix it (or they don't post it).

Edited by Pimpman
Link to post
Share on other sites

Dedicated server under tools.  Who knew?  ?

Instead of copying the two files to an old install I copied my saved data to the dedicated server install.  Dedicated is only 15GB instead of 150GB.

Installed that into a folder along side my existing dedicated server.

start "" steamcmd.exe +login username password +force_install_dir ""D:\Games\ArkServer\Server"" +app_update 376030 +quit 

Copied the Saved folder from the original to the newly downloaded dedicated server. D:\Games\ARKServer\Server\ShooterGame\Saved

Modified my startup batch file and viola!  Started right up.  Cluster in tact.  Mods and everything in place.

 

Link to post
Share on other sites
  • 2 weeks later...
  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...