Jump to content

Dannyuk77

Patch Issues for PC

Recommended Posts

thank you wildcard for another messed up patch.

this is the second time this has happened to me downloading a patch from steam from you.  Seriously enough is enough.... I may be done with the game at this point.

Patch downloads - installs.

At end of install it downloads the patch a SECOND time.... installs....

at end of that it downloads for a THIRD time... this time just constantly increasing the 'update' size and constantly downloading....

This is messed up and im sick of it, its only ARK that does this too, none of the other 300+ games  I have have one single issue installing updates, nope, just ark.... 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

its like its redownloading the whole f.... game, it goes up a little bit about 200-400m each time it reaches what it says it 'needs' to download.  so its in a constant state of downloading, freaking messed up is what this is, all because of 1 … patch....  game ran perfect before that, and now, nope not at all.  Great Job Wildcard!

 

Edit in: their forum isn't giving me much 'faith' in wildcard either, being im seeing someone elses post on my topic above the original post.  really? 

 

Edited by caleb68

Share this post


Link to post
Share on other sites
Posted (edited)

Latest patch broke private server

I was running an older scorched earth, noticed the update from today and restarted the map. It shows system cannot find the file specified (windows OS). All I did was restart the same command to launch the map. I didn't change anything.

I get this error immediately when starting the executable:

The system cannot execute the specified program.

Island and Valguero commands also fail.

I see the paths are all there, exe's there, saved dir and maps+saves are there, I don't know what's missing.

Single player works fine, it's only shootergameserver.exe that fails.

Edited by marcpullen

Share this post


Link to post
Share on other sites
10 minutes ago, caleb68 said:

its like its redownloading the whole f.... game, it goes up a little bit about 200-400m each time it reaches what it says it 'needs' to download.  so its in a constant state of downloading, freaking messed up is what this is, all because of 1 … patch....  game ran perfect before that, and now, nope not at all.  Great Job Wildcard!

 

Edit in: their forum isn't giving me much 'faith' in wildcard either, being im seeing someone elses post on my topic above the original post.  really? 

 

Instead of having 10 threads they merge them. Makes getting answers and info easier

 

  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, marcpullen said:

Latest patch broke private server

I was running an older scorched earth, noticed the update from today and restarted the map. It shows system cannot find the file specified (windows OS). All I did was restart the same command to launch the map. I didn't change anything.

Island and Valguero commands also fail.

I see the paths are all there, exe's there, saved dir and maps+saves are there, I don't know what's missing.

Having the same exact problem on 2 computers running dedicated servers.  Noticed the ShooterGameServer.exe is there, but the icon for it is some default Windows icon instead of the Arc icon.  I have a feeling they botched the update to that file and we can't run a dedicated server now.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Sixpax said:

Having the same exact problem on 2 computers running dedicated servers.  Noticed the ShooterGameServer.exe is there, but the icon for it is some default Windows icon instead of the Arc icon.  I have a feeling they botched the update to that file and we can't run a dedicated server now.

Yeah I'm seeing the same. The file seems too small, it's exactly 2048 kb (~2mb). ARK icon is missing, will not launch. Looking at the file in a text editor shows all blank, there's usually a giant amount of ascii text for the compiled code, there is nothing but nul in it. No details either (usually shows some info or product version), this one is a bad build for the server.

Share this post


Link to post
Share on other sites

Incase the patch, or any future patches screw up like this for anyone else, here's what I had to do to fix the issue:

pause update
shut down steam,
go into the steam folder for downloads (default: c:\program files\steam\steamapps\downloads) and look for the folder associated to the ark update, delete it, and any files with the same file number as the folder.

restart steam - right click Ark, go to properties, local files, validate game.

This stopped the endless update loop but because of it, Ark had to download 6.6gb of data to actually fix the game.  Great job... great job... its amazing that a 365mb update could screw up so badly it would damage 6.6gb of game files.

Share this post


Link to post
Share on other sites
11 minutes ago, Styxx42 said:

Hello fellow Arkrs.

Any Fix for the botched Shootergameserver.exe file for private servers?

Anyone see anything official recognizing that it is in fact broken?


Thanks,

 

Just sitting here waiting... ARGGG I want to Ark.. ' )

 

 

Not that I've seen yet.  Make sure you submit a bug report if you haven't already please.  The more exposure the better. :)

Share this post


Link to post
Share on other sites

Ok, so I have possibly figured it out.  When I open the ShooterGameserver.exe in Notepad++ all it says is NULNULNULNULNULNUL over and over and over.  The new file is 2mb where the old one had a ton of information in it and was around 51mb.   I had not updated my client computer yet so I went and copied the file from that install over into my Dedicated Servers folder and it is launching now.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I did this update like 4 hours ago - and the issue is still there. No endless loop doing the update, but shootergameserver.exe is broken. Bug submitted, but no response other than the canned "thank you for submitting" blurb. Busy trying file validation now to see if that fixes it.

I see that the patch has worked for at least some people, because both official and unofficial server are running it ........

______________________

Update: Validating files did not fix this, however if I do a SteamCommand   "app_update 376030" (which is the server app, not the main game app) then the update goes through OK and I have a valid ShooterGameServer.exe.

It looks like the update to the main game (app ID  346110) is broken with respect to the Server exe

Edited by DirkInSA
  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Jemcrystal said:

Just out of curiosity your folder path looks like this?

C:\Program Files (x86)\Steam\steamapps\common\ARK

And you did not put Steam files anywhere else on your Windows10 personal computer?

No, it's on a separate D drive. This hasn't been an issue for years, only on this latest patch.

Share this post


Link to post
Share on other sites
8 hours ago, marcpullen said:

No, it's on a separate D drive. This hasn't been an issue for years, only on this latest patch.

check both folders for the temp downloaded files when you have steam installed on a alternate drive, ie:

c:\Program Files(x86)\Steam\Downloads\
and then the alterate folder you installed it in as well, even if its just for the games, i.e.:
g:\Program Files(x86)\Steam\Downloads\

if the cache files are in either folder for ark (which it will do both sometimes) it will continue to use whats already there rather then downloading new files even though it looks like it is and you'll still end up with a botched install.  Its a problem that happens when installing the games on a alternate drive then the c drive. if there are files in either folder for ark, pause any update like i said, shut down steam, remove the files, then restart steam, validate instead of starting the paused update.  should fix it.

Share this post


Link to post
Share on other sites

I appreciate the attempt to help, but Steam is not installed on C and does not exist at all on it. It's been on my D drive for a very long time. I've had no issues with this setup with ark or all the other steam games I have.

I do not have a [path]\Steam\Downloads folder.

The server exe from Steam is corrupt. I already deleted it and rechecked local files and it re-downloaded the bad exe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...