Jump to content

AllyGator

extinction Drop killed my Giga

Recommended Posts

Drop killed my Giga

So I’ve been on an Extinction official server since it came out. Well today, going on a meat run for the baby Gigas (the usual), I took my 100% imprinted Giga, she had 34K Hp and 811 Md (with more xp to go still yet), and was wearing an ascendant saddle with 83 armor, out killing stuff just like normal, and out of literally nowhere, all of my armor breaks immediately, I suddenly die, and my Giga dies with me, all showed in red on the screen. I didn’t know what had happened at first, until I went back for my stuff, and saw a drop floating just above my dead Giga’s body :(  The sad part is, I didn’t even hear the rumbling sound the drops make when they plummet down to the ground... there was no sound or anything!

I thought this was patched for console? Is this supposed to still happen,  or was this an unfortunate glitch? Very sad I lost my best Giga I had so far to something like this ( whether it was a glitch that wasn’t supposed to happen, or whether I just have very poopty luck being at the wrong place at the wrong time, idk. ) I’ve read up what little info I could find on this specific subject, and found it was “supposedly” patched on console not long after the map came out. But then I hear that it still does sometimes happen (usually when someone is collecting loot from an OSD they just finished and one spawns in right after completing it). But what little I did find on this was dated to Nov. and Dec. 2018 when the map came out.. so I’m unsure if this is still an existing issue for others or not. :( 

I’m so confused on this subject and not sure if this is still an issue with anyone else  on console (PS4). If anyone has had any RECENT incidents like this happen, I’d like to know about it (and if you were able to get your dino(s) back from reporting it). Thanks in advanced guys.

- One sad Giga Momma 

Edited by AllyGator
  • Sad 2

Share this post


Link to post
Share on other sites
Just now, Fukushu said:

that's really, really unlucky, I just don't understand why you didn't hear anything, the drops are normally loud as f***.

You could try writing a support ticket if you have pictures of it and explain the situation to a GM, maybe they can help, doesn't hurt to ask.

I submitted a ticket to the support center. I have screenshot the pic on the PS4 and took one with my phone of the drop above my gigas body (I can’t upload it on here, says too big of a file). Hopefully they can get me sorted. :( still don’t know if it’s a patch that glitches or if it’s still a thing that happens. Hopefully I’ll get some closure either way. Thank you 

Share this post


Link to post
Share on other sites
12 minutes ago, AngrySaltire said:

As far as I am aware its not a bug or glitch. As much as it sucks its supposed to happen

I hope that’s not the case :/ like I said in original post, I had read that it was an issue when it first came out (then was patched?) but again as they say, believe nothing that you hear and only half of what you see 🤷‍♀️ Thank you for your input  :) 

Share this post


Link to post
Share on other sites
21 minutes ago, AllyGator said:

I hope that’s not the case :/ like I said in original post, I had read that it was an issue when it first came out (then was patched?) but again as they say, believe nothing that you hear and only half of what you see 🤷‍♀️ Thank you for your input  :) 

The issue was a drop spawning on top of a drop just completed while people were still gathering loot. That would kill everything in the area but was not supposed to happen.

It sounds like you just got caught in a drop coming down which is unfortunate but supposed to happen.

Share this post


Link to post
Share on other sites
6 minutes ago, yekrucifixion187 said:

The issue was a drop spawning on top of a drop just completed while people were still gathering loot. That would kill everything in the area but was not supposed to happen.

It sounds like you just got caught in a drop coming down which is unfortunate but supposed to happen.

Of course that would be MY luck :( you’d think it wouldn’t insta-kill an animal with higher hp.. take maybe half the hp in damage or something , not one-shot it and kill it instantly.. kinda crappy on their part.... :/  maybe they will eventually fix this issue too (hopefully)  thanks for the input 

Share this post


Link to post
Share on other sites
On 7/18/2019 at 8:54 AM, AllyGator said:

Of course that would be MY luck :( you’d think it wouldn’t insta-kill an animal with higher hp.. take maybe half the hp in damage or something , not one-shot it and kill it instantly.. kinda crappy on their part.... :/  maybe they will eventually fix this issue too (hopefully)  thanks for the input 

It's a drop that fell from space.... It's quite realistic it kills everything, only exception should be Titans cause they'd just be hurt alot but could take it due to their sheer size, havent tested it and doubt I will tho

Share this post


Link to post
Share on other sites

Unfortunately even if wildcard is willing to replace your giga it will be random stats color and gender found this out when mine dissapeared putting it into a transmitter I submitted a ticket and that's what they told me wildcard is useless when replacing anything raised with mutations

Share this post


Link to post
Share on other sites
On 7/19/2019 at 10:38 PM, Paradign said:

Unfortunately even if wildcard is willing to replace your giga it will be random stats color and gender found this out when mine dissapeared putting it into a transmitter I submitted a ticket and that's what they told me wildcard is useless when replacing anything raised with mutations

Whoah so ur saying u uploaded a giga, forgot, and it despawned after the 24hour timer ran out. AND u got a free giga?!? I've been sending videos with Dino's falling trough the map and dissapearing with no death note and I can't even get a doedi back....

Share this post


Link to post
Share on other sites

Well guys it apparently wasn’t supposed to happen. I did submit a ticket and WC did mature and 100% imprint a baby giga I already had in a cryopod for me. Sorry took awhile to get back on forums to update y’all. Been busy working a lot :/ but yes they matured a baby I had and imprinted it 100% because it was their mistake. I was super happy they did that for me :) 

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...