Jump to content

LowLevelFatalError - Unreal Engine is exiting due to D3D device being lost.


Recommended Posts

I also am now receiving this issue. Not just on the island,  it can be randomly on any map.

1080ti, drivers also up to date
I7 8086k
32GB DDR4 3200 (upgraded to these thinking this was my issue last week...)
High refresh monitor

Changing settings to low, medium, even fullscreen/borderless doesnt fix the crash either. Hell ive been through all of the launch options too. Quite annoying for how much money i've spent on this machine.

Been happening for me for a while, but first time the error actually gave me something useful to read: "Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0005 - 'REMOVED')"

Edited by SignatureBeef
Link to post
Share on other sites
  • Replies 104
  • Created
  • Last Reply

Top Posters In This Topic

Same issue here. come on WILDCARD, this is not allright.

More and more people are having this issue it seams.

It's bin going on for over a year.

Just bought a brand new, beast of a machine, just to play ARK better.

For once focus on FIXING YOUR GAME. Instead of keep putting out new content.

Focus a little on your fan base here. The game is unplayable right now, for a lot of people.

Link to post
Share on other sites

So I have been able to play this game with no issues since updating to my RTX2060 for about 2 or 3 weeks now. All of a sudden I'm also getting this D3D device lost/crash. Only sometimes does it show the crash dialogue. More often than not the game will CTD quite suddenly. Sometimes the frame rate will freeze then crash, others just crash. It's quite frustrating because it only started after I transferred my character to another server. First to Extinction, then Scorched Earth, Ragnarok, and finally The Island. It doesn't seem to happen on The Center at all. I've followed most all of the "fixes" above to see if that would help and so far it's a no go.  I'll try the -norhithread option if it crashes again, but as of this moment I'm re-downloading the game from scratch. Hopefully that will help but I'm beginning to doubt it because it seems that more people who are running the high end graphics cards are complaining about this issue (ie. GTX1080, RTX2060+, etc). I will also say that I'm currently on The Island trying to get to an obelisk to transfer back to The Center so I'll hopefully be able to play more than a couple minutes before crashing.

Link to post
Share on other sites

I followed all the possible solutions in this thread, nothing seems to work.

I updated from a GTX 1080 to a RTX 2080 ti and shortly after that I got this Problem. I can play from 2min to 30min without crashing, then back to windows or newstart...
Ark is one of my favourite games, I got 1k hours of gametime in it, so it bothers me a lot.

Link to post
Share on other sites
  • 2 weeks later...

I have it too ... weird thing is, sometimes it happens after 2 minutes in the game sometimes I can play 6 hours without it happening once...
the things i do are completely different, gliding with a rockdrake, running through my base, diving in the water, collecting berries from my garden, flying my griffin on ragnarok, accessing my industrial forge, riding on my manta, and so on and so forth. Long story short, its frigging hard to reproduce cuz it sometimes just happens. Reinstalling Ark, clean driver install, no use ... might have to reinstall windows ... in hopes that fixes it...

i even tried restoring win10 health in CMD with the DISM commands xD

Edited by Gemini
Link to post
Share on other sites
  • 2 weeks later...
Hello, first my specs:
 
i5 9600k
MSI Z390 Gaming Plus
MSI GTX 1080 Gaming X
M2 760P & Intel SSD
32GB of RAM 3200mhz
 
Everytime i play the game, i have crash 5 minutes after I join the server, i tried many solution (downgrading display drivers, launch options, DX10, repairing the game).
Everytime i repair the game, i have 2 files missing. EVERYTIME.
 
The game cause kernel mode heap corruption bsod on my pc, and when i crash, I have this error.
 
Assertion failed: CurrentThreadIfKnown == ENamedThreads::GetThreadIndex(GetCurrentThread()) [File:F:\build\Trunk\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp] [Line: 1751]



VERSION: 295.106
KERNELBASE.dll!UnknownFunction (0x00007ff881a55299) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FOutputDevice::Logf__VA() (0x00007ff7687677f8) + 159 bytes [f:\build\trunk\engine\source\runtime\core\private\misc\outputdevice.cpp:145]
ShooterGame.exe!FDebug::AssertFailed() (0x00007ff768767d95) + 178 bytes [f:\build\trunk\engine\source\runtime\core\private\misc\outputdevice.cpp:220]
ShooterGame.exe!FTaskGraphImplementation::WaitUntilTasksComplete() (0x00007ff7686d8b9b) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\async\taskgraph.cpp:1755]
ShooterGame.exe!FTaskGraphInterface::WaitUntilTaskCompletes() (0x00007ff7687864c2) + 0 bytes [f:\build\trunk\engine\source\runtime\core\public\async\taskgraphinterfaces.h:320]
ShooterGame.exe!StopRenderingThread() (0x00007ff768bddf79) + 0 bytes [f:\build\trunk\engine\source\runtime\rendercore\private\renderingthread.cpp:602]
ShooterGame.exe!FSceneViewport::UpdateViewportRHI() (0x00007ff76954b262) + 48 bytes [f:\build\trunk\engine\source\runtime\engine\private\slate\sceneviewport.cpp:1037]
ShooterGame.exe!FSceneViewport::~FSceneViewport() (0x00007ff769545b0b) + 0 bytes [f:\build\trunk\engine\source\runtime\engine\private\slate\sceneviewport.cpp:43]
ShooterGame.exe!FSceneViewport::`scalar deleting destructor'() (0x00007ff769545a64) + 0 bytes [UnknownFile:0]
ShooterGame.exe!SharedPointerInternals::FSharedReferencer<0>::operator=() (0x00007ff76775d0a2) + 11 bytes [f:\build\trunk\engine\source\runtime\core\public\templates\sharedpointerinternals.h:402]
ShooterGame.exe!UGameEngine::OnGameWindowClosed() (0x00007ff768f877be) + 43 bytes [f:\build\trunk\engine\source\runtime\engine\private\gameengine.cpp:572]
ShooterGame.exe!TBaseUObjectMethodDelegateInstance_OneParam<UInventoryPanelWidget,void,UDataListEntryButton * __ptr64>::ExecuteIfSafe() (0x00007ff767813d3b) + 0 bytes [f:\build\trunk\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:533]
ShooterGame.exe!SWindow::NotifyWindowBeingDestroyed() (0x00007ff7688c9d95) + 147 bytes [f:\build\trunk\engine\source\runtime\slatecore\private\widgets\swindow.cpp:1042]
ShooterGame.exe!FSlateApplication::PrivateDestroyWindow() (0x00007ff76891f0b2) + 0 bytes [f:\build\trunk\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:4818]
ShooterGame.exe!FSlateApplication::DestroyWindowsImmediately() (0x00007ff76890ecde) + 0 bytes [f:\build\trunk\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1812]
ShooterGame.exe!FSlateApplication::RequestDestroyWindow() (0x00007ff76890c1d1) + 0 bytes [f:\build\trunk\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1382]
ShooterGame.exe!SWindow::RequestDestroyWindow() (0x00007ff7688c9c6f) + 122 bytes [f:\build\trunk\engine\source\runtime\slatecore\private\widgets\swindow.cpp:1026]
ShooterGame.exe!FSlateApplication::OnWindowClose() (0x00007ff76891f216) + 0 bytes [f:\build\trunk\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:4854]
ShooterGame.exe!FWindowsApplication::ProcessDeferredMessage() (0x00007ff7687954bb) + 39 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsapplication.cpp:1521]
ShooterGame.exe!FWindowsApplication::ProcessDeferredEvents() (0x00007ff768796769) + 11 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsapplication.cpp:1709]
ShooterGame.exe!FSlateApplication::Tick() (0x00007ff76890a795) + 0 bytes [f:\build\trunk\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:893]
ShooterGame.exe!FSlateLoadingSynchronizationMechanism::SlateThreadRunMainLoop() (0x00007ff768cfcb28) + 0 bytes [f:\build\trunk\engine\source\runtime\movieplayer\private\movieplayerthreading.cpp:146]
ShooterGame.exe!FSlateLoadingThreadTask::Run() (0x00007ff768cfcc40) + 0 bytes [f:\build\trunk\engine\source\runtime\movieplayer\private\movieplayerthreading.cpp:182]
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff7687b8a56) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff7687b8918) + 8 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
KERNEL32.DLL!UnknownFunction (0x00007ff8834e7e94) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ff884d27ad1) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ff884d27ad1) + 0 bytes [UnknownFile:0]
 
OR this error:
 
LowLevelFatalError [File:F:\build\Trunk\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')


VERSION: 295.106
KERNELBASE.dll!UnknownFunction (0x00007ffd6da19129) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FError::LowLevelFatal() (0x00007ff6729e8376) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
ShooterGame.exe!TerminateOnDeviceRemoved() (0x00007ff672ded399) + 0 bytes [f:\build\trunk\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:189]
ShooterGame.exe!VerifyD3D11Result() (0x00007ff672ded43c) + 0 bytes [f:\build\trunk\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
ShooterGame.exe!FD3D11Viewport::PresentChecked() (0x00007ff672df00b6) + 47 bytes [f:\build\trunk\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:303]
ShooterGame.exe!FD3D11DynamicRHI::RHIEndDrawingViewport() (0x00007ff672df0dae) + 0 bytes [f:\build\trunk\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:612]
ShooterGame.exe!FRHICommandListExecutor::ExecuteInner_DoExecute() (0x00007ff672e514d8) + 0 bytes [f:\build\trunk\engine\source\runtime\rhi\private\rhicommandlist.cpp:249]
ShooterGame.exe!FRHICommandListExecutor::ExecuteInner() (0x00007ff672e51ea6) + 8 bytes [f:\build\trunk\engine\source\runtime\rhi\private\rhicommandlist.cpp:459]
ShooterGame.exe!FRHICommandList::EndDrawingViewport() (0x00007ff672e53631) + 0 bytes [f:\build\trunk\engine\source\runtime\rhi\private\rhicommandlist.cpp:1374]
ShooterGame.exe!FSlateRHIRenderer::DrawWindow_RenderThread() (0x00007ff67415900e) + 23 bytes [f:\build\trunk\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:495]
ShooterGame.exe!TGraphTask<`FSlateRHIRenderer::DrawWindows_Private'::`27'::EURCMacro_SlateDrawWindowsCommand>::ExecuteTask() (0x00007ff6741696a2) + 0 bytes [f:\build\trunk\engine\source\runtime\core\public\async\taskgraphinterfaces.h:895]
ShooterGame.exe!FNamedTaskThread::ProcessTasksNamedThread() (0x00007ff672957048) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\async\taskgraph.cpp:939]
ShooterGame.exe!FNamedTaskThread::ProcessTasksUntilQuit() (0x00007ff6729561fd) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\async\taskgraph.cpp:680]
ShooterGame.exe!RenderingThreadMain() (0x00007ff672e5d219) + 0 bytes [f:\build\trunk\engine\source\runtime\rendercore\private\renderingthread.cpp:265]
ShooterGame.exe!FRenderingThread::Run() (0x00007ff672e5d580) + 0 bytes [f:\build\trunk\engine\source\runtime\rendercore\private\renderingthread.cpp:385]
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff672a38a56) + 0 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff672a38918) + 8 bytes [f:\build\trunk\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
KERNEL32.DLL!UnknownFunction (0x00007ffd6f3a7974) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffd70d0a271) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffd70d0a271) + 0 bytes [UnknownFile:0]
 
This is the first time of my life i can't run a game because developers broke it.
I have a new gen pc, but i can't play.
 
Please, make a fix or give me a solution, thank you.
 
 
Link to post
Share on other sites

NOTICE: This post has been moved from "BSOD in Ark" to this page since the issue is no longer related to BSOD but to d3d device being lost issue.

 

I have now finaly finished my video and uploaded on my Youtube if anyone could be interested but just so that you know, then are the video 46 minutes long because I'm just trying to give as much details about my system and how the game is behaving on my system and hopefully can these information be helpful for any technician that will be seeing my video and that are trying to fix this problem. I'm also showing what I'm using as temperary soloution so that I still can play the game with my RTX 2080 card without any noticeable lost in quality but no further due, so here is the link to my video:

 

 

Btw, thank everyone for coming forward and let me know that I'm not alone with this problem :)

 

UPDATE #1 - I have used the DDU in Windows safe mode to remove Nvidia diplay driver v. 419.67 completely and when rebooted to Windows normaly, I then installed the new Nvidia v. 425.31 but Ark Survival Evolved is still crashing as soon I try to pick any value higher than low for the terrain shadow.

Edited by Niphorox
Link to post
Share on other sites
On 4/16/2019 at 11:17 PM, Ch3vap said:

Jea, in the last Driver Notes it says [ARK Survival Evolved]: Fixed random crashes on GeForce RTX 20 series GPUs. [2453173]
But still got the Line 176 D3D11 Hung Problem :(

https://us.download.nvidia.com/Windows/425.31/425.31-win10-win8-win7-release-notes.pdf

 

Hey guys,
after I reinstalled Ark, deinstalled Nvidia Driver and reinstalled the new Driver set from Nvidia IT IS WORKING! :D

I can now play longer than 4 hours without crashs!

Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...

I'm getting this now... Not sure why, didn't play for a bit, but didn't change anything on the system either. Seems it was fine a few weeks ago. Anywho, only potential info I can find on the issue is:

https://answers.unrealengine.com/questions/670166/unreal-engine-is-exiting-due-to-d3d-device-being-l-8.html

RAKESH KAMAARA's answer there doesn't seem to apply to my system - not being a laptop, and not having GeForce Experience installed.

Doubt the devs see this sorta thing but, here's what little text I can grab from the crash dump (some day I'll figure out what this weird text format is, keep running into it):

LowLevelFatalError [File:F:\build\Trunk\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176] 
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')
rivate\deferredshadingrenderer.cpp:665]

...and a link to several of the full crash dumps:
https://openload.co/f/AuhtThalgFM/crashdump.7z
("Link could not be added due to error: error" so, copy paste, I guess.)

Particularly annoying thing about this crash is that somehow it prevents shootergame.exe from being killed afterwards, and fsks up all sorts of things after the game *appears* to exit, but the executable is still there... Generally to the point where I gotta do a hard reset to get out - this being the first hard reset I've ever had to do on this fairly new system.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

same here, Ive done tons of reconfigure, even the dangerous regedit. I even bought a new desktop with new win10 home OEM. I thought MS is crashing all pirate OS that's why I availed.

it works for me b4 on my old desktop, same specs with new. mostly my game crashes on main menu when im experimenting on video config. ARK is totally unplayable right now both SP and online.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...