Jump to content

LowLevelFatalError - Unreal Engine is exiting due to D3D device being lost.


Recommended Posts

Hey I've still been getting the issue on Ark Survival Evolved: Aberration of the d3d device being lost even with the registry editor fix that Jat mentioned on his twitter and forum.

--->

He says that this was a fix although mine and some others are still having trouble with this bug. For some reason if my game doesn't encounter this bug report my whole computer just freezes and I have to hold the power button on the PC itself as task manager won't even open. I don't know if this is a separate bug so I might not go too much into it. It does however happen in like 10 min. to 2 hours depending on how long I let the computer shutdown sometimes. So I'm just waiting on feedback from wildcard on the d3d issue. I also have tried using different launch options such as -USEALLAVAILABLECORES -sm4 -d3d10 . This is version 280.115 for those that are wondering.

PC Specs: 

OS Name: Microsoft Windows 10 Home                                                   Version: 10.0.16299 Build 16299

Graphics Card: Radeon (TM) RX 480 Graphics                                         Memory: 8 GB Ram                                                             

Processor: Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 4 Logical Processor(s)

System Type: x64-based PC
 

If you have any way around this or you have an update on the problem that would be great.

Link to post
Share on other sites
  • Replies 130
  • Created
  • Last Reply

Top Posters In This Topic

Here's the crash dump for the D3D bug:

LowLevelFatalError [File:D:\build\PC\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176] 
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')


VERSION: 280.115 
KERNELBASE.dll!UnknownFunction (0x00007ffe566950d8) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FError::LowLevelFatal() (0x00007ff660272666) + 0 bytes [d:\build\pc\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
ShooterGame.exe!TerminateOnDeviceRemoved() (0x00007ff6606751d9) + 0 bytes [d:\build\pc\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:189]
ShooterGame.exe!VerifyD3D11Result() (0x00007ff66067527c) + 0 bytes [d:\build\pc\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
ShooterGame.exe!FD3D11DynamicRHI::RHICreateUniformBuffer() (0x00007ff6606733eb) + 0 bytes [d:\build\pc\engine\source\runtime\windows\d3d11rhi\private\d3d11uniformbuffer.cpp:262]
ShooterGame.exe!FFXSystem::SimulateGPUParticles() (0x00007ff660f61683) + 111 bytes [d:\build\pc\engine\source\runtime\engine\private\particles\particlegpusimulation.cpp:4168]
ShooterGame.exe!FFXSystem::PostRenderOpaque() (0x00007ff660f1e71f) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\particles\fxsystem.cpp:332]
ShooterGame.exe!FDeferredShadingSceneRenderer::Render() (0x00007ff66177091a) + 0 bytes [d:\build\pc\engine\source\runtime\renderer\private\deferredshadingrenderer.cpp:873]
ShooterGame.exe!RenderViewFamily_RenderThread() (0x00007ff661854d8f) + 0 bytes [d:\build\pc\engine\source\runtime\renderer\private\scenerendering.cpp:1151]
ShooterGame.exe!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`13'::EURCMacro_FDrawSceneCommand>::ExecuteTask() (0x00007ff66187a032) + 12 bytes [d:\build\pc\engine\source\runtime\core\public\async\taskgraphinterfaces.h:871]
ShooterGame.exe!FNamedTaskThread::ProcessTasksNamedThread() (0x00007ff6601e23d8) + 0 bytes [d:\build\pc\engine\source\runtime\core\private\async\taskgraph.cpp:939]
ShooterGame.exe!FNamedTaskThread::ProcessTasksUntilQuit() (0x00007ff6601e158d) + 0 bytes [d:\build\pc\engine\source\runtime\core\private\async\taskgraph.cpp:680]
ShooterGame.exe!RenderingThreadMain() (0x00007ff6606e4f09) + 0 bytes [d:\build\pc\engine\source\runtime\rendercore\private\renderingthread.cpp:265]
ShooterGame.exe!FRenderingThread::Run() (0x00007ff6606e5270) + 0 bytes [d:\build\pc\engine\source\runtime\rendercore\private\renderingthread.cpp:385]
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff6602c1816) + 0 bytes [d:\build\pc\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff6602c16d8) + 8 bytes [d:\build\pc\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
KERNEL32.DLL!UnknownFunction (0x00007ffe57b11fe4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffe5a01cb31) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffe5a01cb31) + 0 bytes [UnknownFile:0]
 

Link to post
Share on other sites

I also encountered this crash in aberration. It happens when the nameless spawn (both in the blue zone and at the top left cave).
My girlfriend has a similar pc config, but she isn't crashing (although she was crashing once a day on scorched earth and for me zero crashes there)
We both use -d3d10 (got random crashes without it on the island).
Also when i was testing it out, my friend also crashed back at our startup base(big lake shore) when i crashed at the cave entrance.

We tried -nohithread, but still crashed. Although now i was able take a small look at the nameless, and not just the mud pile. (my friend kept crashing also back at base)

Link to post
Share on other sites

this error is here from beggining of abberation nobody cares i came after half a year to check if its fixed and for two days on abberation server i have this error multiple times on nameless spawn or in river (green biome) 

since the time i had the error first time i updated my graphics driver three times, once reinstalled ark and once fully wiped pc

Im really afreaid whats comming with extinction because this dlc is still the same from the release date

Edited by TreskyPlesky
Link to post
Share on other sites

This isnt an Abberation issue as many here are suggesting. I have Abberation installed but rarely play it. I have had to stop playing ARK for the last 3 months as I constantly crash on the Center. If I log onto the Island or Ab, I also crash.

I think for now, if Jats registry fix doesnt work, we are in the hands of the 'EPIC' gods.

 

Link to post
Share on other sites
  • 2 weeks later...
On 7/27/2018 at 11:20 AM, juzek19985 said:

There is nothing Wildcard can do to stop it because it is more related to the game engine they're using not the actual game.

But an update from them is probably what they should be doing to ensure that the community knows what is going on. Its their game, and their choice of game engine. Even if the fix isn't for them to fix, they should keep us all updated as to what is happening with the Unreal fix.

Im guessing, its still not fixed?

Link to post
Share on other sites
1 hour ago, Anarki said:

But an update from them is probably what they should be doing to ensure that the community knows what is going on. Its their game, and their choice of game engine. Even if the fix isn't for them to fix, they should keep us all updated as to what is happening with the Unreal fix.

Im guessing, its still not fixed?

Unreal Engine hadn't fixed it yet for years.

Link to post
Share on other sites
  • Volunteer Moderator

Okay, I get that the message received when you try to access that thread is confusing but you do not have to get access to the Trading section to access that thread because it is simply no longer available. Recently, the entire PC Bug Reports section has been removed and has been replaced by the report form you can find under the Help menu at the top. The message is just a generic one telling you that if you are trying to access a trading post you need to become a Member first but since you guys are not trying to access a trading post you can ignore that. That being said, the "fix" that was proposed in that thread was not a "fix" but a workaround that was helping for some but was making no difference for others.

Quote

Change TdrDelay using Registry Editor

TDR stands for Timeout Detection and Recovery, and this feature is in charge to restart your graphic card if the system doesn’t receive any response from the graphic card for set amount of time. The default time is 2 seconds, and if system doesn’t get response from your graphic card in 2 seconds it will restart the graphic card and crash your game. This can be quite unpleasant, but there’s way to change that:

  1. Start Registry editor by pressing Windows Key + R and typing regedit in the input field. Press Enter or click OK to run Registry Editor.
  2. In the left pane navigate to the following key:
    • HKEY_LOCAL_MACHINESYSTEMControlSet002ControlGraphicsDrivers
  3. Now in the right pane you need to create a new DWORD if you own 32-bit version of Windows or QWORD if you use 64-bit version of Windows. Name the new DWORD or QWORD TdrDelay.
  4. Now double click the TdrDelay and change its value to 8 or 10.
    registry_tdr
  5. Close Registry Editor and try running the game again.

Source:

Spoiler

I don't recommend you downloading anything from that site because it is not necessary. Just linking by respect for the author of the article.

https://windowsreport.com/ark-survival-evolved-issues-windows-10/

 

 

Edited by invincibleqc
Link to post
Share on other sites
  • 1 month later...

I managed to clear it up, but it was a pain.

I have a 1050 ti, ran driver update 1 by 1 from the first update, until I started getting black screened (another issue I've had).
Ended up at 391.35 (crashed on next, 397.something. Rolled back driver)


I then had to disable the driver for my Nvidia card, go into processes through Task Manager, and stop all Nvidia related tasks. That allowed me to delete C:\Program Files (x86)\NVIDIA Corporation\Shadowplay   


I had read elsewhere that it was causing shadow issues. DirectX 12 has previous versions and is a main component of Windows 10, so I couldn't delete that. Downloading Directx 9.c bridge files didn't work either.
D3D seems to be generating shadows, as Nvidia Control Panel option to check games showed that Ark and Fortnite needed shadows down.
All in all, this is the last thing I could think of. I usually couldn't load into Fortnite PVE Save the World, but I seem to be able to know and start to load a game.
Ark will let me run local, which is sometimes crashed on. I haven't tested unofficial (usually crashed on mod loading or earlier) since friends server is down.


That's my recommendation to test if you have Nvidia GPU's and haven't found a solution through general updating, registry edits, DirectX admin updates etc.

I'll update again if anything changes on my end, good or bad.

 

-Redgren

Link to post
Share on other sites
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...