Jump to content

HammersaurusRex

OSD Won't Eject Loot

Recommended Posts

So I've done a little searching around, and haven't seen anything on this, so I figured I'd bring it up. 

The last two drops I've defended (purple, red) have not given me the option to eject the loot. We tried ejecting the loot from the purple drop (before latest update) at the beginning of wave 5, the end of wave 5, and the end of wave 6. Each time there was no prompt to eject loot. 

Just now, after successfully defending a red OSD, the same thing happened. Tried from every angle, jumped, crouched, even landed on top and tried from above. No luck. 

Is this a known bug? If so, any solutions?

Share this post


Link to post
Share on other sites

I found this "bug" since my first days on Extinction. If I claim a drop I can´t eject it myself, I had to get some some tribe mate to eject it.

I haven´t found this topic anywhere else either, weird, but still happening. It is annoying when you are playing alone, because you can´t claim it and have the risk of thieves coming at the end of last wave to steal your loot, or what just happened to me yesterday, I was on a 3rd wave of a Red drop and some box people came, claimed my drop and left, and there is nothing you can do about it, it is so annoying.

I hope they fix it soon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...