Jump to content

tool [Tool] ARK Smart Breeding: Extract Breeding Stats, Dino-library, pedigree


Recommended Posts

11 hours ago, Nooblet said:

@cad Wondering if i might be able to get some help? I have set all the setting to what the server is set to except "Max Graph Level" ( im guessing this is how many levels the dino can level after being tamed?  set it to 71)  But for some reason anything i try to add to the library comes up with an issue, red stat or just wont extract at all.  As for the server the only mod it has is pre nerf flyers mod & increased rates. Included a picture of the setting's page.

Hi, the "Max Graph Level" is only for the visuals in the tool, it does not affect anything from the calculations. The level after taming is the "Max Tamed Levelups".

The classical-flyers mod changes stat-values, so it's not usable with the tool. There's a way to adjust stat-values with an extra file with the tool, I don't know if that's already working with the classical flyers mod, though. Have a look here: https://github.com/cadon/ARKStatsExtractor/issues/244

Link to post
Share on other sites
  • Replies 686
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Forgot to note the stats of a creature before leveling up? This tool helps to retreive the values that matter for breeding. Now you can also save your extracted stats in a library, see which creature

Wish there was a way we could extract stats on Xbox 

Smart Breeding now supports the extraction of imprinted creatures. Please note that the extraction for imprinted creatures may not work always, as the game sometimes "forgets" to increase some st

Posted Images

i cant seem to turn off oxygen so i filled in 150 for the turtle which is i think the base oxygen level.
im then getting 55 points in speed, seems ridiculous. did i find a high hidden speed stat turtle, or am i doing this wrong ?

edit: no this cant be right, all my turtles have high speed this way,
i hope this problem will be fixed soon.

 

turtle.jpg

Edited by BertNoobians
Link to post
Share on other sites

Good evening all. I play on Xbox and I've been looking for something like this. The only problem it says almost all my level values are wrong and in the help section, it says, as a console player, I need to download an older version and use the values json file from the older version. Only problem is, where do I find an older version? Or do I just wait for the new update.

Link to post
Share on other sites
Guest BubbaCrawfish

Encountering an error when using this for Unicorns at times.

 

Unhandled Exception

Value cannot be null, Parameter name: source.

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentNullException: Value cannot be null.
Parameter name: source
   at System.Linq.Enumerable.Select[TSource,TResult](IEnumerable`1 source, Func`2 selector)
   at ARKBreedingStats.CreatureBox.setCreature(Creature creature)
   at ARKBreedingStats.Form1.listViewLibrary_SelectedIndexChanged(Object sender, EventArgs e)
   at System.Windows.Forms.ListView.OnSelectedIndexChanged(EventArgs e)
   at System.Windows.Forms.ListView.WmReflectNotify(Message& m)
   at System.Windows.Forms.ListView.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
ARK Smart Breeding
    Assembly Version: 1.0.0.0
    Win32 Version: 0.22.4
    CodeBase: file:///C:/Users/Gamer/Downloads/ARK.Smart.Breeding_0.20.11.2/ARK%20Smart%20Breeding.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1638.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Serialization
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
SMDiagnostics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/SMDiagnostics/v4.0_4.0.0.0__b77a5c561934e089/SMDiagnostics.dll
----------------------------------------
System.ServiceModel.Internals
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceModel.Internals/v4.0_4.0.0.0__31bf3856ad364e35/System.ServiceModel.Internals.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Am I missing something? It works on everything else, but sometimes if I do encounter this and select an Equus it'll also throw the exception I think.

Link to post
Share on other sites

Hi @Rinjii, @Totallyevil1, @BertNoobians and @rattenmann, make sure you don't have checked the "Enable Oxygen for all Species" in the general settings, this should only be anbled if you use mods that show the oxygen-stat for all species. If you have disabled this setting and still see the oxygen-stat enabled for the species that shouldn't have it, try restarting the tool, select another species with oxygen and then back to the species you had.

Hi @mastermat, is the possibility with 44 levels in stamina not correct? It would be this combination: Rex (Lvl 305, Impr: 73.44%): HP: 14626.7 (50, 1); St: 2268 (44, 0); Ox: 675 (35, 0); Fo: 13762.6 (30, 0); We: 894.6 (28, 0); Dm: 766.1% (50, 35); Sp: 114.7% (31, 0); To: 30363 (268);

Hi @Kalizard, you can find a list of releases here: https://github.com/cadon/ARKStatsExtractor/releases , or you wait for the xbox-update, that should work, too.

Hi @BubbaCrawfish, thanks for the report, that'll be fixed in the next release.

Link to post
Share on other sites

Hey, I decided to give this nifty tool another go as my tribemate/admin successfully could add a freshly tamed ptera yesterday (he couldn't add a thyla though...). I tested with my ankys again, and still get the food/melee errors as before, so tried with my terror birds instead and it worked! :D

I could add all of my bred ones until I tried adding the ones with a melee mutation, then I got the red flag again. I can add the base melee no problems, but not the mutated variant of said melee so what could be the issue?

I'll add two screenshots, one with the base melee and one with the mutated one.

First one is of Amber who has been successfully added to my library:
nw7MkUC.jpg

 

The second one I couldn't add because of the error:
1GnwnHh.jpg

The ancestors of these two were tamed on cooked mutton chops on SE with x4 taming. I've no idea if this info helps any but thought I should add it anyway. Everything else is vanilla, no changed stat multipliers etc.

 

EDIT: Just tested if I could add the stats of the ancestors and I can, but I do get yellow on weight and melee on them. I tried with an equus to and all green there. I don't get any yellow on the base stats on the bred terror birds though, it's all green. :)

Edited by TotallyUncool
Added info
Link to post
Share on other sites
19 hours ago, Jonathanasger said:

How does the "overlay" work?

Is it like steam overlay, so I can acces it without alt-tabbing?
Is it safe to use with battle-eye and stuff?

Thanks

If you enable the overlay, it will show additional infos, e.g. in the inventories it can show the level-numbers, or you can use the speech-recognition (if you enabled it in the settings) to display taming-infos during playing. It does not violate with battle-eye, it's safe to use.

3 hours ago, TotallyUncool said:

Hey, I decided to give this nifty tool another go as my tribemate/admin successfully could add a freshly tamed ptera yesterday (he couldn't add a thyla though...). I tested with my ankys again, and still get the food/melee errors as before, so tried with my terror birds instead and it worked! :D

I could add all of my bred ones until I tried adding the ones with a melee mutation, then I got the red flag again. I can add the base melee no problems, but not the mutated variant of said melee so what could be the issue?

The ancestors of these two were tamed on cooked mutton chops on SE with x4 taming. I've no idea if this info helps any but thought I should add it anyway. Everything else is vanilla, no changed stat multipliers etc.

EDIT: Just tested if I could add the stats of the ancestors and I can, but I do get yellow on weight and melee on them. I tried with an equus to and all green there. I don't get any yellow on the base stats on the bred terror birds though, it's all green. :)

Hi, good to hear it works with some. I still have no idea what's the issue with the non-working. A mutation should only give two more levels, but 407% damage is not a valid number, the closest is 408.1% Maybe there was a change how mutations work. You can try to levelup the damage once, maybe it'll be recalculated and works then.

Link to post
Share on other sites
3 hours ago, cad said:

Hi, good to hear it works with some. I still have no idea what's the issue with the non-working. A mutation should only give two more levels, but 407% damage is not a valid number, the closest is 408.1% Maybe there was a change how mutations work. You can try to levelup the damage once, maybe it'll be recalculated and works then.

I forgot to mention that I leveled the melee on one of them by one level and it still didn't work. The melee is now 413.1% on the one I leveled up, maybe I should try and level it up again?

It's great that I can add the base values though as I wanted to see how many lost levels I had on them, and we can add some animals at least. I'm starting to think that our servers are a bit..."special". xD

Link to post
Share on other sites

So I have 0.23 but I'm still having issues when trying to Read Values from ARK window. This is making it so I can't add the data to a library. Every time, without fail, four things are highligted as if they're invalid. The "Wild, Tamed, Bred" radial buttons are highlighted, the level box is highlighted, the lower end of the TE, and the "since taming no server-restart". I've done everything I can to fix it. All of my multipliers are correct in the settings. I'm in Windowed Fullscreen 1920x1080, all stats are unlocked, yet it's still not working. Any ideas? 

Edit: Also, when it does work, stats are highlighted in red, even though they're correct. 

Edited by FunctionalPessimist
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...