Jump to content


It Won't Let Me Play Scorched Earth

Recommended Posts

Posted (edited)

So i purchased the Scorched Earth DLC for ARK on Xbox One S. After the DLC finished downloading and installing, I went to join a single player world for Scorched Earth. When I hit "Play Single Player" a message popped up saying I had not installed the required DLC. It gave me the option to go to the Microsoft Store to install it. When I went to the store through the link and it said I had installed it. I restarted my Xbox, ARK, and I even took the disc out. Nothing worked. I had recently, before buying Scorched Earth, bought the Aberration DLC, which worked perfectly fine. I uninstalled Scorched Earth and reinstalled it, to see if that worked. It didn't work. I then uninstalled Aberration and reinstalled it, which DID work. Please help me. I spent $8 On Scorched Earth, it was the New Year's discount, and Scorched Earth has always been my favorite map. I'm very upset that it isn't working. Please Help!

Edited by TheBigOOF

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...