Jump to content

Compile Errors in latest version


Ferrat

Recommended Posts

Has anyone else experienced the dev kit freezing every now and again for just a few seconds, I have and I think it is down to a compile error mentioned below, there are more compile errors in just this one file but I will add just this one.......

 

File errors appear in - Charge_RockBase_BP

 

Node - AddCharge

 

Compile error explanation....

Default value "charge" value type is invalid "charge" is not a valid enumerant of <EPrimalCharacterStatusValues>

 

When play is pressed (in the editor) I get the following error message.....

 

One or more blueprints has an unresolved compiler error are you sure you want to play in editor.

Charge_RockBase_BP

 

This is just one of a few compile errors within this file, can we have this sorted please.

 

I include some images of the errors, and YES I have verified the files at the launcher.

CompileErrorMain.jpg

CompileError001.jpg

CompileError002.jpg

 

If play is selected in the editor I get this......

 

EditorPlayMsg001.thumb.jpg.59b95dc03617385e172dbde22aab9d97.jpg

 

 

 

EditorPlayMsg002.jpg

 

Link to post
Share on other sites

Okay I am going to say this even if WC are obviously NOT reading the bug report section as they should be, I thought maybe I had inadvertently deleted or changed something in the file so decided to do as full uninstall then install of the Dev Kit (even though I realized it would take most of the day, I at least am not against trying to sort this) but upon restarting the fresh reinstalled dev kit the compile error is STILL THERE.

This is a BIG problem and should never have got to the release stage, it is a basic thing to check if a blueprint compiles correctly, every modder knows that so why doesn't WC, they are after all suppose to be the professionals here.

Link to post
Share on other sites

Okay this is the LAST time I will be reporting anything on here, the site is USELESS as WildCard do not even look on here let alone act on anything put here, if they want to put poope out then we will have to learn to like it or leave it. I have been cooking a mod now for over 24 hours as the latest version of the dev kit is so full of errors it has been deamed almost useless. I will not be bumping this anymore as there is no freaking point, just let WC send out poop it is what they are good at!

Link to post
Share on other sites

It has been 12 days now since I reported this error, it is not as if it is a silly little error it is a MASSIVE error on the part of WildCard, this could answer all the 'game is crashing' reports since the update but WC do not seem interested in either sorting it out or putting a comment on this post, probably too busy making another money spinning DLC than to correct their errors on the last one. Lets have this sorted out or at least explain why there are compile errors in a released DLC.

Link to post
Share on other sites
  • 4 weeks later...

Okay they obviously DO NOT CARE that they are sending out errors to paying customers, just upgraded to version 278 of the dev kit and this error IS STILL THERE, do they not read this bug report section or is it that they simply DO NOT CARE and are concentrating too much on getting it out to other platforms to make more money, this is SO frustrating. This as I said earlier could be the cause of a lot of reported problems, your customers are reporting serious problems WC so please sort them out.

Link to post
Share on other sites

I can't belive how WC manage the bug, reports, mods, etc... The info is so confuse, outdated, posted everywere without any order and if you came to the official page, you don't get an answer. I can't belive it. Best try to post at UE4 forum, maybe there you find a solution. A question for you Ferrat, since i land here due to cook errors in my little map and maybe you can help me. I try to find the log of the cook process since even the map is revised with no errors, i get 8 errors and a failure at the end of the process. Can you help me with that?

Thanks in advance and a friendly bump for this.

Link to post
Share on other sites
  • Wildcard Community

Hello! I am the new Mod Community Manager.
I'm sorry that this has gone without response for so long it's difficult for me to go back through the older threads since I didn't have a very large presence on STA before I started.

As for why you get pauses in in the devkit I don't believe this is due to compile errors (Unless you are actually manually trying to compile something when it happens) The devkit to my knowledge doesn't do any auto-compiling with the exception of shaders, but even then you do have to take an action which forces an asset to load that it needs to compile shaders for.

If these are pauses that occur without any user interaction it could be the autosave, or it could be that the devkit is starved for resources. Right now my memory delta is about 10GB and taking up about 55% CPU of my FX-8350 (8 logical cores at 4 GHz). So the resource desire of the devkit is quite massive.

If the hitches you describe are when you are opening files, that is because when you open any file in the devkit it also tries to load any and all files that are referenced by it in a long cascading chain of frustration (I always load my PGD first thing after I open my kit to try and get as much of that done and over with as early as possible).

Otherwise, I'm going to need a better description of where these pauses are occurring in order to be able to potentially determine the cause.

I did open the file in questions though, and I DO see the compile errors in its log so I am going to investigate that.
That particular blueprint does not appear to be referenced by anything though and It shouldn't even be getting loaded or process by the devkit unless you specifically open it.
Does the compile error in that file cause you to be unable to cook your mod?

Link to post
Share on other sites

The pauses happen every 3 or 4 minutes regularly, it is not something that you can quantify as happening randomly or as a save option, in test mode when you test a change in the mod and run the game in the editor window you (or I) will experience the game freeze every few minutes (by this I mean less than 5 mins) and it happens regularly. It did not do this before the Aberration DLC items were added to the last but 1 update and that is why I assumed it was to do with the Charge Rock mis-compile error, as far as

On 3/30/2018 at 5:47 AM, ZenRowe said:

to my knowledge doesn't do any auto-compiling with the exception of shaders

is concerned it does warn you the first time you test start the game in the editor that there is a compiler error and would you like to carry on, so yes I think it is trying to run this erroneous file while playing causing the lags (pauses) in the test game.

Link to post
Share on other sites
  • Wildcard Community
4 hours ago, Ferrat said:

is concerned it does warn you the first time you test start the game in the editor that there is a compiler error and would you like to carry on, so yes I think it is trying to run this erroneous file while playing causing the lags (pauses) in the test game.

If you have opened that file and try to start PIE, yes you will get that warning about the file. if you don't open the file it doesn't get loaded. unless you have a mod that is referencing it.

You say the pauses started happening after the aberration update was added to the kit, do they also only happen when using 'play in editor'?
When aberration was added there was a ton of new assets added to the game, as a result, the resource requirements increased as well. Also possible that your mod is trying to access something other people don't really try and you found something there.
What are your PC specs like?
What is in the mod you are testing with?
If you restart the devkit entirely and run PIE without having loaded ANY files do you still get the pauses?
(Also side note, just in case, make sure you do not have a PGD override saved in the default loaded test map)

Link to post
Share on other sites

This happens WHEN I am playing in the editor and no my mod is not accessing anything from the aberration DLC. This happens with all my mods no matter what it does or what it references, I would not be able to test my mod at all without putting the PrimalGameData override blueprint in would I?.

 

I have an AMD A10-5800K quad core computer x64 based processor

Installed memory is 16 Gb

Graphics card is a Radeon HD7770 with 3Gb onboard (hopefully soon to be upgraded to a GTX 1080)

Running Windows 8.1 64bit version

UE4 is up to date as is the Dev Kit.

 

The mod I am testing it with does not matter as it does this with ALL my mods no matter what the type.

 

I have just tried running the mod in the editor window without a PGD file saved and it does not work!!!!!

 

Link to post
Share on other sites
  • Wildcard Community

Apologies, I should have been more clear about what I trying to get you to do. I am trying to figure out if this has a tipping point where the problem occurs vs when it doesn't. The Charge rock is not loaded by default in the kit, so we need to figure out when and why it is happening.

so I would like you to follow these steps(with no extra actions whatsoever) if possible and tell me at which step the problem starts to occur.

1. Open the default test map (The one that automatically opens when the kit does) and make sure that there is no PGD is saved in the override. Save the map, and shut down the devkit entirely.
2. Go to your mods folder and remove all your mods (you can leave the mods that come default with the devkit) from the devkit, and put them somewhere else for safekeeping.
3. Launch the devkit. do not open any files, do not even click on any of them.
4. Start PIE (Do you get the compile warning here still?)
5. Shut down the kit.
6. Move your mod files back into the devkit mod directory.
7. launch the devkit. do not open any files, no clicking.
8. Start PIE (does the compile warning happen here?)
9. Open your mods PGD (Don't add it to the PGD override of the map though)
10. Start PIE (How about now?)


As for the pauses, between using a 7770 and only 16GB of RAM (Like I said, my memory delta is about 10GB since aberration was added to the devkit, so that doesn't leave you much room, Win10 like to eat up about 4GB all by itself) I think your system might just be under a lot of pressure.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...