• Announcements

    • Jatheish

      Note for players regarding Ascension (please open terminal/tribute before ascending)   02/04/18

      With the latest server update on PC (v276.493), if you're going to attempt ascension, before doing so please make sure you've opened a supply crate/transmitter/obelisk/ basically anything terminal/tribute inventories. It's a temp workaround to characters being lost when ascending whilst we're investigating character issues further.
    • Eli

      Official PC: Hard Turret Limit begins on 18th of February at 1PM ET   02/16/18

      On the 18th of February, at 1PM ET we will be enabling the hard turret limit on all PC Official Servers. This means that you will not be able to build over 100 turrets within a 10k unit radius. This will work on autoturrets, heavy turrets, tek turrets, plus plant turrets and is no longer map specific. The hard limit calculation is done on start-up, so if your turrets are ever over the limit, they will be randomly shut-off until you're under the limit. In order to restore shut off turrets, you must pick up any which exceed the number, as well as shut-off turrets and replace them in order for them to work.
Sign in to follow this  
Matt189

Dedicated Server On PC for Xbox?

Recommended Posts

I hosted a dedicated server on my PC, I was able to join it on my local network through my Xbox however my friends would receive "unable to join" messages when attempting to connect. I tried searching through other forums and posts however most of those searches came up empty. Does anyone know any solutions or tips on how to get this to work?

Share this post


Link to post
Share on other sites

I am trying this as well but no matter what i try my friend cant connect.

i have my server hosted on my Gaming PC through the Windows 10 Store version of Ark with a Silver account and me and my friends Play our gold accounts on the Xbox One
Once set up, i did not see my server in the Player Dedicated list but i was able to Join in my LAN by friending the silver account and just going to Join Game.
My friends could not connect from outside my network though.

At first i only had the following forwarded and i could join but my friends got Join Failed message

TCP: 3074
UDP: 88,500,3074,3544,4500
I also set up rules to allow them through my windows firewall and tested their availability with a port checker

Currently i am set up with the following ports forwarded and my windows firewall disabled on my PC (I know that's not secure but did it for troubleshooting purposes)

TCP: 3074, 25147, 27015-27030, 27036-27037
UDP: 88, 500, 3074, 3544,4380, 4500, 7777, 25147, 27000-27031, 27036

 

What am I missing / doing wrong

Share this post


Link to post
Share on other sites
On 2/6/2018 at 11:40 AM, Zeddicus919 said:

I am trying this as well but no matter what i try my friend cant connect.

i have my server hosted on my Gaming PC through the Windows 10 Store version of Ark with a Silver account and me and my friends Play our gold accounts on the Xbox One
Once set up, i did not see my server in the Player Dedicated list but i was able to Join in my LAN by friending the silver account and just going to Join Game.
My friends could not connect from outside my network though.

At first i only had the following forwarded and i could join but my friends got Join Failed message

TCP: 3074
UDP: 88,500,3074,3544,4500
I also set up rules to allow them through my windows firewall and tested their availability with a port checker

Currently i am set up with the following ports forwarded and my windows firewall disabled on my PC (I know that's not secure but did it for troubleshooting purposes)

TCP: 3074, 25147, 27015-27030, 27036-27037
UDP: 88, 500, 3074, 3544,4380, 4500, 7777, 25147, 27000-27031, 27036

 

What am I missing / doing wrong

NAT types are open all around, even when removing all my port forwards and going back to bones i cant connect within my own LAN anymore either..

Has ANYONE ever set this up successfully? Now i don't have a way to play on the same server as my Wife anymore...

Share this post


Link to post
Share on other sites

Mine works fine, I use upnp on my router so I don't even need to open ports. I can connect locally on my lan and others can connect also via my hosting pc by joining, on the host pc xbox account. It occasionally will show up on ark server list but it seems completely random.

I am currently trying to figure out if I can cluster servers by using VMs, it might work but I am not sure of performance. 

 

Ping your host computer and see if you can even see it. I put my host on a dedicated ip not within dhcp range because it could end up dropping it on refresh of tables or reassign it an different interal ip which might drop connections.

Edited by Juggernaut

Share this post


Link to post
Share on other sites

 

21 hours ago, Juggernaut said:

Mine works fine, I use upnp on my router so I don't even need to open ports. I can connect locally on my lan and others can connect also via my hosting pc by joining, on the host pc xbox account. It occasionally will show up on ark server list but it seems completely random.

I am currently trying to figure out if I can cluster servers by using VMs, it might work but I am not sure of performance. 

 

Ping your host computer and see if you can even see it. I put my host on a dedicated ip not within dhcp range because it could end up dropping it on refresh of tables or reassign it an different interal ip which might drop connections.

Thanks for the suggestion, i wonder if because i have UPnP enabled as well the port forwards and it are fighting. also i did set a static but well within the random assignment range, ill reconfigure and try again. Ill let you know how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this