Jump to content
BIGDisreallyBIG

Friends can't join my dedicated server...

Recommended Posts

I've set up a server to host my friends on Win10 PC, friends on xbox.  Yes, it is the windows store version, crossplay compatible, I've tried with and without passwords, and it never lets my friends join.

Trying to start on Abberation. One of my friends played in my basement and was able to join, but a few others were not.  Any ideas?  I've looked over the setting and can't figure out how to move forward, and it is very frustrating to be stuck on something that should be working fine.

Share this post


Link to post
Share on other sites

So just to clarify you have people on xbox that can join and some that cant? Or is it only the people trying to play on the xbox that cant join? There is a setting I believe to enable crossplay. Also it could be your router settings. There are more similar posts in the xbox bugs and support forum also. I havent really been paying attention to them as I dont use this feature. Sorry Im not much help but theres definitely other people having similar issues so there should ve more info out there.

Share this post


Link to post
Share on other sites

Same issue here. After the last Xbox Ark update, only the PC host can sign in from his Xbox on the same home network. Even though that is also going through Xbox Live, no one else can connect from Xbox Live now. This is with having the hosting Silver account added as a friend and attempting to join game through that friend. Everyone outside of the hosts home network receives "Join Failed". We would also like to know if there is a fix. 

Share this post


Link to post
Share on other sites

I have the opposite problem it seems...

I set up a dedi server on PC using silver account... runs fine.  My friends on Xbox outside my house CAN JOIN.  My Xbox in the house gets the "joined failed."  I can join other people's Dedi servers that actually show up on the server list.

This PC thing has been crap from day 1.

On Game load I get stuck on PrimalGamedata_BP and I get the fail.

Edited by HappyNem
new info

Share this post


Link to post
Share on other sites

I am having the same problem. I host an xbox cross play server on my windows 10 pc, I have 3 other xbox's on my local network that can all join no problems, any time someone else tries to join they get "Failed to join". I have tried enabling UPnP, I have set port forwarding to my pc with a static IP for all ARK and XBox One ports forwarded to it, I set the PC to the DMZ, I even completely disabled the router firewall and I received the same issue. Other people weren't able to join when trying to host on an Xbox either. I bypass the router and online friends can connect just fine. I put the router back in line, same issue, tried another router and have the same issue, even tried having friends join while all other devices but the pc were off with it connected to the router, new router had UPnP enabled, ports forwarded, and it was DMZed with no effect. Any assistance?

Share this post


Link to post
Share on other sites

I have the server set up on my win10 PC and I couldn't connect from my home network. I had never had problems and always had open NAT so i never did the port forwarding. So I went ahead and did that and now I can connect from inside the network but no one  else can from outside. I'm just wondering if anyone can confirm that the people trying to connect from outside the network do infact have theirs done and still have the problem.

Share this post


Link to post
Share on other sites
On 3/27/2018 at 8:13 AM, mitzelplick said:

Be real raptoring nice if poop got answered...Same problem for me. must not matter because im past the refund window, huh?

Yes, everyday we complain about windows 10 store version but nothing gets fixed. Crickets...what we get when the devs port steam version to Xbox and then port the Xbox version back to PC windows 10 store version. If you think they didn't care about console players, imagine the amount stuff they care about windows 10 store version. I post everyday about store issues but nothing is fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...