Jump to content

Windows 10 / Play Anywhere - Closes on Start Up


Recommended Posts

  • Replies 339
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This is not about this topic but I’ve got an idea about something you could do for the dlc extinction. Instead of having canteens water bottles and skins you could have a uncommon chance to find a wat

If you search for ARK in Add or Remove Programs, then select 'Advanced,' you'll see a list of add-ons. Just select one of them, and hit uninstall and then head to the store again, to reinstall it. 

Can confirm that installing scorched earth allowed my game to launch fully

Posted Images

53 minutes ago, CyberAngel67 said:

Would you be in a position to test if you can run the game from two accounts, on the same computer at the same time, on that build?

I am running the game on a server PC (the one that is experiencing issues) and playing on another PC (haven't had any issues playing or start-up issues) using the same gold account to purchase the game on each machine. I could run the game twice on the same PC. Not sure if I can host and play on the same PC at the same time though. The play PC uses my xbox gold account and the server PC uses a silver xbox account. 

 

My play PC is on stock windows 10 pro (haven't installed insider yet as I don't have issues on it), I just installed the insider build on the windows 10 ark server PC, the one with client licensing/crashing issues. A few people already joined the server but have to wait and see after a day or two if it crashes due to DCOM/Client license stuff. 

Specs for my machines are nearly identical:

Server PC: 16gb ddr3, i7-4790k (slight overclock on it given I run a 10x boosted server), windows 10 pro insider, intel stock graphics

Play PC: 8gb DDR3, i5-4690k, windows 10 pro stock, rx 480 graphics card. 

Edited by Juggernaut
Link to post
Share on other sites
3 hours ago, Juggernaut said:

I am running the game on a server PC (the one that is experiencing issues) and playing on another PC (haven't had any issues playing or start-up issues) using the same gold account to purchase the game on each machine. I could run the game twice on the same PC. Not sure if I can host and play on the same PC at the same time though. The play PC uses my xbox gold account and the server PC uses a silver xbox account. 

 

My play PC is on stock windows 10 pro (haven't installed insider yet as I don't have issues on it), I just installed the insider build on the windows 10 ark server PC, the one with client licensing/crashing issues. A few people already joined the server but have to wait and see after a day or two if it crashes due to DCOM/Client license stuff. 

Specs for my machines are nearly identical:

Server PC: 16gb ddr3, i7-4790k (slight overclock on it given I run a 10x boosted server), windows 10 pro insider, intel stock graphics

Play PC: 8gb DDR3, i5-4690k, windows 10 pro stock, rx 480 graphics card. 

Yeah it is the running it on the same machine as you play that I am interested in. I had this working for about 10 days after Ark Win10 was released, then it just stopped working and has never worked since. I have that insider build, but not on a machine that will run Ark unfortunately.

Link to post
Share on other sites
2 minutes ago, CyberAngel67 said:

Yeah it is the running it on the same machine as you play that I am interested in. I had this working for about 10 days after Ark Win10 was released, then it just stopped working and has never worked since. I have that insider build, but not on a machine that will run Ark unfortunately.

I was able to run a VM before on the same machine and it worked. I think the sharing of licenses with multiple Xbox accounts is causing some kind of issue overall though. 

Link to post
Share on other sites
10 minutes ago, Juggernaut said:

I was able to run a VM before on the same machine and it worked. I think the sharing of licenses with multiple Xbox accounts is causing some kind of issue overall though. 

Not looking for a VM solution, looking to see if the preview version mentioned, will fix it for this situation.

Link to post
Share on other sites

Thank you for the potential fix Jesse, I installed what you recommended. This is the most recent error:

Unable to start a DCOM Server: StudioWildcard.4558480580BB9_1.7.771.2_x64__1w2mm55455e38!AppARKSurvivalEvolved as Unavailable/Unavailable. The error:
"5"
Happened while starting this command:
"C:\Program Files\WindowsApps\StudioWildcard.4558480580BB9_1.7.771.2_x64__1w2mm55455e38\ShooterGame\Binaries\UWP64\ShooterGame.exe" -ServerName:AppARKSurvivalEvolved.AppX8dqae3jbqbp71qzw0jv2man0p45gr0c6.mca

 

Edited by ARKhaspotential
Link to post
Share on other sites
  • Wildcard Staff
19 minutes ago, ARKhaspotential said:

Thank you for the potential fix Jesse, I installed what you recommended. This is the most recent error:

Unable to start a DCOM Server: StudioWildcard.4558480580BB9_1.7.771.2_x64__1w2mm55455e38!AppARKSurvivalEvolved as Unavailable/Unavailable. The error:
"5"
Happened while starting this command:
"C:\Program Files\WindowsApps\StudioWildcard.4558480580BB9_1.7.771.2_x64__1w2mm55455e38\ShooterGame\Binaries\UWP64\ShooterGame.exe" -ServerName:AppARKSurvivalEvolved.AppX8dqae3jbqbp71qzw0jv2man0p45gr0c6.mca

 

Can you please let me know exactly what build of Windows you are running under System Information > Version? What are the steps you took in detail? Thanks!

Link to post
Share on other sites

Yes. The computer is running win 10 pro version 10.0.17115 build 17115.rs4_release.180302-1642. At first i tried "skip ahead to next windows release"and errors did not change. I then reloaded windows via revert option offered when stoping windows insider updates and selected keep personal files. I then used the update window from start menu again and selected "active development of windows" and selected "slow pace". Acouple hours later, all installs were successful and computer was up to date. I updated store, redownloaded ark, and tried launching via xbox app, desktop, and store. I got error mentioned and it closed out on launch. I spam launched ark to see any errors generated. Dlc license did not change error. This error is the only one and consistent

this is the file detailing event, licensingdiag, wscollect https://www.dropbox.com/s/ri394594lxrzt0m/ARKerror.zip?dl=0

 

Edited by ARKhaspotential
Link to post
Share on other sites
5 hours ago, ARKhaspotential said:

Yes. The computer is running win 10 pro version 10.0.17115 build 17115.rs4_release.180302-1642. At first i tried "skip ahead to next windows release"and errors did not change. I then reloaded windows via revert option offered when stoping windows insider updates and selected keep personal files. I then used the update window from start menu again and selected "active development of windows" and selected "slow pace". Acouple hours later, all installs were successful and computer was up to date. I updated store, redownloaded ark, and tried launching via xbox app, desktop, and store. I got error mentioned and it closed out on launch. I spam launched ark to see any errors generated. Dlc license did not change error. This error is the only one and consistent

this is the file detailing event, licensingdiag, wscollect https://www.dropbox.com/s/ri394594lxrzt0m/ARKerror.zip?dl=0

 

Did you try downloading another app and then launch ark?

Link to post
Share on other sites

@Jesse I am on win 10 pro version 10.0.17115 build 17115.rs4_release.180302-1642 and haven't had to server restart/server crash in the past 24hrs with no events related to client licensing/dcom server issues now which is good (thank you for suggestion) but I am still getting issues with people not able to join the game after while via xbox. I have seen others complain of this also.There are no events error related to it. I have open NAT and ports forwarded. Server I run is PC windows 10 store hosted, cross play enabled, not password protected

 

 

 

 

 

 

 

 

 

open nat.PNG

port forward.PNG

Edited by Juggernaut
Link to post
Share on other sites
1 hour ago, Juggernaut said:

@Jesse I am on win 10 pro version 10.0.17115 build 17115.rs4_release.180302-1642 and haven't had to server restart/server crash in the past 24hrs with no events related to client licensing/dcom server issues now which is good (thank you for suggestion) but I am still getting issues with people not able to join the game after while via xbox. I have seen others complain of this also.There are no events error related to it. I have open NAT and ports forwarded. Server I run is PC windows 10 store hosted, cross play enabled, not password protected

 

 

 

 

 

Yeah this is an issue I have been seeing a lot as well, the only solution I have seen that works, is to open the Xbox App and within a minute or two people can join via the GT again.

Link to post
Share on other sites
2 minutes ago, CyberAngel67 said:

Yeah this is an issue I have been seeing a lot as well, the only solution I have seen that works, is to open the Xbox App and within a minute or two people can join via the GT again.

I tried that, closed the xbox app and everything, still wouldn't allow people to join unless i closed ark down and restarted it. 

Link to post
Share on other sites
29 minutes ago, ARKhaspotential said:

Has anyone tried puting the server in the network dmz and hardening the host? Since its a public facing server, id assume this could solve a lot of connection issues. If firewalls or virus scans are the problem. Unfortunatly it probly wont be NAT protected

Shouldn't have to, hosting a server worked fine 2 weeks ago before TLC update and the latest window xbox app updates, "xbox identity program" app updates, and windows 10 updates. No way I am exposing my windows pc to dmz, a xbox console sure. Plus I need remote access to the server PC.

Edited by Juggernaut
Link to post
Share on other sites

If might not be related at all, but on Tuesday I found that inside C:/Program Files/Windows Apps/... I found full version 770 files. When 771 dropped, I downloaded the patch for 15 hours and the amount of GB it was downloading kept rising. I eventually stopped it around 95GB, and decided to uninstall ark and reinstall the new version. Evidently when I uninstalled the old version, it never got rid of the files in C:/Program Files/Windows Apps/. I installed the new version and after the 70GB download it worked, but would crash after 24 hours. Fast forward to last Tuesday (the 13th) When trying to clear up space on my hard drive I found the old version files. I promptly took ownership of the folder and deleted it. I also had older versions of aberration and SE in there as well that I also removed. 

 

Unfortunately, because of all this mess of having to uninstall and reinstall SE every day I forgot to turn the windows update service off and Windows decided to update my computer early Tuesday, before I made any of these changes. Because of this I cannot accurately say whether removing the old files fixed my problem, or whether it was the Windows update, or maybe both? Regardless my game client hasn't crashed since.

Link to post
Share on other sites
3 hours ago, DeadlyNancy said:

If might not be related at all, but on Tuesday I found that inside C:/Program Files/Windows Apps/... I found full version 770 files. When 771 dropped, I downloaded the patch for 15 hours and the amount of GB it was downloading kept rising. I eventually stopped it around 95GB, and decided to uninstall ark and reinstall the new version. Evidently when I uninstalled the old version, it never got rid of the files in C:/Program Files/Windows Apps/. I installed the new version and after the 70GB download it worked, but would crash after 24 hours. Fast forward to last Tuesday (the 13th) When trying to clear up space on my hard drive I found the old version files. I promptly took ownership of the folder and deleted it. I also had older versions of aberration and SE in there as well that I also removed. 

 

Unfortunately, because of all this mess of having to uninstall and reinstall SE every day I forgot to turn the windows update service off and Windows decided to update my computer early Tuesday, before I made any of these changes. Because of this I cannot accurately say whether removing the old files fixed my problem, or whether it was the Windows update, or maybe both? Regardless my game client hasn't crashed since.

This has been an issue since day 1 on windows 10 store version, it doesn't properly handle updates correctly and makes you download the entire game each time there is an update. RIP people on metered/slow connections. 

Link to post
Share on other sites
  • Wildcard Staff

Hey all,

 

I'm really sorry about all the Windows Store problems! If the Insider Build does not fix it for you, Microsoft requests that you leave feedback / errors about the store in the Feedback Hub App. Unfortunately many of these launch, update, and connection issues seem to be related to things outside of our control. :(

 

Jesse

Link to post
Share on other sites
On 3/13/2018 at 3:32 PM, Jesse said:

POTENTIAL FIX! If you are still experiencing issues with Win10 version closing on launch, we have some evidence that the problem is fixed in Windows Insider Builds (source: I had the problem > Microsoft mentioned it might be fixed in Insider > I installed Windows Insider Slow Ring > Problem went away). 

If any of you are brave enough to sign up for Windows Insider and give the latest builds a try, please let us know if the problem is resolved for you. If you continue to have the problem, let us know that, too. Thanks!

Still broken for me.

I have been following this thread since mid Feb when I first had the problem closing on splash screen problem. Tried all the solutions including this one. I am on slow ring  currently running windows 10 pro Build 17120.rs4 180309-1616

After uninstalling and reinstalling in this build a new problem developed, now it is stuck in a download loop. I am running vanilla ark, it downloads over 80 GB (much larger then the game), then the download freezes, if I pause and restart the download it restarts at around 20 GB and repeats....

 

Link to post
Share on other sites
1 hour ago, dumuzi99 said:

Still broken for me.

I have been following this thread since mid Feb when I first had the problem closing on splash screen problem. Tried all the solutions including this one. I am on slow ring  currently running windows 10 pro Build 17120.rs4 180309-1616

After uninstalling and reinstalling in this build a new problem developed, now it is stuck in a download loop. I am running vanilla ark, it downloads over 80 GB (much larger then the game), then the download freezes, if I pause and restart the download it restarts at around 20 GB and repeats....

 

try to clear the game cache/rest under apps > ark > advanced options. Then do wsreset.exe. I am on that same build haven't crashed in 5 days (was crashing every day before i downloaded that windows build) still not on server list though...

Link to post
Share on other sites
On 3/15/2018 at 8:08 AM, Juggernaut said:

I tried that, closed the xbox app and everything, still wouldn't allow people to join unless i closed ark down and restarted it. 

 

On 3/16/2018 at 2:27 PM, Jesse said:

Hey all,

 

I'm really sorry about all the Windows Store problems! If the Insider Build does not fix it for you, Microsoft requests that you leave feedback / errors about the store in the Feedback Hub App. Unfortunately many of these launch, update, and connection issues seem to be related to things outside of our control. :(

 

Jesse

 

After installing the insider build my game is no longer crashing. I've had PC and Xbox users able to join for the last 3 days without any issue. I haven't had any issues with xbox users trying to connect. I'll keep an eye out.

Windows 10 Pro

17120.rs4_release.180309-1616

Link to post
Share on other sites

My server finally crashed after being on server list for a few days, constantly at 70 ppl. Wasn't related to dcom/licensing though, just that ark straight up crashed in event viewer. Still on windows insider builds. Back to waiting 5 days before I can appear on server list again...

Edited by Juggernaut
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...