Jump to content

Any Fix In Sight For "Joining failed - could not retrieve address"


Go to solution Solved by Chuwalee,

Recommended Posts

  • Replies 779
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

No solution yet, but there is a work around.   Go to your network settings, hit advanced settings go to DNS and make your primary and secondary DNS 8.8.8.8

Hi, Everytime I go to join an Official dedicated server it says "could not retrieve address". After I try a few more times the game freezes and dashboards me. It does t

The changing my DNS setting worked thank u so much!!!!!!!!!  

Posted Images

After I was able to get players to connect to other servers, I redid my own setup and was able to get connections.

For those of you running windows 10 dedicated servers, the latest 20H update will reset some default settings you may have changed so go back to the basics.

check settings>game mode>xbox network

and verify things there look okay.

For mine it was an issue of that combined with ipv6 being disabled for the purposes of another application running on server. Once enabled and the fix was run under xbox network settings Users were able to connect. My own pc would not connect until I did a full Firewall reset to defaults and similar setting check. The only thing in common is the 20h2 update for windows. 
Hope this helps anyone with PC dedicated servers for xbox.

there are a few kb's that help with this issue for me:

  1. https://support.xbox.com/en-US/help/hardware-network/connect-network/network-settings
  2. https://support.xbox.com/en-US/help/hardware-network/connect-network/troubleshoot-party-chat
  3. https://support.xbox.com/en-US/help/hardware-network/connect-network/server-connectivity-xbox-app-displays-blocked

I've yet to hear of any disconnects and it's been over an hour

Edited by namtr0
Link to post
Share on other sites
  • 1 month later...

I've asked this same question before Ark support closed it so I'm gonna ask here. I am unable to connect to any server, official or unofficial. Whenever I try to join a server it says joining session, then loads PrimalGameData_BP about 4 times, then says Join Failed, failed to retrieve address. This has been going on since I installed Ark. I've preformed every single trick in the book including soft factory resetting my Xbox, hard shutdowns, reinstalling the game, starting another game than joining Ark again. Every. Single. Thing, doesn't work. Also, whenever I try to join my friends, it tries to join then says "Join Failed". Thank you for your time to help me with my request.

UPDATE:

I've installed Ark on PC via MS Store, and the same thing occurs, this issue has been plaguing me ever since I downloaded the game for the first time.

Edited by TheWhovian2018
Link to post
Share on other sites

I know there are a ton of topics on this, but I need help. I am constantly unable to join servers today on PC (XBOX loads fine) and always get " Could not retrieve address." I am able to join single player and host servers, but unable to join any server, official and unofficial included. I have tried every solution I could find but am unable to find a fix. I have tried modifying my security settings and firewall, though nothing has changed since everything was working fine yesterday. Anyway, any help would be appreciated.

Edit: I wouldlike to thank the moderator that threw my post on a 30 page thread with no solutions. *clap*

Edit 2: A "workaround" from 5 years ago with no real solution to the problem only emphasizes the lack of concern about a fault in the system, especially when the "solution" has not always worked simply based on reading other people's problems.

Edited by Gunmonkey0861
Link to post
Share on other sites

I play on Xbox official small tribes Genesis server 128 and today everytime I try and login I says could not retrieve address but only does this when trying to connect to NA servers I’m playing from the EU. Can anyone suggest a fix to this problem I don’t want to lose my main character.

Edited by Redeyedspartan
Add more information
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...