Jump to content

Any Fix In Sight For "Joining failed - could not retrieve address"


Go to solution Solved by Chuwalee,

Recommended Posts

  • Replies 779
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

No solution yet, but there is a work around.   Go to your network settings, hit advanced settings go to DNS and make your primary and secondary DNS 8.8.8.8

Hi, Everytime I go to join an Official dedicated server it says "could not retrieve address". After I try a few more times the game freezes and dashboards me. It does t

The changing my DNS setting worked thank u so much!!!!!!!!!  

Posted Images

On 12/20/2019 at 8:55 PM, RStrumsworth said:

Maybe so but it doesn't excuse the fact that people have had this problem for 3 years now. Half the people that started this thread have moved on I assume. I only come to check to see if anybody with any sort of authority in Wildcard will acknowledge this problem but they still dont. Conan Exiles I can log onto any server I wish, so it's for sure a Wildcard server problem.

I agree with you on the first part, three years is far too long and somethings should have improved by now......... Wildcard will not comment here, I assume and not likely the mods on here either, they're probably as much in the dark as everyone.........

Assuming again here and speaking only for myself... I don't think it will be addressed or rather fixed 100% across the board so to speak. As with everything Wildcard from my past experience with them and from what I've read, Fix's are slow in coming, historical issues seem to get forgotten about or whoever that person was who could fix the issue most likely has "moved on" too, to pastures new... If it's a huge fix they need  to do  to sort the issues out  it may never be done as it could just be too time consuming to do it and possibly from that cause more related issue's; do more harm than good......? As of 2016, Studio Wildcard is now managed by a Chinese management team from Snail games in China, this may also impact on the game too in some way but I really don't know their policy's........... Customer care these days is in decline everywhere,  all you can do is keep submitting tickets and live in hope you eventually get some kind of reply...... Good luck.

Link to post
Share on other sites
  • 3 weeks later...
On 12/20/2019 at 12:55 PM, RStrumsworth said:

ARK I have only been able to play OC servers the past 3 years(despite being in the US) and they screwed that up when they took the OC rag servers down a few weeks ago. I could play any server I wanted before the Halloween event 3 years ago. 

 

On 12/8/2019 at 8:08 AM, RStrumsworth said:

Good luck. I helped start this thread almost 3 years ago about this issue and they still havent helped me. Changing dns doesn't work for a lot of people. This is the only game I have this issue with so its definitely wildcard servers. I've only been able to play OC servers since the start of this problem(despite being on the east coast of the US) and then the turkey trial update made those inaccessible to me as well. 

I have this identical problem . Managed to get it working for a few weeks, then it quit again during the Christmas event. There isn't even a way to speak to customer service about connection problems. Ridiculous

Link to post
Share on other sites
  • Joebl0w13 changed the title to Could Not Retrieve Address
  • Joebl0w13 changed the title to Any Fix In Sight For "Joining failed - could not retrieve address"

ERROR DE CONEXION SERVIDORES XBOX

Buenas, he intentando acceder al servidor al que juego, y me saca a la pantalla de servidores indicando error de conexion, he intentado otros servidores para ver si se trataba de ese solo y me indica lo mismo en todos, son las 18:08 de España, espero lo resuelvan lo antes posible , un saludo.

Link to post
Share on other sites
28 minutes ago, Damnlag said:

Seeing how this thread was created in 2016 and has 19 pages of posts, I doubt this will be fixed any time soon. Probably why the game doesn't have many playing anymore.

I also want to add, 1/17/2020 I am having Could Not Retrieve Address errors when trying to join Xbox Official servers. 

This post was created today not in 2016 as I created it myself 

Link to post
Share on other sites

Join failed on dedicated server

It would be nice to actually play the game but I can't join a dedicated server I usually play because it says it couldn't find the address. 14 other people are on. I've tried restarting my Xbox twice. I've quit and restarted the game about 8 or 9 times.

 

"Join Failed. Could not retrieve address." NA Ragnarok 167 PVE

 

Getting really tired of this crap! Especially since there was some update yesterday that probably added more garbage we don't need!

 

WAIT..I JUST GOT IN! Oh thank goodness. 

 

Nevermind, lost/timeout connection to host.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...