Jump to content

Any Fix In Sight For "Joining failed - could not retrieve address"


Go to solution Solved by Chuwalee,

Recommended Posts

  • Replies 779
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

No solution yet, but there is a work around.   Go to your network settings, hit advanced settings go to DNS and make your primary and secondary DNS 8.8.8.8

Hi, Everytime I go to join an Official dedicated server it says "could not retrieve address". After I try a few more times the game freezes and dashboards me. It does t

The changing my DNS setting worked thank u so much!!!!!!!!!  

Posted Images

Hi all

im trying to join a non-dedicated server on the Xbox version played on a pc (I’m on an Xbox one)

however it comes up with the host connection has timed out (or similar)

any fixes for this?

no mods, NAT is open

it works when I run the non dedicated server and my partner can join that but partner wants to host it

 

any suggestions?

Link to post
Share on other sites

the windows client is a total mess, and the way the team handle things is a total joke, wildcard are the most unprofessional developers i have ever encountered in all of my years gaming they need to take a look at how they treat the player base

 

the games not in early access anymore, its a full release, and still riddled with every bug and issue it was while in development. 

a little communication with the players will go a long way... havent you learned anything this past 4-5 years?

 

Theres literally no reason to invest time into this game anymore the devs dont care. If you're as sick as me, there's a good chance you are entitled to a full refund of the base game and all the dlc's but you'll have to go through small claims court, dont worry, they'll do the work for you, i dont see any reason to let wildcard keep our money at this point

 

Edited by EazyLee
Link to post
Share on other sites

I cannot log into any official server. it says address not found on any server i have tried to log into for the last 5 hours. I have restarted my router/modem/computer and reinstalled the game. is there anything else that can be done. i have already reported it to the outage page but my tribe mates can connect so the server isn't down. it was working fine earlier then just started doing this.

Link to post
Share on other sites

I get this message when I try to log in to any server, official or unofficial. I'm still on 780.10, but the server is on 780.11. I'm playing thru the Microsoft store on PC. My brother is able to log in using his Xbox on the server, but every time I try, I get the above message 'Could not retrieve address'. 

Anyone have any solutions to this? I've restarted my router, my modem, my computer, turned off my firewall and anti-virus. Nothing has worked so far. I've tried to update the game in the Microsoft store, it says all the latest updates have been installed.

Any advice would be appreciated. Thanks, all. 

Link to post
Share on other sites
  • Joebl0w13 changed the title to Any Fix In Sight For "Joining failed - could not retrieve address"
  • Joebl0w13 locked this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...