Cymerio

Linux Bug Reports

Recommended Posts

On 8/29/2017 at 2:24 PM, TheRealestMVP said:

So, this is it. ARK is now officially released, Early Access is over. And the Linux client is still broken. Nothing has changed (again).

  • Non-US keyboards still not working properly: many keys non-functional, wrong keys displayed in options, non-ASCII keys not working in chat (like öäüß). Whistle groups (numpad) not working at all, no way to remap.
  • ...

The numeric keypad issue is not specific to non-US keyboards. All my keyboards (and my wife's, and my kid's) are US keyboards and the numeric keypad is mismapped in ARK on all of them. ARK is the only game that mismapps them. in this manner. Here's what I posted to both their customer-annoyance ignore-and-close system and to their blind post google docs pretend bug-tracking system:

Quote

In case it helps, here's what it returns when I'm in the Options screen trying to set things to use the numeric keypad (to figure out why it's not working properly): 
NumLock has no effect on the below (same result whether on or off) 
Keypad 0 results in a B 
keypad period results in a C 
keypad enter works correctly 
keypad 1 and 2 result in "Unassigned" 
keypad 3 results in "LeftBracket" 
keypad 4 results in "Backslash" 
keypad 5 results in "RightBracket" 
keypad 6 results in "Caret" 
keypad 7 results in "Underscore" 
keypad 8 results in "Tilde" 
keypad 9 results in A 
keypad /, *, - and + all result in "Unassigned"

 

Share this post


Link to post
Share on other sites
56 minutes ago, glabifrons said:

Mine has segfaulted (sig-11) during shutdown (sig-3) at least since I started back in October 2015.  Are you saying it's segfaulting at other times too?

 

It did because of a modded vehicle beeing stuck inside a modded wall, it hasnt crashed since I killed that vehicle.

Share this post


Link to post
Share on other sites
On 7/1/2016 at 8:33 AM, NotJason said:

I'd really like to have that forced lowmemory thing reversed. Could we at least have a launch argument that disables it? Anyway I came here to report bugs, but it looks like every major one I know about is already on the list.
Here are the others:

  • The game freezes at the menu for quite a while on every launch. This happens on every linux system I've seen the game on. That includes, arch/i3, mint/cinnamon, and ubuntu. I wish I could remember the precise update number when this started, but I think it was sometime between v226 and v230.
  • The state of capslock is ignored in game.
  • Key rebinds are reset every launch.
  • Voice and other sounds seem confusingly tied to music volume. If the music is turned all the way down, all of the game sounds stop.

Yes all except the sounds, is good for me, then i need to play with steam controller and xbox 360, before of 2016 i can play, but now i cannot play with steam controller and joystick 360, please fix this issue i want to play with controllers

Share this post


Link to post
Share on other sites

Su uhmm, I'm just curious...will the Linux version ever work again? I mean the game is not early access anymore and it is sold as a game for the linux platform. It does not work on Linux and I guess it doesn't work on Mac either. Anything we can do about it? I just don't want any linux-guy to buy this game and never be able to play. I made that mistake, it's clearly too late for me.

Share this post


Link to post
Share on other sites

I am wondering if they aren't acknowledging the bugs because they don't know how to fix them and they think not acknowledging them is plausable deniability in court.  (Bugs this obvious don't fall under that.)

They've already been sued once for bad support, after all.  Maybe they have some REALLY bad lawyers who think this.  (Several companies have gotten this same bad advice and done things like refused to recall merchandise that were literally killing people because it meant admitting there was something wrong with the product according to these nutcase lawyers.)


 

Share this post


Link to post
Share on other sites

Hi guys,

I finally abandoned Ragnaroc map and uploaded my player on The Center.

With my Antergos distro with NVIDIA's latest 384.69 drivers I play Ark as a windows system (the only thing is that it lags if I set shadows and textures on high, probably because my GTX780 has only 3GB). Other thing I reccomend is toggle steam overlay that causes crashes.

So I'm finally happy and can play my favorite game flawlessly!!

Share this post


Link to post
Share on other sites

I think the water issue on linux is because of using a wrong compression method for the water texture.

(in short: do not use 'Default', use 'Normalmap' instead)

As the ARK-Dev-Kit is not available for linux I can show it only with UE4Editor.
For those of you who are interested in here some steps to reproduce the water bug and then to solve it.

Open up the UE4Editor and make a new project, I used FirstPerson C++ template.
Select the ground plate and in 'Materials' section on the right set the material from CubeMaterial to M_Water_Ocean.
(now you should see a water surface on the ground plate)

In 'Materials' click Textures and select T_Water_N. Some textures should show up now.
Doubleclick on the T_Water_N texture and the Texture-Editor will be opened.
In 'Compression-Compression Settings' set method from Normalmap to Default.
(have a closer look on our ground plate, looks familiar ? :) )

Ok so far, now let's solve the problem.

Switch back from Default to Normalmap compression. (water surface still looks ugly)

Now doubleclick the cube in 'Materials'. The Material editor will open.
Beside others you should see a 'subwindow' named M_Water_Ocean. Within that 'subwindow' locate the result node
called M_Water_Ocean too.
Just rightclick that M_Water_Ocean title and wait a few seconds. (may be 10 seconds or less)

The water texture on the ground plate should be ok again.

I think that the water issue in ARK is similiar to that in my exaple.

That's all. (sorry for my bad english)

 

Edited by TuxFan

Share this post


Link to post
Share on other sites
On 9/5/2017 at 4:08 AM, SpEcIeS said:

@Jat @Jen Please take the time to review this thread and respond to these bugs. We are all getting really discouraged with the lack of attention that GNU/Linux users are receiving. :(

Throw the Mac users in with that too. Water texture is still missing. clickwheel doesn't work, dragging items is buggy, pink rain, and all the other bugs reported for the past 6+ months.

Share this post


Link to post
Share on other sites
11 minutes ago, AoiBlue said:

@Jat Please quit ignoring the Linux users.

At least admit the bugs exist. 

By not admitting the bugs exist you are even more liable for failure to test your product.

 

Not happening. Maybe they have some shady deal with Microsoft for using their platform, but that is just speculation. I think WC and Linux/Mac are done.

Share this post


Link to post
Share on other sites
On 9/17/2017 at 6:24 AM, tenten said:

Just found this

 

I don't know what it means, but at least we have an answer...

It took them 2 months to even give us a reply.

It's really sad how bad their community response is.

It kills me to see a wonderful game like Ark be ruined like this.

Share this post


Link to post
Share on other sites
On 9/23/2017 at 2:54 PM, CCRogerWilco said:

Throw the Mac users in with that too. Water texture is still missing. clickwheel doesn't work, dragging items is buggy, pink rain, and all the other bugs reported for the past 6+ months.

Mac and Linux both use the broken OpenGL stack.  They have refused to upgrade to the new one upstream in Unreal 4.  

Honestly, Windows works with OpenGL as well.  Often it works better.

Share this post


Link to post
Share on other sites

Guys, Jat acked the problems, and he also acked that they will be looking at the issues.

As I suggested: wait another month, that makes it release+2 months, and then we can pull their legs... Face it, we are a minority platform. If they raptor up the majority platform it will end bad anyway. Do they have to fix the bugs for our platform, yes of course they need to.

For now you can just rate the game for linux users as it is now... not worth the price.

@TuxFan thanks for looking into the unreal editor. Is it hard to install? I just put another intel desktop online with an old jessie installation and very old fglrx drivers. Unfortunately I can only access it from vnc, or I should try steam in home streaming 8-D.

I want to note that water in brown muddy lakes are transparent on the Island. I was really surprised to so transparent water, and yes it feels so refreshing :-).

  • Like 1

Share this post


Link to post
Share on other sites
On 9/26/2017 at 11:28 AM, DirtyCamper said:

Guys, Jat acked the problems, and he also acked that they will be looking at the issues.

As I suggested: wait another month, that makes it release+2 months, and then we can pull their legs... Face it, we are a minority platform. If they raptor up the majority platform it will end bad anyway. Do they have to fix the bugs for our platform, yes of course they need to.

For now you can just rate the game for linux users as it is now... not worth the price.

Yes. I really appreciated that bit of communication. It's still vague and noncommittal, but a few responses like that would go a long way.

I would like something a bit more clear, like: We're too busy now, but we expect to get around to the Mac/Linux version in X months, so we're planning the official release in Y months. Then I would know when to come back and start following what's going on again.

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, misha3bioshock said:

Any news here? We're really missing the blue water!

Here is a fix from the steam survietheark community:

Water surface workaround - Linux (WORKING) Mac (PERHAPS?)
Found this on survivetheark by Loki42 and it works for me:
( fixes TheIsland, for Ragnarok need to find the asset aswell it seems )


#!/bin/bash

# Enter YOUR OWN path here... !!!
cd /home/example/steamapps/common/ARK/ShooterGame/

mv ./Content/PrimalEarth/Environment/Water/Water_DepthBlur_MIC.uasset ./Content/PrimalEarth/Environment/Water/Water_DepthBlur_MIC.uasset.bak

cp ./Content/Mods/TheCenter/Assets/Mic/Water_DepthBlur_MIC.uasset ./Content/PrimalEarth/Environment/Water/Water_DepthBlur_MIC.uasset 


Edit:
Could help if MAC Users post their results as well

 

http://steamcommunity.com/app/346110/discussions/0/1519260397793942170/

Yes, that's right, we have to fix the game for ourself. Nice work, WC

Edited by tenten

Share this post


Link to post
Share on other sites
On 9/26/2017 at 5:28 AM, DirtyCamper said:

Guys, Jat acked the problems, and he also acked that they will be looking at the issues.

As I suggested: wait another month, that makes it release+2 months, and then we can pull their legs... Face it, we are a minority platform. If they raptor up the majority platform it will end bad anyway. Do they have to fix the bugs for our platform, yes of course they need to.

For now you can just rate the game for linux users as it is now... not worth the price.

@TuxFan thanks for looking into the unreal editor. Is it hard to install? I just put another intel desktop online with an old jessie installation and very old fglrx drivers. Unfortunately I can only access it from vnc, or I should try steam in home streaming 8-D.

I want to note that water in brown muddy lakes are transparent on the Island. I was really surprised to so transparent water, and yes it feels so refreshing :-).

Why would you want fglrx drivers?  Mesa is OpenGL compliant, FGLRX is not. 

They should support Mesa and AMDGPU Pro for AMD, and nVidia Proprietary for nVidia (until Mesa can catch up on nVidia performance)
Currently R400-R600 and Radeon SI all run better on Mesa than fglrx, including more OpenGL features.   For instance, fglrx on an R600 has only OpenGL 4.2 compatability, but on Mesa has OpenGL 4.5 copatability.

Currently AMDGPU Pro works with ARK (other than gray water) but Mesa does not.  

Mesa has, however, seen some notable improvements, with the lines now being all black and no longer flashing.

Edited by AoiBlue
more info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now